Language bar problem

I have added the US-International keyboard.  The language bar gives me 2 options (US-I or US).  If I select US-International, it converts to US whenever I open a new window (e.g. Thunderbird).  I then have to re-select US-I.  Is there a way to make the selection STICK? 

 

Never had this issue with XP.   ThaNKS>

 

Question Info


Last updated February 27, 2018 Views 812 Applies to:
Answer

I type exclusively Dvorak, but I occasionally have other users who invariably type on the US (qwerty) layout.

The input language setting is a per-process setting in XP, Vista, and 7.  In most cases, it's a per-window setting, but if you have Explorer set to use a separate process for each window, then each IE tab has its own language setting.  Same if you use Google Chrome.

I have added the US-International keyboard.  The language bar gives me 2 options (US-I or US).  If I select US-International, it converts to US whenever I open a new window (e.g. Thunderbird).  I then have to re-select US-I.  Is there a way to make the selection STICK? 

Yes. You'll need to set US-I as the default keyboard.  From "Settings" in the language bar's menu, you'll get the "Text Services and Input Languages" control panel window.

On the General tab, change the drop-down selection at the top from "English (United States) - US" to "English (United States) - US International" to make that the default for every window.

Regardless of which input language is default, you can switch among all the installed input languages with a keystroke which you can configure on the Advanced Key Settings tab.

If you want your current settings to be used on the Welcome Screen as well, then you'll need to use the Region and Language control panel:

  • Start -> Search for "region and language" -> Control Panel result -> Administrative (tab) -> ★Copy settings (button) ->☑Welcome screen and system accounts -> OK
  • or Start -> Control Panel -> Clock, Language, and Region -> Region and Language -> Administrative (tab) -> ★Copy settings (button) ->☑Welcome screen and system accounts -> OK

 

Never had this issue with XP.   ThaNKS>

Count yourself lucky, then. :) On the only XP system in my office, I've had to change language settings on a per-window basis because it would inconvenience everyone else for me to make anything but US the default.


Windows Genuine Advantage disadvantaged my genuine Windows. Posted from genuine Ubuntu.
Windows Genuine Advantage disadvantaged my genuine Windows. Posted from genuine Unix.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.