You'll need a new app to open this - ms-windows-store

It happened today when my start menu first stopped functioning. I tried to run PowerShell commands through the command prompt and all it has done was remove all my Windows 10 apps as well as the store. I can't even run wsreset.exe without opening Microsoft Store. Is there any way to reinstall it through some way?

Question Info

Last updated December 13, 2019 Views 157,887 Applies to:

I did the solution mentioned here

and that worked for me.

open an elevated powershell (right click start -> "command prompt (admin)" -> enter "powershell") and run the following command:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Re-run it if it gets stuck for a long time. I had to do it couple of time...



479 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.