Windows 10 Store "Server Stumbled" with error code 80072EFD

I had upgraded my windows 7 to windows 10

But when I am going to store it is showing the message "The Server is Stumbled , We all have bad days Refresh the page "

with an error code "0x80072EFD"

my internet connection is BSNL Broadband with 2 Mbps Speed still showing the internet connection is not made properly.

take a look at the screenshot what I get every time when I open the store

 

Question Info


Last updated April 2, 2020 Views 21,608 Applies to:
Answer
Answer

Hi all,

The error text "Server Stumbled" is generic, and covers multiple issues with different resolutions.

They key is the error code.  If you post about this issue, please do include the error code in the title.

Here are a few known issues with resolutions. Comments welcome.

80072EFF
Indicates that TLS is disabled, and should be re-enabled.

Solution: see below section 'How to Enable TLS'

80072EFD
Indicates a connection with the server could not be established. 

Solutions: For this we look at general internet connection settings

  1. Try the 'How to enable TLS' below.
  2. Next, check your proxy settings. An invalid proxy will prevent connections.
  3. Next, remove your internet connection, and add it back in.
 
801901F7
Indicates the Windows Update service is not running. Use these steps to re-enable it.
  • Right click Start and select Run
  • Enter services.msc and hit enter.
  • Scroll down to Windows Update.
  • If Startup Type is set to Disabled, this is the problem. 
  • Double click the Windows update to edit, and change to Manual.
  • If Startup type is already set to Manual, some users have reported that setting the Startup type to Automatic or Automatic Delayed Start fixes their issue. If you find that this latter case applies to you, please let us know so we can investigate further why Manual does not work for you.
 

Fix Server Stumbled error 80072EFF  by Enabling TLS

For a secure connection, the Windows Store uses TLS (Transport Security Layer).  On some machines, we have found that this error was caused by TLS being disabled.  Here is how to check if "Disabled TLS" is the cause of your issue. 

  1. Click the Windows start button and click Settings
  2. Click on Network and Internet
  3. Select Wi-Fi on the left navigation bar if not already on that page
  4. Scroll down and click on Internet Options
  5. Click on the Advanced tab
  6. Scroll down to bottom of the list of options, to the Security section
  7. Ensure there is a check mark next to 
     Use TLS 1.2
  8. Select Apply on bottom and then OK
  9. Re-open Store and Cortana and check if the issue is resolved. A restart should not be required.
  10. If your TLS options were all checked, try clicking the Reset button to set Internet options back to default settings.  A restart should not be required, but may be in some cases.

46 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.