Windows 10 Store occurs 0x80073CF9 when changing App Storage to any other location than C: drive

I was attempting to install a game from Windows Store.

I changed the App storage location from C: to D: in 'Settings - Storage', as the game requires at least 29GiB diskspace.

Then the store wouldn't allow me to install any app with an error code '0x80073CF9'.

If I change it back to C: , everything goes just fine.

I got UAC enabled, 'AppReadiness' and 'AUInstallAgent' folders just in the place where they should be, I've tried Store App Diagnostic Program, I've checked the system language and location settings and they are also fine. But I still got this annoying error code.

Would somebody please help?

 

Question Info


Last updated April 10, 2019 Views 1,526 Applies to:

Hi,

Thank you for posting your query in Microsoft Community. I regret the inconvenience caused to you. Let me help you

The error code 0x80073cf9 may appear also when you try to update an application to make it suitable for Windows 10. If you try to reboot the Windows 10 it might work but if you follow the tutorials posted below you will see how to permanently fix this issue and prevent it from happening again.

Sign out form the current user account, restart the pc and login to the admin account or the Microsoft account to check if that helps.

Also install any pending updates on the pc to check if that helps.  Updates are additions to software that can help prevent or fix problems, improve how your computer works, or enhance your computing experience.

Steps on how to fix error code 0x80073cf9 in Windows 10.

Method 1:

  1. Press and hold the “Windows” button on the keyboard.

  2. After you get to the start screen you will need to left click or tap on the “Windows Store” feature you have there.

  3. After you get to Windows store you will need to press and hold the button “Windows” and the button “I”.

  4. Left click on “App updates”.

  5. Left click or tap on the “Sync licenses here”.

  6. Let it do its job and reboot the Windows 8 or Windows 10 device.

  7. Try to install the app or upgrade the app and see if you still have this error message appearing.

     

Method 2:

1.      Left click on the “Desktop” icon in your start screen.

2.      Open the My Computer icon by double clicking on in.

3.      Open the partition where you have your Windows 8 or Windows 10 installed.

4.      Double click on the “Windows” folder you have in the partition.

5.      In the Windows folder check and see if you have another folder by the name of “AUInstallAgent”.
Note: If you don’t have the “AUInstallAgent” folder you need to right click in the “Windows” directory and create a new folder with that name.

6.      After you made the folder you need to reboot the Windows 8 or Windows 10 device.

7.      Check and see if you still have this issue.

Method 3:
If the issue persists,
I suggest you to run System File Check (SFC). SFC scan will scan for corrupt system files on the computer and replace them.

Use the System File Checker tool to repair missing or corrupted system files
http://support.microsoft.com/kb/929833

Hope this information helps you. Kindly post back with the updated issue for further assistance.
 
Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I know what the problem you're having is. Your Store app is unable to write data in C:\ProgramData\Microsoft\Windows\AppRepository\Packages, so you can not download any apps from the store

Here is how to fix it:

+)First, you need to take ownership the folder AppRepository on C:\ProgramData\Microsoft\Windows\AppRepository. (If you don't have the folder ProgramData, go to Folder Options, check the Show hidden files and folders option). You download the Take Ownership registry  here http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/  and follow the instruction on that site to take ownership of that folder.

+)Second, you need to give the SYSTEM account and the ALL APPLICATION PACKAGES account full control on the folder C:\ProgramData\Microsoft\Windows\AppRepository\Packages. Here's how you do it

- Right-click on the Packages folder and select Properties.

- Go to the Security tab and click Advanced.

- In the Advanced Security Settings, click the Add button

- Click on the "Select a principal" link located at the top of the window

- Type "ALL APPLICATION PACKAGES" (without quotes) in the textbox of the new window and click OK.

- Check the following permission Full control, Then click OK  

- And do the same with SYSTEM account

It works perfectly for me. I also tried every solotions on the internet but none of them worked. It turned out to be very simple, the Store app is unable to write data on the installation folder. Let me know if it works for you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.