Windows 10 store error code 0x80070002 issue. Help?

Hello windows community. In the windows 10 store, I currently have an issue in where I get the error code 0x80070002. Now I have research ways to fix this, but they are mainly for older OS like windows 03. The error code says "we can't the app" (correction from file) and then the code itself. Now I wish to get response from users who have windows 10 and/or currently have this issue. Thanks.
 

Question Info


Last updated April 19, 2019 Views 48,338 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello Megatron,

Welcome and thank you for posting your query in Microsoft Community. We appreciate your interest in Windows 10.

I understand that you are unable to access Windows store as it pops-up an error code 0x80070002. We will help you to resolve this issue.

I would like to inform that this problem occurs when some files in the Windows Update are missing, even though the update is downloaded and extracted successfully.

Method 1: I suggest you to refer to the below article about fixing Windows Update error "0x80070002" or "0x80070003" and check if it helps:
https://support.microsoft.com/en-us/kb/910336
(Applies to Windows 10 as well)

Method 2: Please try to re-register the Store App. Run the following in a Command Window (CMD) and see if it helps to resolve the issue.

    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.XML

Hope it helps. Kindly update the status of this issue, we will be happy to help you.

Thank you.

21 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Method 2 doesn't seem to apply to Windows 10 as there is no WinStore folder in the system root!

251 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I appear to have fixed my issue with the store. Here are the steps that I took:

1. Signed out of my account in the store by following step one in the instructions located here: http://www.tenforums.com/tutorials/4235-store-sign-different-account-windows-10-a.html

2. Closed the store.

3. Ran WSReset.exe

4. Logged back in to the store with the same account information.

Suddenly, everything I try to download works.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah! I just signed out of my Microsoft Account and into my local account and all of a sudden it works, but I didn't run the wsReset. It only seems to be present when you have your Microsoft Account signed in.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah! I just signed out of my Microsoft Account and into my local account and all of a sudden it works, but I didn't run the wsReset. It only seems to be present when you have your Microsoft Account signed in.

Confirmed, the problem started when I used my Microsoft Account and after changing back to my local account it worked again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

J'ai désactivé les paramètres de synchronisation. (paramètres/Comptes/Synchroniser vos paramètres) et plus d'erreur

0x80070002  !!!!!!!!!!

Pouvez-vous essayer?

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Method 1 did not work for me.  When I tried Method 2 I got the message:

Add-AppxPackage : Cannot find path 'C:\WINDOWS\WinStore\AppxManifest.XML'
because it does not exist.
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\Win ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (C:\WINDOWS\WinStore\AppxManifes
   t.XML:String) [Add-AppxPackage], ItemNotFoundException
    + FullyQualifiedErrorId : PathNotFound,Microsoft.Windows.Appx.PackageManag
   er.Commands.AddAppxPackageCommand

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

can you try the below and share the output

  • Press Windows key and 'R'
  • type powershell --- open powershell
  • cd HKCU:\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Families\Microsoft.WindowsStore_8wekyb3d8bbwe
  • dir

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Families\Microsoft.WindowsStore_8wekyb3d8bbwe]
[HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Families\Microsoft.WindowsStore_8wekyb3d8bbwe\Microsoft.WindowsStore_2015.8.3.0_neutral_split.language-fr_8wekyb3d8bbwe]
"Flags"=dword:00000004
"InstallTime"=hex(b):14,25,e9,79,39,d4,d0,01

[HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Families\Microsoft.WindowsStore_8wekyb3d8bbwe\Microsoft.WindowsStore_2015.8.3.0_x64__8wekyb3d8bbwe]
"Flags"=dword:00000001
"InstallTime"=hex(b):b1,7b,e5,79,39,d4,d0,01

I suspect that the problem I have is becauce I use my Microsoft account on different Windows (1x Win8.1 and 4x Win10) with different languages (EN-US, FR-FR,NL-NL,FR-BE)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

btw does the app work in a different account on the same machine (because that's what others in this thread mention)

The entries above look fine.. could you also check another entry in powershell and share the output

dir "HKCU:\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\Appcontainer\storage\Microsoft.WindowsStore_8wekyb3d8bbwe"

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.