Unable to move or install Windows Store apps/games to anywhere but the default C: drive

I had previously created two threads on different forums hoping to get an answer to a particularly annoying issue I have recently encountered since running low on disk space on my 256 GB boot SSD where Windows 10 Pro is installed.

The threads are here: http://forums.guru3d.com/showthread.php?t=408917

and here: http://www.tenforums.com/software-apps/56687-windows-store-error-0x80070005-when-using-different-location-c.html

I've had Windows 10 Pro installed as an upgrade from Windows 8.1 Pro since just before its official July 2015 release and since then it has been upgrading to v1511 last November and, finally, to various v1607 builds in the past few weeks to the current Build 14393.3 I am using now. I have been using a standard admin Microsoft account since Windows 8 so there have been no changes to my accounts. My PC was built in June 2013 which was when I installed a clean copy of Windows 8 Pro.

Although, Windows runs 100% stable and all games and apps work as they should with no unexpected crashes or anything like that, I've encountered issues with the Windows Store updating certain apps and games which had been installed months before and had previously been updating fine. These apps are located on my H: drive (the Storage location for apps is set to H:), which is where I have either installed them or moved them to over the months to save space on my 256 GB boot SSD. The error is 0x80070005; I believe this means "access denied". I cannot say when this issue started as I only noticed it after upgrading to v1607 via the Insider Preview and noticing I was low on disk space (however, I have restored a backup of v1511 and that too has the same issue, unfortunately).

It seems that apps and games installed on the Windows drive C:, will download and update fine and I have had no problems at all. I've also discovered that I can move these affected games and apps from H: to C: and they will also update fine. If I set the Storage location back to C: then, again, I can install new games and apps fine as they are placed on the Windows drive. So there does not appear to be an issue with the way the Windows Store works when using the default Storage location, which is C:.

Alas, once I've moved games and apps to C: to update them then I am unable to move them back to H:... or any other drive for that matter, which includes D: and E: (these drives did not have a WindowsApps folder as I have never used them for relocating Windows Store apps previously). The error I get when attempting this is, you guessed it, error 0x80070005!!!

Things I've tried to fix this issue include taking ownership of the H:\WindowsApps folder and the H:\WpSystem folder and changing the owner from TrustedInstaller to Darren and Administrators. I've even set all the accounts showing under Properties > Security to Full Control, added ALL APPLICATION PACKAGES, Everyone, Users, LOCAL SERVICE, NETWORK SERVICE... nothing works! It's infuriating. 

I did notice that the root permission for my H: drive was set to SYSTEM as are the ones for my D: and E: drive. My C: drive shows as Administrators though. Could this be the issue? What is the correct permission seeing as it doesn't affect Steam, Origin and UPlay games which are installed across my D:, E: and H: drives? I set the owner to Administrators on the root but did not take full ownership of the drive, only changed the H:\WindowsApps folder to Administrators (which did not work needless to add). 

 

Question Info


Last updated July 31, 2018 Views 2,509 Applies to:
After using Tweaking.com's Windows Repair All in One v3.9.5 tool in a last ditch effort to fix the error and completely messing up the Windows install (missing taskbar icons for Store, Xbox, Photos, etc, and Edge plus the Store opening and instantly closing), I decided to restore my backup of Windows 10 Pro v1511 Build 10586.494 from 14th July 2016. I then tried to move apps and games from C: to H: but got the same error so clearly the issue, whatever it is, was there before upgrading to Insider Preview Build 14393.

That said, I was able to set the Storage location for apps to H: and download both Forza Motorsport 6 Apex (Beta) and Killer Instinct to the H: drive once I'd uninstalled them. Thinking that I had a solution to the issue, I went ahead and upgraded straight to Build 14393 again. But, and it's a big but, I am unable to download those same games to H: under this v1607 build of Windows with Storage set to H: despite it working under v1511! I have been able to download Forza to my C: drive though, once I set the Storage location to C: but, again, I am unable to move it back to H:!

GRRRRRRRRRRRRRRRRRRRRRRRR!!!

I did some reading and found that you can move Windows Store packages via Powershell so here's what I tried:

1. Opened an elevated Powershell window;
2. Typed Get-Appxpackages and pressed Enter which then lists all the installed apps and games.
3. I found the full package name for Forza and typed Move-Appxpackage "Microsoft.APEXPG_1.3.12.0_x64__8wekyb3d8bbwe\AppxManifest.xml" -Volume H: (cut and paste from the listing to avoid mistyping it) and got this error:

move-appxpackage : Deployment failed with HRESULT: 0x80070005, Access is denied.
error 0x80070005: Creating file \\?\H:\WindowsApps\Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe\AppxManifest.xml
failed.
NOTE: For additional information, look for [ActivityId] aaf12b4c-e58c-0001-938e-f1aa8ce5d101 in the Event Log or use
the command line Get-AppxLog -ActivityID aaf12b4c-e58c-0001-938e-f1aa8ce5d101
At line:1 char:1
+ move-appxpackage -package "Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bb ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : SecurityError: (Microsoft.ApexP...__8wekyb3d8bbwe:String) [Move-AppxPackage], PSSecuri
   Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.MoveAppxPackageCommand

The error also contains a command for more info, Get-AppxLog -ActivityID aaf12b4c-e58c-0001-938e-f1aa8ce5d101 so I typed it and got this:

Time                      ID           Message
----                      --           -------
24 Jul 2016 12:08:00 pm   301          The calling process is powershell.exe
24 Jul 2016 12:08:00 pm   603          Started deployment MovePackageOperation operation on a package with main
                                       parameter: Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe and Options:
                                       ForceApplicationShutdownOption. See
                                       [url]http://go.microsoft.com/fwlink/?LinkId=235160[/url] for help diagnosing app
                                       deployment issues.
24 Jul 2016 12:08:00 pm   10002        Creating Resiliency File C:\ProgramData\Microsoft\Windows\AppRepository\306e3e3f
                                       -89d4-4bf5-a008-009a230a20a1_S-1-5-21-2433208727-1117016099-336912914-1007_1.rsl
                                       c for MovePackageOperation Operation on Package
                                       Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe.
24 Jul 2016 12:08:00 pm   607          Deployment MovePackageOperation operation on package
                                       Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe has been de-queued and is running
                                       for user DARREN\Darren.
24 Jul 2016 12:08:03 pm   10000        About to service package Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe. Setting
                                       the package state to disabled returned with 0x0.
24 Jul 2016 12:08:03 pm   462          error 0x80070005: Creating file \\?\H:\WindowsApps\Microsoft.ApexPG_1.3.12.0_x64
                                       __8wekyb3d8bbwe\AppxManifest.xml failed.
24 Jul 2016 12:08:03 pm   470          error 0x80070005: Package update failed for
                                       Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe. Re-stage package
                                       Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe.
24 Jul 2016 12:08:03 pm   605          The last successful state reached was PreStagePackagesInUseClosed. Failure
                                       occurred before reaching the next state Staged. hr: 0x80070005
24 Jul 2016 12:08:03 pm   10001        Finished servicing package Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe.
                                       Setting the package state to enabled returned with 0x0.
24 Jul 2016 12:08:03 pm   401          Deployment MovePackageOperation operation with target volume H: on Package
                                       Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe from:  (AppxManifest.xml)  failed
                                       with error 0x80070005. See [url]http://go.microsoft.com/fwlink/?LinkId=235160[/url] for
                                       help diagnosing app deployment issues.
24 Jul 2016 12:08:03 pm   404          AppX Deployment operation failed for package
                                       Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe with error 0x80070005. The
                                       specific error text for this failure is: error 0x80070005: Creating file \\?\H:\
                                       WindowsApps\Microsoft.ApexPG_1.3.12.0_x64__8wekyb3d8bbwe\AppxManifest.xml
                                       failed.

Does that help identify what the issue is to anyone who understands it please? I would be so grateful for any help as this is driving me mad. My only recourse at the moment, since a clean install of Windows or even a repair install is not possible at the moment, is to buy a larger 1 GB SSD!

Thanks in advance.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

One final thing I neglected to mention was that if I have the H:\WindowsApp folder open while trying to move or install a game with the Storage location set to H: then I can see a folder being created for it but at most it will contain one file but usually remain empty until I cancel the install from the Store at which point the folder will then disappear, presumably deleted by the Store.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

OK, so apparently I *CAN* move games from the C: drive to a FAT32 formatted USB memory stick N:, albeit the one I am testing, Oxenfree, is very slow even though it is only 3.4 GB in size. When I try to access the N:\WindowsApps folder though I get an access denied error and I am unable to even view the security permissions. Maybe that is due to FAT32 not having security permissions? All my other drives are formatted as NTFS.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What I did notice when I briefly restored v1511 of Windows 10 ahead of reinstalling v1607 Build 14393 was that while I was still unable to update apps and games that where installed to H:\WindowsApps, I could reinstall there (with Storage location set to H:) after uninstalling them and redownloading them. I started doing this for both Killer Instinct and Forza Motorsport 6: Apex (Beta) but neither completed before the Windows upgrade started (another question is why is the Windows Store so depressingly slow to download compared with Steam, Uplay and Origin but that's for another topic, I guess!!!).

However, post-v1607 Build 14393, again with Storage location set to H: (which it retained from v1511 anyway), I was unable to download either of those games as both would fail with error 0x80070005.

That does sound to me like the v1607 upgrade has someone how messed up the settings somewhere since I could redownload them to H: on v1511.

I did some reading around and while I am no expert, I understand that Windows assigns a new security ID to the user account with each upgrade/install even if you continue to use the same account. Could these SIDs be the reason why I am unable to move or install files to anywhere but C:?

Despite two threads and hundreds of people having read them, I have yet to receive a single reply, which is depressing since it makes it very hard to know what to do. I've Google-d error 0x80070005 and tried the various suggestions but they all have no affect and many of them end up completely breaking the Store and apps!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I replied to the linked forum posts, but I wanted to put my response here as well just in case some one needs it.

I also had this issue and what fixed it for me was to disable compression on my secondary drive. Actually it looks like just disabling compression for the WindowsApp folder will do as well. After that I could move and install applications without an issue to the other drive.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.