Cannot run windows store(windows 10 build 10240)

Three days ago I upgraded to windows 10 build 10240 since then I cannot open store

Things I've tried

(1) sfc /scannow

(2) reinstalling store using

Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.7.1.0_x64__8wekyb3d8bbwe\AppXManifest.xml"

(twice)

(3) wsreset

 gives

ms-windows-store:PurgeCaches

The app didn't start

none of above things worked

Here's what shows up in event viewer

Activation of app Microsoft.WindowsStore_8wekyb3d8bbwe!App failed with error: The app didn't start. See the Microsoft-Windows-TWinUI/Operational log for additional information.

Log Name:      Application
Source:        Microsoft-Windows-Immersive-Shell
Date:          7/29/2015 11:10:12 AM
Event ID:      5973
Task Category: (5973)
Level:         Error
Keywords:     
User:          WIN-***********\*******
Computer:      WIN-***********
Description:
Activation of app Microsoft.WindowsStore_8wekyb3d8bbwe!App failed with error: The app didn't start. See the Microsoft-Windows-TWinUI/Operational log for additional information.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
    <EventID>5973</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>5973</Task>
    <Opcode>0</Opcode>
    <Keywords>0x2000000000000000</Keywords>
    <TimeCreated SystemTime="2015-07-29T05:40:12.056832900Z" />
    <EventRecordID>1973</EventRecordID>
    <Correlation ActivityID="{A6AD013D-C9BF-0000-4A70-ADA6BFC9D001}" />
    <Execution ProcessID="2300" ThreadID="2460" />
    <Channel>Application</Channel>
    <Computer>WIN-***********</Computer>
    <Security UserID="S-1-5-21-760086675-1576030598-2708741165-1001" />
  </System>
  <EventData>
    <Data Name="AppId">Microsoft.WindowsStore_8wekyb3d8bbwe!App</Data>
    <Data Name="ErrorCode">-2144927141</Data>
  </EventData>
</Event>

What should I do now? I don't want to reset or refresh windows.

 

Question Info


Last updated March 13, 2019 Views 4,471 Applies to:

Hi,

I suggest you to run the PowerShell command given in the link below and check if it helps you.

Fix Store App in Windows 8.1

http://blogs.msdn.com/b/notime/archive/2013/10/21/10458031.aspx

Let us know if it helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Finally it got fixed

Here's what I did

(1)Changed owner of WindowsApps folder to my account

(2)Changed it back to nt service/trustedinstaller

And ran

"Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.7.1.0_x64__8wekyb3d8bbwe\AppXManifest.xml"(in powershell)

Store started and it had a 40 MB update.

Now everything works fine.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thankyou I did something similar and now stores working.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, I cannot do this:

"(2)Changed it back to nt service/trustedinstaller"

There is no "TrustedInstaller" user.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 NT SERVICE\TrustedInstaller

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes that worked, thanks;)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is clearly not an isolated issue, as it's affected me today too. Store just stopped working. Splash Screen shows briefly, then the app crashes. Same messages as in the original post when I run wsreset.exe.

Tried the above, but had to change the path in the command line as it said file not found. Seems the store version number had changed.

Unfortunately, Store still wont open for me after doing this.  Which is annoying, as I only finished reinstalling my surface a few days ago. Store was fine, now it's not.  :(

Windows PowerShell
Copyright (C) 2015 Microsoft Corporation. All rights reserved.
PS C:\WINDOWS\system32> Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.Window
sStore_2015.7.1.0_x64__8wekyb3d8bbwe\AppXManifest.xml"
Add-AppxPackage : Cannot find path 'C:\Program
Files\WindowsApps\Microsoft.WindowsStore_2015.7.1.0_x64__8wekyb3d8bbwe\AppXManifest.xml' because it does not exist.
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\W ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (C:\Program File...ppXManifest.xml:String) [Add-AppxPackage], ItemNotFou
   ndException
    + FullyQualifiedErrorId : PathNotFound,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
PS C:\WINDOWS\system32> Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.Window
sStore_2015.10.5.0_x64__8wekyb3d8bbwe\AppXManifest.xml"

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Ryan,

Thank you for keeping us updated.

To access the Windows Store, download and run apps, let's ensure the following settings:

  1. UAC (User Account Control) must be enabled.
  2. You need an active Internet connection and a screen resolution of at least 1024 x 768.
  3. To snap apps, you need a screen resolution of at least 1366 x 768.
  4. Make sure video card driver is updated.  

Let us try the following steps and check if it helps.

Step 1: Run the troubleshooter for Windows apps

Apps Troubleshooter

Step 2: System File Checker

System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files.

Press Windows key + X and click Command Prompt (Admin)

Type the following command and press Enter

sfc /scannow

Note: Do not close this Command Prompt window until the verification is 100% complete. The scan results will be shown after this process is finished.

Hope this information is helpful. Please feel free to reply in case you face any other issues with Windows in future.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried this but all I got was the following... Cannot find path 'C:\Program
Files\WindowsApps\Microsoft.WindowsStore_2015.7.1.0_x64__8wekyb3d8bbwe\AppXManifest.xml' because it does not exist.
At line:1 char:1

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After my fist failed attempt at this I checked and found that the folder in my computer had a different Designation... Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.23.23.0_x64__8wekyb3d8bbwe\AppXManifest.xml" but still got this result...

Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsStor
e_2015.23.23.0_x64__8wekyb3d8bbwe\AppXManifest.xml"
Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered.
error 0x80070003: Reading manifest from location: AppxManifest.xml failed with error: The system cannot find the path
specified.
.
NOTE: For additional information, look for [ActivityId] c4bc648e-32c0-0001-6387-bcc4c032d101 in the Event Log or use
the command line Get-AppxLog -ActivityID c4bc648e-32c0-0001-6387-bcc4c032d101
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\W ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : WriteError: (C:\Program File...ppXManifest.xml:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

So, still no better off

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.