Windows 10 upgrade fails with 0xC1900101-0x20017 -- Steps to Fix

If you have certain processors, especially the Intel G3258, and try to install or upgrade to Windows 10 it may fail with the error code 0xC1900101-0x20017.  This can be caused by a faulty CPU microcode update embedded in the Windows 10 installation image preventing a successful boot into Win10.  Hopefully, Microsoft will correct this in the near future. 

Actually, it seems that Win10 installs fine but it fails on its first boot into Win10 so it automatically reverts to the previous OS.  If you watch carefully when Win10 boots the first time after installation you will hear a boot beep and a boot screen momentarily flash on the screen, then immediately another beep as Windows reboots into the old OS and displays a Win10 installation failure message.  If you're connected to the Internet and select the "download updates" during Win10 installation, it's possible that Microsoft will already have posted a corrected microcode DLL to replace the faulty file during installation -- so this fix may soon be unnecessary.

In this fix we will reduce the processor to a single core and slow it to stock core speed which allows Win10 to install and boot properly with the faulty microcode update.  Since you wouldn't want to continue to run your computer in this crippled processor state, after Win10 is installed we will disable the faulty processor update so you can return the processor to full performance.  After the faulty microcode update is disabled, Win10 will then boot and operate properly at full processor performance.

Follow these steps to install Win10 and disable the faulty microcode update:

  1. Make sure you are running Windows 7 SP1 or Windows 8.1 Update, and it is properly activated.
  2. Prepare for the upgrade by downloading the correct image file using the Microsoft Download Tool on the Windows 10 Upgrade page, either as an ISO or to a USB.  If you're running Win8.1, it's easiest to just save the ISO to your desktop and double-click it to mount (but don't mount it yet).
  3. After having your update file ready, this is Critical-- Boot into BIOS, disable all but one CPU core and disable any overclocking.
  4. Reboot
  5. If Win8.1, just double-click on the ISO to mount it.  If Win7, burn the ISO to a blank DVD (or use your favorite mounting utility), then open the DVD in Windows Explorer (for an upgrade, do not boot to the DVD or USB).
  6. Run Setup.exe from the root of the ISO or USB to install the Win10 upgrade.
  7. After the update to Windows 10 has fully completed and is stable:
  8. Using Windows Explorer, go to the folder: c:/windows/system32
  9. Right-click on the file: mcupdate_GenuineIntel.dll
  10. Select Properties
  11. Select the Security tab
  12. Click Advanced button (near bottom)
  13. Advanced Security Settings should appear
  14. Click on Change (next to Owner)
  15. Select User or Group window should appear
  16. Type your user name in the Enter the Object Name box
  17. Click the Check Names box to select the corrected user name
  18. Click OK all the way out
  19. Right-click on mcupdate_GenuineIntel.dll again
  20. Select Properties
  21. Select the Security tab
  22. Click Advanced button
  23. Click Add button
  24. Permission Entry window should appear
  25. Click Select a Principal
  26. Type your user name in the Enter the Object name box
  27. Click the Check Names box to select the corrected user name
  28. Click OK
  29. In Permissions Entry window, select Full Control
  30. Click OK all the way out
  31. Rename mcupdate_GenuineIntel.dll to mcupdate_GenuineIntel.dll.BAK
  32. Reboot the computer to verify it is working okay.
  33. Reboot into BIOS and re-enable all CPU cores.
  34. Reboot into Win10 and verify it is working okay.
  35. Optional -- Reboot into BIOS and overclock the CPU as desired.
  36. Reboot and enjoy Win10 and your full processor's power!

In response to the concerns that this fix might break Win10 in some way, the microcode update affects only the processor. You have only one model of processor, so if the microcode update for your processor is defective and disabling the defective update solves the problem, then this is the probably the best and only solution until Microsoft corrects the microcode update file.  This should be easy for MS to do by installing a corrected microcode update file with a simple KB update pushed through online as they would any other regular weekly OS update.

BTW, my system has UEFI BIOS and my drive is formatted NTFS so conversion to GPT is not required for the Win10 update as some have suggested.  NTFS vs GPT does not appear to be an issue.

Some motherboard manufacturers have posted a BIOS update which allows Win10 to be installed on processors with the faulty microcode update issue, but many users report that the BIOS update breaks the ability to overclock.  In this case you might need to revert to the previous BIOS version and apply the steps of this fix.

After spending many hours trying to figure out this problem, I finally called Microsoft Partner Support for help.  During the hour I waited on the callback, I tried downgrading the processor to its most basic level by disabling all but one core and slowing it to default -- the install completed successfully.  Then during another hour on the phone with the technician, during the times I was put on hold while he could research the issue, and going by the clue that the processor was somehow involved in the failure to boot, I found the microcode update file and tried disabling it -- and it worked!  When the MS technician returned I told him that I had figured out what appeared to be a fix.  He took some notes and asked me to please post this fix on the Community Forum so it might help others.  So, I returned the system to the starting point (all cores active and Win10 would not load), then wrote down the steps above as I performed them ... and it worked again without a hitch!

Edit:  I hear that others have also figured out and posted a similar fix in around the same time-frame, and this is only natural -- it is Scientific Determinism in action.  I'm not looking for credit, I'm just trying to help others avoid pulling out their hair as I had done.

If this fix solves your problem, please click on the recommend ("Me Too")  button below to bump this discussion up in the search results so more people with this problem can find it.  Thanks.

 

Discussion Info


Last updated May 25, 2019 Views 14,015 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Could someone from Microsoft comment on the consequences of disabling mcupdate_GenuineIntel.dll?

I applied this same fix on my desktop (AsRock MB + Pentium G3258) and the issue seems to be resolved.  If this fix breaks something in Win10, I can't tell.

It would be nice to have MS weigh in as suggested and let us know what the impact of this fix is.

Dave H.

I Have done this with a custom built pc and the intel pentium g3258 and this completely works. I have a Gigabyte P85-D3 Motherboard and at first i thought this was the problem. Lots of research brought me here to this page and all I have to say is thank you! I will update if there are any problems going forward. hopefully there aren't any!

Update:

So, for anyone with a gigabyte motherboard who is having this problem they have released an update for the bios to solve this issue. i found that after using this method, i could not go ahead and do a clean install, or reset the pc. upgrades were also a problem. But after i flashed the new bios update, no more problems. if you are still having this problem of updating to windows 10, PLEASE PLEASE check your motherboard manufacturers website for a bios update as this will most likely solve this problem as windows 10 has been out for some time now.

WORKED 100% FOR ME !!!!

I've been trying to install 64 bit Win 10 for past 3-4 days. I never thought this was a problem with processor.

I had initially upgraded from a 32 bit Win 7 ultimate to 32 bit Win 10 pro without any problems with the same processor. But when I tried to upgrade from a 64 bit Win 7 Ultimate, this began to happen.

Most of the higher end BIOS are also giving new versions, but mine didn't. I'm hoping they will soon...

GA B85M D3H rev 2.1

26/08/2015

  Wow!! They released new update for my bios with

  1. Update CPU microcode for win10 support with Pentium AE

 Going to flash it... Love Gigabyte..!!!

If you plan to overclock your CPU, don't install a bios that includes the "microcode 19" update from Intel since this will disable overclocking the CPU cores, although the memory can still be overclocked. Until MS fixes the issue the best resolution seems to be renaming mcupdate_GenuineIntel.dll.

Dave H.

I have just tried this and can confirm that it works!

Am now running windows 10 on G3258 with Asrock H81M-HDS. The new BIOS from Asrock completely removes the overclocking ability.

From further reading it seems that Intel has a problem with people overclocking the CPU on non-Z chipset motherboard, and so pushed out a mirocode update to prevent this. I don't think people with G3258 on Z97/Z87 chipset have experienced similar problem?

I have a Gigabyte mother board and dual Intel Pentium G3258 3.20Ghz x64 system running Windows 8.1 a desktop PC built from parts.  I started trying to upgrade on July 31st.  I finally succeeded last week.

Disabling a cpu from msconfig.exe doesn't work. It has to be done in the BIOS as stated.  I removed my USB wireless mouse and wireless keyboard and plugged some old serial keyboard and mouse.  I earlier created a media disk DVD with the windows ISO, uninstalled my Norton antivirus, did a clean boot with disabled start-up items.  I ran the media desk and for the first time in a MONTH I got to 95% on the windows upgrade.  I elected not to download the windows updates since I already tried that once with no improvement in results.  I pulled my Ethernet connection for the upgrade.  At 95%, I went to bed and the next morning I had Windows 10.  Big celebration!!!!!!!  At 95% the Win10 upgrade program is backing up the hard drive files that you want to keep.  So...it can take a while, a LONG while.  If you can, you might want to reduce the stuff you have stored on the hard drive, esp. pictures and videos.  I had everything backed up but not removed.

I followed the directions for editing the mcupdate_GenuineIntel.dll and did a boot.  Everything was fine!  Booted to the BIOS and turned my other cpu and proceeded to full start up and all was well.  Ran msconfig.exe and returned to a normal boot, enabled all the start up items, removed the serial input devices and plugged in my wireless devices and booted again, and I am satisfied that this ordeal is finally over.  Norton re-installed with no issues.  Windows updated itself from that point on and no problems have showed up.

As I understand it, MS has released its last upgrade with Win 10.  Good...don't want to do this again anytime soon.  During this process I had 80072EFE, 8020002E, 8024402C, 8020056 and finally a C1900101-20017 error code to deal with before I found this solution.  I had corrupted or damaged windows update files that required me to find and install a fix from MS.  I received a error report from the troubleshooter showing a RootCause:  RE_DataStore,  ErrorCode: 0x80070057 which gave me no clue.  At one point I did a restore of my 8.1 software and spent a day installing updates.  Later on I did a "refresh" of 8.1 to recover from a bad update experience.  After that, everything I tried was preceded by establishing a restore point until I found the forum discussions about the suspected G3258 cause.

I want to thank the geniuses that mapped out this solution. 

This fix worked for me, thanks! I'd managed to get Windows 10 installed by dropping my overclocked g3258 back down to 3.2ghz, figuring I'd just bump it back up after install. Ended up stuck in boot loop others have mentioned. Followed these instructions then bumped back up to my previous overclock settings, booted up like normal. Yessssss! Disappointed to have to do this, but happy to find a workaround! Kudos!

HELP please!!

I have an Acer Aspire 4740G laptop with Intel I5 processor (4 cores) and 4MB RAM.  The Acer BIOS is simple in the extreme - there is no option to disable any of the cores. 
Windows 7 SP1 is installed and is complete with all current updates.  It is a recent "clean" installation, activated, and with no other software loaded.  It is not overclocked.  Only the native Win. 7 drivers are installed (no Acer drivers).
My BIOS version is 1.10 (dated Nov 2010) and is the latest version listed on the Acer support website.  Acer is notoriously slow with BIOS updates - I do not expect them to update this BIOS anytime soon, if at all.

The Win. 10 update site indicates that the 4740 laptop has specifications suitable for upgrade.  In fact it was working well with Win. 10 loaded during the earlier stages of the Windows 10 insider program (but not the later stages).

All ideas will be appreciated.

My computer is an HP Compaq 8100 Elite Convertible Minitower; I was running Windows 7 Professional 32 Bit; and was trying unsuccessfully (numerous tries) to install Windows 10 Professional from Microsoft Update.

Each attempt would terminate with the C-1900101-20017 error; and the machine would revert back to Windows 7

What finally worked for me was to restore the machine to the 'original condition,' which included going back to the original 2 GB RAM installation it came with.

When I did this, Windows 10 installed OK as a Microsoft Update; and then I re-installed the 4 GB of RAM again.

I believe the RAM was the direct issue in my situation which was preventing Windows 10 from installing; and RAM upgrades are quite common so this might be something to check on first......

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.