Question

Q: windows 10 setup cannot start because wdsutil.dll is missing from computer

i am using windows 8.1 single language . After downloading windows 10 using media creation tool into a USB drive it give me this error . however my system is completely updated and i am using a genuine version of windows too. kindly help me figure out the problem.




Hi Nishant, 

Thank you for posting your query on Microsoft Community.

I understand your inconvenience. Don’t worry. We will assist to resolve this issue.

DLL ("dynamic link library") files such as wdsutil.dll are small programs, similar to EXE ("executable") files, which allow multiple software programs to share the same functionality.

Follow the below steps and check if it helps:

Method 1: Manually Register Wdsutil.dll Using Microsoft Register Server

How to re-register wdsutil.dll from an elevated command prompt:

  1. Right click on the Start button and select Command Prompt (Admin).
  2. You will be prompted with a permission dialog box.
  3. Click Yes.
  4. Type the following command: regsvr32 /u wdsutil.dll.
  5. Hit ENTER. This will UN-REGISTER your file.
  6. Type the following command: regsvr32 /i wdsutil.dll.
  7. Hit ENTER. This will RE-REGISTER your file.
  8. Close the command prompt window.
  9. Re-start the program associated with wdsutil.dll error.

If the issue persists, try the next method.

Method 2: Update Your PC Device Drivers

Wdsutil.dll errors can be related to corrupt or outdated device drivers. Drivers can work one day, and suddenly stop working the next day, for a variety of reasons. The good news is that you can often update the device driver to fix the DLL problem.

So I would suggest you to update all your drivers and check if it helps.

Method 3: Run SFC scan.

What is SFC (System File Checker)?

System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files.

Follow the steps given in the below article to perform SFC scan:

https://support.microsoft.com/en-us/kb/929833?ppud=4&wa=wsignin1.0

Try the above suggestion and let us know if it helps. For further assistance feel free to post your queries in Microsoft forums. We will be glad to assist you.

Thank you.   

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


hi,

i adopted method 1 to solve my problem but it returned the following error:

what could be the possible reason.

Method 2:

i am using sony vaio fit 15e (svf1521ksnb) notebook pc. the update utility provided by the manufacturer says that the drivers are up to date and there is no need of updating them. however my pc model has discontinued production , but the after sales support still remains , right? .

Method 3:

deploying method 3 gave me this report:

i dont know what to do now. guide me please

Did this solve your problem?

Sorry this didn't help.

7 people were helped by this reply


Hi,

I am also getting the same errors from method 1 & 3. For method 2 all my devices are already updated. In Method 3 I tried to correct the corrupt files, the result is still same. Is there any tools to rectify wdsutil.dll error ? 

Not to forget mentioning, after click OK in the wdsutil.dll error box.. it shows another error message says: "autorun.dll could not be loaded or is corrupt. Setup cannot contimue. Error Code is [0x7E] "

Did this solve your problem?

Sorry this didn't help.

329 people were helped by this reply


hi.  I had exactly the same problem.   I tried the same solutions as you and also got the same results...  I spent hours tying to fix it.   doing sfc scans and even trying to replace the wdsutil.dll.

I then retried the upgrade process and instead of selecting the create usb option I chose the "upgrade now " option.   it worked fine and I now have windows 10...

this got me wondering why it didn't work before.   I tried the usb I had created on my other pc and it also brought up the same errors.   this seemed very strange so I searched a bit further..

if you look on your c drive you should have a folder called $windows.~WS     (its probably hidden so you might have to enable hidden folders to see it)   this is the temporary folder windows 10 gets downloaded to.    hopefully you still have it.  inside is a folder called sources and inside that is another folder called Windows.   that's all the files that get copied to the stick.   if you double click the setup.exe thatll run the upgrade process right from your C drive.     you can cancel it at the first step so you can safely click on it to test it.      you can also copy everything that's inside the windows folder onto a usb stick and it will work from there too..       when I tried it from my C drive the upgrade process worked.  when I copied it to my stick it failed and I got the wdsutil.dll error like before.     I found an old usb stick and everything copied to it fine and worked just like it did from my c drive.    turns out the stick I was using was faulty!   so was nothing to do with the wdsutil.dll at all.   lol.

Did this solve your problem?

Sorry this didn't help.


hi, I had the same errors.  see my response below.   hopefully it helps..

Did this solve your problem?

Sorry this didn't help.


hi guys !!!

the problem got fixed when i re-downloaded the iso image and it now works fine..... the error here is only because of corrupted files present in download. re-downloading helped me , might help you too. again windows 10 removes all your previous drives and support software provided by your pc manufacturer so taking a backup is advisable, but there are some drivers which wont work with the latest windows 10 . i recommend you waiting for the update which will come from update utility.

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply


error related to autorun is because your antivirus is blocking the autorun files from running , you can change that in your anti-virus software settings.

Did this solve your problem?

Sorry this didn't help.


how to fix this problem?  ( 0x7E)

my win 7 ultimate ... asus 

please  wrhite my Answer by persian or arabic lang

Did this solve your problem?

Sorry this didn't help.


 
Question Info

Views: 17,994 Last updated: June 23, 2018 Applies to: