Windows 10 Media Creation Tool Error: 0x80042405 - 0xA001A


Recently, I have seen many people inquiring about this error regarding the Media Creation Tool. I myself got this error when I try to create a bootable USB drive (aka Create an Installable Media).

Here's what I tried:

Reformatting USB drive to FAT32

Deleting files

Tried to locate and run Setupprep.exe (I couldn't find this file in C:\\$Windows.~BT\\Sources or anywhere)

Change Startup Type of Update-Related Services (Startup Type: Manual -> Automatic)

Uninstalled and Reinstall Windows 10 Media Creation Tool

Made sure my USB is above 8Gb as instructed by the tool (it is 15Gb)

The Fix (for me at least):

1. Download the Windows 10 Media Creation Tool directly into the USB drive that you want to use as a bootable device (meaning you download the Tool into the same USB you chose to use as an Installation Media). If you already downloaded the tool on your PC's Desktop, copy it into your USB.

2. Run the Tool directly from your USB, meaning you open File Explorer, locate the MediaCreationTool.exe in your USB and double-click to run it.

The installer should then create an Installation Media/Bootable USB.

Hope this helps!



* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Not sure why, but the suggested fix worked for me, too. Thanks!
It did not work for me.

This worked for me.

Thank You

Good work Thomas TKH - worked for me. Thanks!

Per Tom's suggestion, I tried loading the MCT onto the drive on which I want to store the bootable image.  It's an 8 GB dual layer DVD drive that formatted the disk as UDF (Universal Disk Format) when I said I wanted it to be a R/W USB device.

MCT successfully downloads and verifies W10, then hangs at "Creating Windows 10 Media - Progress 29%" for a while, then moves on to 50%, briefly hangs and then displays error code 0x9031004A-0xA001A.

Any additional suggestions would be appreciated!

When I read this I laughed! What hair brained idea was this!? What buffoon posted this cockamamie suggestion!

....BUT! it worked....  :)

  No more error, no idea why but it worked! 

Microsoft should have it fixed by the time Windows 25 is released *giggle* (Just kidding Microsoft, don't melt my face)

Thanks Thomas, you're brilliant!  @KolbyPanda

This post was created with 100% recycled electrons.

I got around this by creating an ISO image instead.  No bootable image, but I can certainly reinstall if I run into trouble.

it work! Thank you!

Didn't help :/

Used a 64GB USB

Formatted the drive (FAT32)

Copied the Windows 10 Media Creation Tool onto the USB

Ran as Administrator

Abracadabra.... it worked.

Thanks for the suggestion.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.


Discussion Info

Last updated November 27, 2020 Views 433,151 Applies to: