Customized cultures cannot be passed by LCID, only by name. Microsoft Web Platform Installer 5.0 error

I can't install Azure SDK update and some other tools like SQL CE4.0 because it requires Web Platform Installer, which doesn't want to install on my system.

 No idea what to do about this error, have tried changing Region and Language settings to UK/US but no results whatsoever ;/


 

Question Info


Last updated September 16, 2019 Views 2,800 Applies to:
Hi,  

Thank you for posting your query in Microsoft Community.

I understand your concern, and we in Community will try to help you in the best possible way we can.

I suggest that you perform the methods below and check if it helps resolve your issue

Method 1:  Safe mode.

  1. With the Windows Startup Settings screen (formerly advanced boot options) you can start Windows in different advanced troubleshooting modes so you can find and fix problems on your PC.

  2. To log in safe mode, run command (press windows logo button+R) and type “msconfig”

  3. A pop-up window will open and click on boot tap and select safe mode with minimal as option

If the issue does not arise here move to method 2.

Method 2: Clean Boot.

Try Clean Boot and check if it helps.

https://support.microsoft.com/en-us/kb/929135

(Applies to Windows 10)

Method 3:

I would suggest you to check the compatibility with window 10 compatibility center from the below link.

http://www.microsoft.com/en-us/windows/compatibility/CompatCenter/Home

Hope the information helps. Please let us know if the issue persist and we will be happy to assist you further.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for replying, but that unfortunately didn't work, i get the same error when i try to install it even in Safe Mode with all unnecessary services/processes disabled. No idea what to do about it ;/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved it by changing Windows' regional settings. Instead of "English (Europe)", I used "English (United States)". Others have reported similar behaviours with changing for example from "Russian (Ukraine)" to "Russian (Russia)", etc.

18 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was using Region format Portuguese (Angola) and had this same error, just changed it to Portuguese (Portugal) and the installation went smoothly.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I solved it by changing Windows' regional settings. Instead of "English (Europe)", I used "English (United States)". Others have reported similar behaviours with changing for example from "Russian (Ukraine)" to "Russian (Russia)", etc.

Thank you so much!!!! I love you!!!! :D :D :D

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.