Question

Q: I don't want Windows 10 - I've even deliberately not installed the KB3035583 yet I've still got the notification

Hi.

I'm getting pretty sick of this stupid notification. Stop trying to force me to get Windows 10, I'll get it when and if I want to! This is turning out to be worse than those **** "Your anti-virus subscription is out of date" notifications you see on PC's that are full of bloatware that was never removed after the PC was purchased. 

I recently reinstalled 8.1 and I've hidden the update yet the thing has somehow sneaked in. It's getting really annoying. I can't even hide the icon because you guys have designed it to reset it from "Hide icon and notifications" to "Show icon and notifications" every single time I log in. That's a bit unfair isn't it, are you trying to put me off Windows 10 already?

See, it's not even installed yet its sneaked in anyway, what's all that about?!

Can someone please explain why the update is allowed through despite me not allowing it in Windows Update? It sets a pretty dangerous precedent if Microsoft can force updates through like that now, as we all know occasionally an update will brick a machine. Note I'm running 8.1 Pro as well.

How do I get rid of this thing?

Answer

A:

Hi,

Thank you for posting in Microsoft Community.

I suggest you to disable/ Hide the update and see if it helps.

Method 1: Using Group Policy Editor (gpedit.msc)

1. Press "WIN+R" keys together to launch RUN dialog box and type gpedit.msc and press Enter. It'll open Group Policy Editor.

2. Now go to:

Computer Configuration -> Administrative Templates -> Windows Components -> Store

In right-side pane, double-click on "Turn off the offer to update to the latest version of Windows" option and set its value to "Enabled".

It'll immediately disable the Windows 10 free update notification in Windows 8.1.

METHOD 2: Using Registry Editor (regedit).

1. Press "WIN+R" keys together to launch RUN dialog box and type regedit and press Enter. It'll open Registry Editor.

2. Now go to following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft

3. Create a new key under Microsoft key and set its name as WindowsStore

So the final key path would be:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsStore

4. Select Windows Store key and in right-side pane, create a new DWORD DisableOSUpgrade and set its value to 1

5. Close Registry Editor and log off or restart Windows to take effect. It'll completely turn off Windows 8.1 update notification.

If you want to restore the notification in future, just delete the DWORD or set its value to 0.

METHOD 3: Another Registry Editor Fix.

If the above mentioned methods don't work for you, try following method: 

1. Press "WIN+R" keys together to launch RUN dialog box and type regedit and press Enter. It'll open Registry Editor.

2. Now go to following key: 

HKEY_LOCAL_MACHINE\SYSTEM\Setup\UpgradeNotification 

3. In right-side pane, look for UpgradeAvailable and change its value to o 

4. Close Registry Editor and log off or restart Windows to take effect and you'll get rid of Windows 8.1 update notification. 

To restore the upgrade notification in future, just change value of UpgradeAvailable to 1 again. 

Registry disclaimer

To do so: Important this section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

How to back up and restore the registry in Windows

http://support.microsoft.com/kb/322756/

Hope this information is helpful, if not let us know with the updated status and we will be happy to assist you further.

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 6617 Last updated: November 27, 2017 Applies to: