How can I get Cortana to work on start-up without fiddling every day?

Cortana has never worked without intervention other than on day 11. Every other day (today is day 13 of my Windows 10 experience) it has required some manipulation (here is my experience so far). During this time I have made no changes to the system settings other than whatever Microsoft pushes with its updates, and one Nvidia driver update.

The latest is the experience I had on the evening of day 7 and day 12, and my instincts tell me that this is Cortana’s latest behaviour.

I have two microphones: one built in to my webcam (the default) and an external headset with mic. Cortana does not respond on start-up until I plug in the headset and then pull it out. Only then does Cortana hear me through the webcam.

No other program requires this: they all work as they always did.

The webcam mic is the default.

How do I get Cortana to recognize the microphone the same way as every other program (Skype, Audacity) does?

 

Question Info


Last updated December 30, 2017 Views 93 Applies to:

Hello Jack,

Thank you for contacting Microsoft Community.

Regret the inconvenience you have experienced. Suggest you to try with the below mentioned steps and check if it helps. Before doing that, type Setup Mic into the search bar and select the same from the list. Follow the on-screen instructions to set up the Mic again for Cortana. Once you done with it, check if the problem still appears. If it does, then continue with the below troubleshooting steps.

Method 1:

Set desired Mic as default

* Go to system tray, right click on the Speaker Icon and select Sounds, then a new window will open up.
* In the new windows click on the "Recording” tab and right click in the window and click on Show Disabled devices.

* Click and highlight the microphone you want to set default and click on "Set as Default" device.

Now reboot your PC and see if it works fine.

Method 2:

Uninstall and reinstall the Audio driver through Device Manager.

a) Open run command by pressing Windows key + R and type “devmgmt.msc” (without quotes) and hit Enter.

b) Spot and expand the “Audio inputs and outputs”.

c) Right click on the High Definition Audio Device driver and select “Uninstall” then restart the system and let the system install the driver automatically on Start. Check and see if it resolve the issue.

This action will uninstall and reinstall the audio drivers freshly on your PC. By doing this will erase the previous preference that are saved for Mic settings before. Again try the steps that are suggested in the Method 1, to see if it resolve the issue.

Keep us posted if you require further assistance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you, Yashwanth.

I’ve gone through your suggestions and it hasn’t made a difference to Cortana, although one different behaviour after rebooting is that no sound applications (e.g. Audacity, Skype) work until I plug in an external mic, then pull it out.

Only on pulling out does my webcam mic pick up any sound.

The webcam mic is the default, as it was in Windows 7, and it is correctly listed as such in the recording devices.

The good news is that the bug is consistent across all devices that require sound, though it is still annoying that one has to employ this plug-in, pull-out technique to get the default mic to work.

Jack Yan
jackyan.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I apologize for the delay in response.

Check installing the driver in the compatibility mode.

I would suggest you install the latest driver from NVIDIA  and other audio/sound drivers for Windows 10.

If there no drivers available for Windows 10, download the latest driver from the manufacturer’s website and try installing it in compatibility mode. Compatibility mode runs the program using settings from a previous version of Windows.

Follow these steps to install the drivers in compatibility mode and check if that helps.

a. Download the driver from the manufacturer’s website.

b. Right-click on the driver setup file and click on ‘properties’.

c. Click on the ‘compatibility’ tab and check the box ‘Run this program in compatibility mode for’ and select Windows 8 operating system from the drop down menu and proceed with the installation.

d. Once this is done, restart the computer and check if the issue persists.

You may also refer: Make older programs compatible with this version of Windows (Steps applies to Windows 10).

Let us know if you need further assistance. We will be glad to help you further.

____________________

Thanks & Regards,

Isha Soni

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Isha: my Nvidia drivers are definitely up to date, and Windows reports that all my audio and sound drivers have no updated drivers from the ones already installed.

The Nvidia driver won’t give me the option to install manually as everything comes in through GeForce Experience.

I will, however, attempt to download the driver to the Logitech webcam, which should be the default.

Jack Yan
jackyan.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Thanks for the update.

I understand all the drivers are up to date. However we have to diagnose the issue by checking them compatibility mode.  All you have to try is to install the driver in compatibility mode and check the result.

Please post back with the results. We will be glad to assist you further.

______________

Thanks & Regards,

Isha Soni

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Isha, it really has made no difference what mode I install in.

This thread may be a clue:

http://answers.microsoft.com/en-us/windows/forum/windows_10-win_cortana/hey-cortana-stops-working-needs-to-be-re-enabled/38b6f67f-903e-433c-bc7f-a403ab0711c9#LastReply

What Mwewe wrote on December 30 might be the reason.

However, it is rather worrying that Windows 10 keeps forgetting what the mic settings are. It does appear that after a restart or a sleep cycle, we’re back to square one.

I buy a computer so it remembers stuff, but it seems Windows 10 is as forgetful as a human!

Jack Yan
jackyan.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.