"Task scheduler service is not available."?!

After the (Windows 10 Pro) Anniversary Update, I saw one of my scheduled tasks hadn't been run in a day or so (it needs to every 30 mins). So I tried to run it manually, and it said "Task scheduler service is not available. Task scheduler will try to reconnect to it." Wut?! So, I checked (in Services) whether the Task Scheduler service is even running; and sure enough it is.

Kinda stumped here. The task's 'history' (as usual) tells you absolutely nothing, either. Anyone any ideas?
 

Question Info


Last updated July 8, 2019 Views 3,856 Applies to:

Hi,

I would suggest you to place the computer in clean boot and then start the Task Scheduler service.

a.     Type “services.msc” in start search box and press enter.

b.     Locate the Task Scheduler service.

c.      Open the Task Scheduler service and click on “Start” button.

d.     Set the Startup type to “Automatic”.

e.     Click OK.

How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows.

http://support.microsoft.com/kb/929135   

 Note: After troubleshooting, make sure to set the computer to start as usual as mentioned in Step 7 in the above KB article.

Hope this information helps.

Regards,

Guru Kiran

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I didn't make it sufficiently clear, it looks, but the Task scheduler service actually *is* running just fine, and other tasks are being run as well. Only on the 1 specific task it says "Task scheduler service is not available" (for no apparent good reason).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem after the Anniversary Update.  Same as meimeiriver2, where it is just 1 task.  Task Scheduler is certainly running, as many other tasks execute normally as before the upgrade.

I narrowed down the problem a little bit.  This particular task was set with the condition to "Start only if the following network connection is available" and to a specific network.  When I change that condition to "Any connection", the task runs normally again on its usual schedule.  Change the setting back, and the "Task scheduler service is not available..." error returns.

I have tried an assortment of the usual Task Schedule problem solutions: Run only when user is logged on (both variations), Configure for... previous Windows versions, making sure the password is correctly set, etc.  Nothing makes a difference if a specific network is selected.

Being suspicious, I check similar tasks on 2 other systems - they all have the identical problem.  And changing to "Any connection" allows the task to run again.  Problem is that the specific network is a required condition for this particular Task.  So I really want to find a work-around.

Any ideas or suggestions?

One suspicion:  is Task Scheduler mistakenly trying to run the task as if on a remote system?

36 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I reached the same conclusion as you, on the 'other' MS forum:

"Task scheduler service is not available" on specific task

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just spent quite some time figuring this out.

The error "Task Scheduler service is not available. Task Scheduler will attempt to reconnect to it"  seems to come up for any choice of networks except "any connection".

I'm not sure if the whole detection mechanism is broken or that this error message is simply a bad way of telling the user that the required network is not available at the time that I want to run it.

However, when I choose the domain network I'm now connected to, the error happens as well.

So it seems like we will have to implement checks in the scripts we are triggering, which might be the most robust way anyway.

Only make sure you save the scripts locally on the computer... :)

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also have run into this problem.  Finally let my system upgrade to Anniversary edition the other day and my backup task stopped working.

I've tried quite a few things - including rebuilding the task from Scratch - to no avail.  The only solution is to set the network to either not required or Any Connection.  Not ideal as I don't want the task to run through wireless if the wired connection is down...

Joseph W. Leathlean

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same here, I removed the condition specific network.

Not ideal...

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 "And changing to "Any connection" allows the task to run again.  Problem is that the specific network is a required condition for this particular Task.  So I really want to find a work-around."

Definitely looks to be a bug with the "Start only if the following network connection is available" option..

As soon as I untick this option the task works. Very annoying as I too would like to use this. FYI I am using Windows 10 1702.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.