Stop windows from defragmenting my SSD!!!

Hello,

I have an SSD and had disabled scheduled defragmentation.

Today I opened "drive optimization" only to find that scheduled defragmentation has re-enabled itself most likely after a windows update.

As a result of this my very expensive SSD has been defragmented God knows how may times!!!!

So not only is stupid windows not smart enough to automatically disable scheduled defragmentation on SSD drives, but even after I go through the trouble of disabling it I still have to watch over it like a hawk to make sure stupid microsoft doesnt mess it up again.

And when stupid microsoft ruins my drive will they pay for it? - NO!!!!

Please start wring your stupid software properly so it at the very least vaguely reflects its outrageous price!

Hi Bob I get this all the time when I teach the Windows 10 course and I will tell you what I tell my students.
Yes, Windows does put all your drives even if they are SSD in the Weekly defrag schedule.
However, Windows will NOT defrag an SSD weekly, at the most it does this once a month. And you are right that SSD drives don't get fragmented as often but they still can get fragmented. So the defrag utility will first check to see if if requires a defrag before defraging. It actually does that on all types of drives.
And for SSD drives it doesn't do the same "traditional defrag" as with HDD drives.
It actually uses a TRIM feature to defrag SSD drives.
So you don't need to disable it all. I have a laptop that has a SSD drive and it has been running Windows 10 for 2 years with defrag enabled it is absolutely fine.

I hope this helps. Take care.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

According to this post by Microsoft's Scott Hanselman, it should not do any harm:
http://www.hanselman.com/blog/TheRealAndComplet...

It likely is enabled because you have the Volume Shadow service enabled and or you are using System Restore.
Best,
Andre
Windows Insider MVP
MVP-Windows and Devices for IT
twitter/adacosta
groovypost.com

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 11, 2020 Views 7,999 Applies to: