Programs Can't Be Opened and/or Uninstalled After Updating Windows (KB 4560960): "Windows cannot find *.exe. Make sure you typed the name correctly, and then try again."

So, last night I was checking for updates using Windows Update, and (unfortunately) I decided to update my Windows 10 Education. There were two updates:

and I just instinctively installed them.

This afternoon, I was trying to open Remote Mouse (a third-party app) via desktop shortcut. Nothing happened, so I tried a few times. Then I tried opening the executable file directly in the install directory. That's when Windows gave me this message: "Windows cannot find 'C:\Program Files (x86)\Remote Mouse\RemoteMouse.exe'. Make sure you typed the name correctly, and then try again."

That's SO WEIRD because how can't Windows find it when I freaking double clicked on the exe file? Like, IT'S THERE.

That's not the worst part. The worst part is, it's happening to a lot of my programs, like:

- Daemon Tools

- Intel Rapid Storage

- Killer Network Manager

- Even Microsoft Office

SH**. Sorry, but I'm really frustrated right now.

I've tried reinstalling some of them to no avail. At some point I couldn't even uninstall them, because Windows couldn't find it (same error).

I've somehow managed to reinstall Remote Mouse and get it to run without errors. I honestly don't know exactly how I did it, but what I remember I did was deleting the install dir on the Program Files dir, and I removed a lot of registry entries containing the words "remote mouse". Now, this method is really impractical if I want to reinstall all my "troubled" programs. I don't even know if it (Remote Mouse) was fixed this way.

I want to uninstall the Updates (KB 4560960) to see if it's really the source of this issue, but apparently I can't.

I also can't exactly reinstall Windows 10 right now because I'm on mobile plan and my ISO is a pretty old version. It would take a lot of time and money (hard to come by these days) to reinstall Windows, update, install my programs (some need internet connection).

So, please, if anyone has any suggestion, a fix, a trick, something, please tell me.

Also, if this issue is really caused by the latest Windows Update (KB 4560960), can somebody at Microsoft please make a fix? Cause I'm currently on a dead end.



The best fix is to wait as this is a known problem.

Alternate resolution requires a registry edit:

Right click Start>Run

Type regedit and press enter.

Go to: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution folder

rename the folders of the apps that do not work and check, like winword.exe to backupwinword.exe and so on.


Ordinary mod that cannot do anything

4 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated May 29, 2021 Views 1,740 Applies to: