My work lost after Window 10 nightly restart for update even when disabled in group policy

I'm annoyed by automatic restart after Windows update. I have enabled in group policy under

Computer Configuration\Administrator Templates\Windows Components\Windows Update

item“No auto-restart with logged on users for scheduled automatic update installations”  (corresponding value in registry is NoAutoRebootWithLoggedOnUsers under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AU)

but when update needs restart it still automatically restarts.

I have lost my work in my sleeping PC, Windows wakeup it and restarts! I'm annoyed.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Jiri,

Thank you for posting on Microsoft Community. I understand the inconvenience you are facing. I will certainly help you with this.

Try with the methods below and check.

Method 1:I suggest you to run System File Checker, which will check your system for missing, corrupt or damaged files and attempt to fix them.

Please refer the article on “How to run System File Checker” and check if that helps.
https://support.microsoft.com/kb/929833/en-gb

Method 2:

Also, I would suggest you to perform a Clean Boot and check.

Putting your system in Clean Boot state helps in identifying if any third party applications or startup items are causing the issue. You need to follow the steps from the article mentioned below to perform a Clean Boot.

How to perform a clean boot in Windows

http://support.microsoft.com/kb/929135

Note: After troubleshooting, refer to this section "How to reset the computer to start normally after clean boot troubleshooting".

Hope this helps. If you face any issues with Windows, do get back to us. We will be happy to assist you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi.

  I have provided clean install of Windows 10 for tests with the same result.

Windows 10 ignores group policy setting Computer Configuration\Administrator Templates\Windows Components\Windows Update\No auto-restart with logged on users for scheduled automatic update installations set to Enabled.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Correct. It is ignored.

I find this incredibly annoying too.

14 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Did you even read what his problem is? This "solution" is in no way helpful

31 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Wow, your reply couldn't be more unrelated to the OP's question.

I also have this policy ignored in my PC.

"To alcohol! The cause of and solution to all of life's problems." - Homer Simpson

20 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

According to pointer in another thread, the policy settings may need force updating with this command:

gpupdate /force

Reference

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks, will try this one out and see if it works :)
"To alcohol! The cause of and solution to all of life's problems." - Homer Simpson

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

gpupdate /force not solved my problem. Windows are still restarting.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Go to the services section and there to updates. Then click on Advanced updates settings and then "Choose how updates get installed" setting it to notify to schedule restart and then give a suitable time.  
Projjal Gop

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

It does apply to WHEN updates are installed, not WHEN the computer is restarted.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated November 21, 2020 Views 6,941 Applies to: