How to stop automatic updates in Windows 10

Split from this thread.

How do I stop Windows 10 updating automatically. Basically, I don't want to update my OS. Windows update is very annoying and it breaks the system sometimes. In windows 10 I don't find any option to turn off automatic update.

***Post moved by the moderator to the appropriate forum category.***

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Basically, at the moment there is little you can do to stop W10 updating itself for most W10 versions. This is unlikely to change by much as far as I can tell from the info around on the www.

General W10 Update info from MS - https://support.microsoft.com/en-us/instantanswers/c4a6d3df-d0d4-42b6-0018-ca48577f9909/update-windows-10

Apart from the Enterprise version (I believe), you cannot pick and choose updates for most versions of W10 (Home etc), Its all automatic. Unlike with older versions of Windows which allowed you to set Windows Update in a number of different ways.

There are a few minor tweaks you can do, like:

1. Refuse a persistent 'duff driver' update - https://support.microsoft.com/en-us/help/3073930/how-to-temporarily-prevent-a-driver-update-from-reinstalling-in-windows-10

2. Stop an update restart mid-work time - http://www.howtogeek.com/221903/how-to-schedule-restarts-for-updates-in-windows-10/  and set active hours - http://www.howtogeek.com/264325/how-to-set-active-hours-so-windows-10-wont-restart-at-a-bad-time/

3. Metered Connections ( mainly for paid/metered WiFi I believe ) - https://www.tenforums.com/tutorials/3162-wireless-network-metered-connection-set-windows-10-a.html

But basically, you have to accept the update(s) as they are offered.

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To disable Windows 10 Automatic Updates:

  1. Go to Control Panel - Administrative Tools - Services
  2. Scroll down to Windows Update in the resulting list
  3. Double click the Windows Update Entry
  4. In the resulting dialog, if the service is started, click 'Stop'
  5. Set Startup Type to Disabled

Please Note: if you disable Windows 10 Updates, your system will be at risk from attack

  1. Windows Defender will not be updated
  2. Operating System patches will not be applied
  3. You will not be able to use the Windows Store
  4. Windows Apps will not update and possibly fail

On the plus side your hardware will continue to work!

If you do decide to turn off Automatic Updates, you should download them from the Microsoft Catalog Page and install them manually at a convenient time. Just enter Windows 10  + your current build number into the search box  (1607, 1511 . . .etc.) to get the appropriate updates - for example: Windows 10 1607

___________________________________________________________________

Power to the Developer!

MSI GV72 - 17.3", i7-8750H (Hex Core), 32GB DDR4, 4GB GeForce GTX 1050 Ti, 256GB NVMe M2, 2TB HDD

103 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This no longer works, Windows is enabling that service on it's own now.  I'm attempting to disable via gpedit.msc, but the service disable I've been using for a while doesn't stay disabled anymore.

23 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Every time an update tries to occur it destroys my entire network internet connection and all the users start screaming.  That's why it should be made easy and sticky to only notify of updates but not download or do them until the users gives consent.  This is an  issue for all types of users, dumb or sophisticated.  MS just makes it ridiculously hard to take control of updates, and particularly hard in W10 Home.

Once you think you have it stopped then when you do allow an update they turn it all on again for you.

Now they've removed the registry value you can tweak to accomplish this in Home version, and you are forced to collect a bunch of missing features and get them installed in your OS again.  If you do get it working it will probably all just disappear again next time you do an update.

Yet another reason why users hate Microsoft.

37 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Honestly a bad situation.

I have no problem if Windows notifies me and I can apply updates when I have time to fix everything the update breaks.

But unilaterally applying an update that can eff up my system without allowing me to accept or delay that update is not good.  I've had updates bomb out my system the evening before a critical presentation and, oh-well, you're out of luck.  Enjoy your brick in front of a customer.

Absolutely bad.

18 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I wonder how Microsoft doesn't see worldwide statistics of increasing home Linux users. Telling users how to use THEIR computers is incredibly dubious decision. Microsoft takes a lot of negatives because of such manager mistakes.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In this method, we are going to use the Local Group Policy Editor. Since Group Policy Editor is not present in Windows 10 Home edition, this method is not applicable to Windows 10 Home.

Step 1: Open Local Group Policy Editor. To do so, type Edit Group Policy in Start or taskbar search box and then press Enter key. Alternatively, open Run command box, type Gpedit.msc, and then press Enter key to open the same.

Step 2: Navigate to the following policy:

Computer Configuration > Administrative Templates > Windows Components > Windows Update.

Step 3: On the right-side, double-click on the policy labelled Configure Automatic Updates to open its properties.

Step 4: Select Enabled option. Under Configure automatic updating, select second option labelled Notify for download and notify for install. Don’t touch rest of the settings.

Click Apply button. As mentioned before, this method will not turn off Windows Update but you will be notified when updates are available to download. You can simply ignore the alert to avoid downloading and installing updates.

When this policy is enabled, you’ll see Some settings are managed by your organization message under Advanced options of Windows Update

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In this method, we are going to use the Local Group Policy Editor. Since Group Policy Editor is not present in Windows 10 Home edition, this method is not applicable to Windows 10 Home.

Step 1: Open Local Group Policy Editor. To do so, type Edit Group Policy in Start or taskbar search box and then press Enter key. Alternatively, open Run command box, type Gpedit.msc, and then press Enter key to open the same.

Step 2: Navigate to the following policy:

Computer Configuration > Administrative Templates > Windows Components > Windows Update.

Step 3: On the right-side, double-click on the policy labelled Configure Automatic Updates to open its properties.

Step 4: Select Enabled option. Under Configure automatic updating, select second option labelled Notify for download and notify for install. Don’t touch rest of the settings.

Click Apply button. As mentioned before, this method will not turn off Windows Update but you will be notified when updates are available to download. You can simply ignore the alert to avoid downloading and installing updates.

When this policy is enabled, you’ll see Some settings are managed by your organization message under Advanced options of Windows Update

Thanks for the information. However, I have windows 10 home edition.

Is there a way to do this in home edition?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know what the freaking H..l is wrong with Microsoft.  The Windows 10 update experience has been the worst thing ever, since the beginning of W10.

Every major update has failed to install on every computer I have to deal with.  I've had to find the download file somehow, use a third party to convert it to an iso, mount the iso, and install from there.  That's the only thing that works.  Similar experience for other users I know.

MS absolutely destroyed my home network for months trying to do an update over and over again.  No network activity showed up on the resource monitor, but windows would download a 4GB update, fail to install, then download the same 4GB update over and over again.  By the time I finally found this in my update history it had done that 15 times.

Now they have removed the ability to stop it from W10 home.  Then they wonder why we hate them.

Oh, and by the way, if you edit your system to stop this activity expect them to remove your changes when they do another major update, so you have to do it all over again.

To add insult to injury,  I had a nice utility program for updating all my machines called Portable Update.  But recent windows updates somehow no longer will work with that utility.

Microsoft, belly up to the bar and fix this, or take your marbles and go home.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I FINALLY FIXED THIS

This problem has plagued me as well. I have installed the creators version and it keeps uninstalling itself and telling me I have to update again. I did everything on this thread with not luck and I finally resolved it. Basically I:

  • Changed my internet to metered
  • Removed the update directory
  • Stopped the update Service
  • Then look in C:\WINDOWS\UpdateAssistant (Note I also had an UpdateAssistant(2) folder which I deleted)
    • In this Folder there is a file "UpdateAssistant.exe"
    • Change this file to "UpdateAssistant.txt"

Apparently this is the file that does the damage and this keeps it from running. I have had this in place for over a week and while I occasionally get messages that say "There is an update" I just open the window and close it and I'm done. I have not had Windows create another update folder since I did this and you can always reverse it.

Good luck Amigo's

23 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated August 9, 2020 Views 31,838 Applies to: