how to disable digital signing of driver in windows 10 as there is no option in advanced restart as earlier in 8.1

in windows 8.1  pressing shift and restart goes to a screen where troubleshoot option was present but in win 10 there is no troubleshoot option is present.   then how to disable secureboot and disable driver signing .. please help

 and how can i go to safe mode now?

 

Question Info


Last updated October 11, 2018 Views 4,939 Applies to:

Hi Krishna,

Thank you for posting your query on Microsoft Community. 

I appreciate your interest in Windows 10. We sincerely regret for the inconvenience caused.

Please check if you have performed these steps to disable the driver signature enforcement in Windows 10.

a. Press the Win + C and click on PC settings.

b. Switch over to the “Update & recovery” section.

c. Then click on the Recovery option on the left hand side.

d. Once selected, you will see an advanced startup section appear on the right hand side. You will need to click on the “Restart now” button.

e. Once your Computer has rebooted you will need to choose the Troubleshoot option.

f. Then head into Advanced options.

g. Then Startup Settings.

h. Since we are modifying boot time configuration settings, you will need to restart your computer one last time.

I. Here you will be given a list of startup settings that you can change. The one we are looking for is “Disable driver signature enforcement”. To choose the setting, you will need to press the F7 key.

Hope this information helps.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

there is no troubleshoot option as it was in 8.1 now there is only continue,recovery from disc and exit &shutdown

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This solves the problem only once.

Next time you restart the system it restarts with the driver signature enforcement.

This is useless.

What is the way to disable the annoying policy PERMANENTLY, please?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

When I get to the screen to select F7, my keyboad is dead and will not allow me to enter anything. The mouse is not available either. What can I do to fix this or disable the driver signature enforcment some other way>

Thank you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

As of preview release 15002 all unsigned drivers work only once with the F7 option. I need a permanent fix. I run lab equipment and they no longer work.

Getting signed drivers is impossible since the companies no longer exist.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same issue for a while. Always needing to hold down shift before clicking restart to reboot with the troubleshooting option to disable driver certificate enforcement.

But, ultimately, I found a way that might not work for you the same as it did me.

But before we continue, please consider the following, and perform your own diligent research, as I do not recommend nor condone end-users to modify their BIOS in any way. I'm merely educating on how doing so can achieve the effect desired here.

Consider this:

To quote Microsoft, "Secure Boot is a security standard developed by members of the PC industry to help make sure that your PC boots using only software that is trusted by the PC manufacturer. When the PC starts, the firmware checks the signature of each piece of boot software, including firmware drivers (Option ROMs) and the operating system. If the signatures are good, the PC boots, and the firmware gives control to the operating system."

You should be made aware that Microsoft Windows is fully aware that "you may need to disable Secure Boot to run some PC graphics cards, hardware, or operating systems such as Linux or previous version of Windows."

Their definition out of the way, you should know that it is designed to keep rootkits and other malicious software from booting you into an OS you didn't install or running binary you never intended. It also protects you from you. It plays a major role in keeping your system safe.

But.

Here are the steps:

1) Click start

2) Click the power icon to reveal the options sleep, shut down, restart (and to some folks, hibernate will be there, too).

3) Hold down your shift key, and with it still depressed, click on restart.

a) This will take you to the advanced reboot menu.

4) Click Troubleshoot --> Advanced Options

5) From here, see an option to change UEFI Firmware Settings. Click that, and the click Restart on the next screen.

6) Once your PC reboots into it's BIOS, find a setting that says Secure Boot and choose to disable that feature. Then hit enter on the option Reset to Setup mode. This will change the status of the secure boot to disabled immediately.

DISCLAIMERS

a) The option may not appear in the same words mine did. The goal is to change your BIOS configuration to disable **SECURE BOOT** and change **USER MODE** to **SET-UP MODE**, SO LOOK AROUND OR RESEARCH HOW TO MAKE THESE CHANGES IN YOUR OWN BIOS RELEASE IF THE METHOD I USED IS NOT PRESENT FOR YOU.

    ----May appear with: platform mode

b) Don't do anything else other than these steps while you're in there.

c) If your option is not under "Configuration" as mine is, it will most likely be under "Security Options."

7) You're now ready to change load OS optimized defaults to Disabled. Then DO NOT CLICK Load Default Settings. Just Disable the option to do it.

8) Make sure you changed "Secure Boot" to "disabled."

If you don't have the option to enter set up mode, you'll most likely need to reboot again after your initial boot to make the change take.

If secure boot does not fully disable after attempting a second restart because you don't have an option to enter set up mode, now you can choose load default settings with the OS optimized defaults set to DISABLED.

If you don't need to perform the default settings action, don't do it. This puts you in Legacy Bios mode instead of EUFI and I see no reason to do that if you don't need to. There are no good reasons to modify BIOS settings when you don't need to. Hopefully Microsoft is rising up to be able to take advantage of the protections Secure Boot offers while providing companies which produce goods (which also keeps OS's in business) that need drivers with a free, easy way to get device/hardware specific driver certificates. This is to much for me to be able to game with the latest Graphics support needed, or utilize the audio services better, or run medical equipment without needing to remember to go through a 10 minute shut down procedure.

Now:

8) Save and exit.

9) Install your drivers. (Best way to do graphics drivers is to get the .zip file with the .inf file in it, choose "have disk" under the update driver options and run that .inf file to install the driver).

10) Reboot.

If everything worked like it did for me, your drivers will still be installed, permanently, as long as you don't revert those BIOS settings.

Disclaimer 2: Don't get all huffy if it doesn't work. It worked for me.

To revert all of this back to normal, change secure boot back to enabled and then select the option "restore factory keys" to go back to user mode. Keep in mind, if you do that, you'll lose all your changes and your drivers will be reverted back to the OS recommended ones. And also keep in mind, I'm not telling you to do any of this, I'm just saying it's what I do.

For more information visit: Secure Boot Overview on Microsoft's Windows IT Center's website.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Wow... it was really that easy. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.