Disable automatic reboot on updates - Windows 10 Pro anniversary update

I have processes that run overnight on my machine, and with the new Windows 10 update, I no longer have control over when the machine reboots, which kills my processes.

This completely destroys my ability to use my own machine and to do my work. How do I fix this? Is the only answer Linux?

 

Question Info


Last updated March 21, 2019 Views 5,010 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Reply In reply to deleted message

Wow. Did you even read my question?

Automatic updates reboot my machine when I have overnight processes running.

I need my machine to run overnight without rebooting, which was not a problem until the Windows 10 anniversary update.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The response from Microsoft is boilerplate and useless. I have the same problem. This might help solve the problem: http://www.makeuseof.com/tag/5-ways-temporarily-turn-off-windows-update-windows-10/ See part 2. I'm not sure if it does the trick yet. I'll know on the next update. I need to prevent Windows 10 Anniversary edition from rebooting automatically after an update. The active hours concept does not work for me. I need the computer to run at all times . The @#$%^&* reboot just cost me days of work!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

With the Windows 10 Anniversary update I lost a couple settings as well as the license of one of my programs which I use.

Ok so far, but you topped that last night when my computer was restarting without asking me and closing all open and documents without saving them.


All these open and unsaved documents are lost!

There is even not an option anymore in the Windows system settings which can prevent this behaviour.

Are you serious Microsoft?

(I found in the meanwhile a Group Policy setting which should prevent that, I will see it on the next updates if it works: http://superuser.com/questions/1110265/how-to-prevent-windows-10-from-restarting-the-computer-after-installing-updates)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Windows Anniversary rebooted my system tonight ALTHOUGH I had set the group policy "No auto-restart with logged on users for scheduled automatic updates installations" to "Activated". That was working before the Anniversary.

I had a lengthy download running overnight which is now broken. If I had unsaved documents somewhere, too, they also would be gone now.

That's just insane. How could anyone still use Windows in a professional environment when such serious flaws come up? I understand that normal users need to be pushed to reboot their systems, fine. But there NEEDS to be a way for experienced users to decide on their own when it's safe to reboot the machine and when not. "Active Hours" are definitely not the proper way.

Please fix this!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Midassi,

Yeah, I completely feel your pain.  This is absolutely driving me crazy.  I had that policy set, too. I just added a few more things in an effort to prevent it from doing this, but no way of knowing if it worked until the THIRD time this has happened to me.

I don't leave documents unsaved, but what I do have are windows spread across 4 virtual desktops where I'm trying to do software development. It's not reasonable to shut down every single window every night. It just isn't.  I have windows open with code from a lot of different repositories, debug output, etc. that I need to reference.  Coming in to see all that blown away is crazy!

Last night, I was working on one machine when the machine to my left decided it wanted to reboot!  Yeah, I had not touched it in a while, but I was coming back to it!  You can't even set the work hours longer than 12.  How crazy is that?  Yes, I tend to work more than 12 hours in a day ... many days.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So it happened again tonight.... Windows rebooted after an update, although all policies were saying "NO".

I'm now going to completely disable the Update services, as this seems to be the only way to prevent auto reboots. On the long run I probably need to switch to an operating system that is suitable for professional/enterprise usage. Windows is no longer, it seems.

I really wonder why they do that stuff. Are they just dumb, or do they have saboteurs among the developers that want to harm the company? 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I made changes recently.  Windows 10 downloads updates, applies them, says it will reboot, but it does not.  I hate the threat that it's going to reboot, but I guess the settings I have applied are preventing it.

Here's what I did...

1) Run 'gpedit.msc'

2) Under "Computer Configuration" -> "Administrative Templates" -> "Windows Components" -> "Windows Update"...
2a) Select "Configure Automatic Updates", select "enabled", select "4 - auto download and schedule the install", check "install during automatic maintenance" and select a time to install.  I also checked "install updates for other MS products"

2b) Under "No auto-restart when logged on users for scheduled automatic updates" select "Enabled"

3) Run "gpupdate /force"

This seems to work for Windows 10 Pro, which is what I'm using.  I guess if you are running Windows 10 (whatever "home" is called), you're hosed.

Microsoft ABSOLUTELY needs to go back to allow more flexibility.  If I go to bed and come back in the morning and find that 4 virtual desktops with windows all over the place where I had code editors open working on software are all closed, I'm going find a way to entirely block updates, too.  I'd rather have a stale OS than one that reboots at will.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I prefer option 2 (notify to download and notify to install)

I get notification of updates being available, I can look at what they are and leave them until I am ready.

with home, you could disable the service and use the task scheduler to turn it on once a week and check for updates.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried that on one machine, but it's annoying.  Every single day there are antivirus updates. I see no good reason not to just let those update.  If not for those, I'd prefer option #2, as well.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can understand where it would be benificial to reboot machines which are not in use (a few friends of mine keep their machines online 24/7 for no reason except they don't want to wait the 10 seconds it takes their high end ssd machines to boot.....).

But my machine runs a few virtual machines with active database clones in them in order to debug faster (working with multi GB databases which have to be read many times a day with a slow connection is impossible otherwise).

The #$%^&*() policy which auto reboots has litteraly killed the database the last few months, once the recovery failed as well resulting in having to stay up till 2am in order to recreate it.

  • Patch tuesday is noted in my calendar, manually installed and rebooted the same day
  • Every trick I could find has been tried to stop the %^&*() auto reboots

The whole problem comes with these often unecesary between patch tuesday patches, it's making me think real hard about ditching this OS and just running a small VM for the only few remaining windows only apps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.