Administrator account not allowed to disable UpdateOrchestrator Reboot task after latest update

For a long time my PC was plagued with insomnia, waking up in the middle of the night for apparently no reason as nothing new would be open when I unlocked the computer. If I was asleep, the whirring of fans would often wake me up along with it, which as you can imagine is very annoying. Finally, I stumbled upon an article on some blog or other that helped me finally solve my problem via the following steps:

  1. Open Task Scheduler, navigate to Microsoft\Windows\UpdateOrchestrator and select "Reboot"
  2. Open properties for the task and uncheck "Wake the computer to run this task"
  3. Right click the task and disable it for good measure
  4. Find the task file in File Explorer under System32\Tasks\Microsoft\Windows\UpdateOrchestrator
  5. Open its properties and under Security, uncheck all permissions for System

It was a hamfisted fix, but the only thing that ever helped. Occasionally, updates would override my settings, but I only had to fix them every couple months which was still infinitely better than before.

HOWEVER

Since last week's major update, the "Creator's Update" or whatever it's called, I can no longer do this. Attempting to disable the task gives me an error message saying "The user account you are operating under does not have permission to disable this task." Hitting "OK" after editing the task's properties brings up a password prompt, and putting in my username and password (I'm an administrator) tells me: "An error has occurred for the task Reboot. Error message: The following error was reported: The supplied variant structure contains invalid data." I can open the task in a text editor to view the XML, but am not allowed to save the file after making changes despite making sure that both administrators in general and my specific account had "full control" permissions.

Is there any way for me to disable this task after the update? Bonus points if I can do it once and for all, instead of having to repeat the fix after every major update.

 

Question Info


Last updated September 21, 2018 Views 4,819 Applies to:
Answer

The first thing to try is an elevated cmd/powershell and do: SCHTASKS /Change /TN "Microsoft\Windows\UpdateOrchestrator\Reboot" /DISABLE

If this gives you an access denied error, you'll need something like NSudo (http://www.majorgeeks.com/files/details/nsudo.html). Run NSudo, and the cmd as TrustedInstaller with all privileges. You should then b able to run the aforementioned command.

However, this still doesn't solve the re-enabling issue; to fix that, do the following in the NSudo elevated cmd: icacls "%WINDIR%\System32\Tasks\Microsoft\Windows\UpdateOrchestrator\Reboot" /inheritance:r /deny "Everyone:F" /deny "SYSTEM:F" /deny "Local Service:F" /deny "Administrators:F"

(You might need to edit the command slightly to suit your setup/usernames/SIDs.)

26 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.