Runtimebroker.exe high cpu

Is there any way to fix runtimebroker?  It's using about 30 - 40 % cpu usage

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for posting your query in Microsoft Community.

As you have mentioned that you want to know the ways to fix runtime broker.

Runtime Broker is a Windows process in Task Manager that helps manage permissions on your PC for apps from Windows Store. It should only use a few megabytes of memory, but in some cases, a faulty app might cause Runtime Broker to use up to a gigabyte of RAM or more.
If your RAM use is high and your PC is running slowly, an app may be the cause of the problem. Press Ctrl+Shift+Esc to open Task Manager and then, on the Processes tab, check to see how much memory Runtime Broker is using. If it’s using more than 15% of your memory, you probably have an issue with an app on your PC. To stop Runtime Broker from using so much memory, select Runtime Broker in the list, select End task to close Runtime Broker, and then restart your computer.

If still the issue persist suggest OP to run in-built system maintainace troubleshooter and check-- give appro steps;

1) go to control panel.

2)Select Troubleshooting
3)On left pane, select View all.

4)Select system maintaince and run the troubleshooter .

Hope this information will be helpful for you. Keep us posted on the status of the issue and I’ll be glad to assist you further

Thank you.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I updated from Windows 7 to Windows 10 Pro and now the runtimebroker.exe is using 10-15% CPU and 10-15 Mb RAM when the computer is idling. Including other background processes this means my computer is running at a constant minimum of 25% CPU when idling and my fan is working pretty hard to keep it cool. This is modern core i7 processer and should not be running this hard at idle. Will you log this as a bug? Doing system maintaince doesn't help. I will do a clean install to see if that fixes it.

89 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've tried a clean install a couple times and it still persists. Don't waste your time.
To be the best you must lose your mind.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Alright, I will disable runtimebroker.exe via the registry edit hack then. Thanks.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Alright, I will disable runtimebroker.exe via the registry edit hack then. Thanks.

This is the first mention of a registry hack in this thread. Can you post a link, or post instructions? Did it work for you? Were there any adverse effects? 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I don't recommend doing this as it breaks certain functionality in Windows 10 and can even break the start menu all together but here are the steps needed to disable it. Again I strongly recommend not doing this.

Right-click on the Start Menu Icon. Go to RUN and type regedit.exe and select OK.

Find the following entry:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003

Change the 3 to a 4.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

4 is Disabled, 3 is Manual and 2 is Automatic startup.

Before editing, the original value was 3. Set to 4 to disable. Just change the 3 to a 4 through the MODIFY menu selection, exit regedit and reboot your system.

To be the best you must lose your mind.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Having the same problem. RunTime Broker starts running and consumes so much CPU it takes minutes for Task Manager to come up.  I end the process and the systems is fine for awhile.  Another thread said turn off "Show me tips about Windows" and I did that and it did not help.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Awesome. Turning off "Show me tips about Windows" immediately dropped average CPU usage from about 40% to 5%. Runtimebroker.exe was the process taking so much CPU.

Thanks for the tip, PaulPrimmer. I'm sorry it didn't work for you as well.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

There seems to be some common elements to these runtime broker issues.  Check this post for a possible solution

answers.microsoft.com/message/

Cat herder
Windows Insider MVP
MVP-Windows and Devices for IT
http://www.zigzag3143.com/

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I tried disabling all the notifications and still had the run time broker consume CPU.  On my PC it is consuming so much that it takes a couple of minutes to run Task Manager to get it working.  After ending the process I may go for about an hour before it is back.  I've checked to see if other apps as the "Store" are running and they are not.  There was a post about "Choose How Updates are Delivered" and I turned off the "When this is turned on, your PC may also send parts of previously downloaded Windows updates and apps to PC's on your local network, or PCs on the Internet, depending on what's selected below"  This was by default on and I turned it off as someone posted that this could be some P2P background work burning CPU.  That did not work.  I did the register change that is in this thread and that has topped my problem and I have not seen any ill affects.  It would be nice to hear from someone at Microsoft on what I a may be getting/not getting with turning of Run Time Broker.  For me the CPU problem made my system unusable.  So far this has been the one big negative of going to Windows 10.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated March 4, 2021 Views 17,550 Applies to: