Runtime Broker is using too much cpu on a quadcore i5 3570k

My computer usage levels right now are hovering around 66%-70% with it occasionally spiking into the 90% territory. I'm not sure what is causing it other than the runtime broker program which is currently consuming the most out of cpu usage out of any other program. 

 

Question Info


Last updated August 11, 2018 Views 887 Applies to:

 

Hi,

Welcome to Microsoft Community.

 

Runtime Broker is a Windows process in Task Manager that helps manage permissions on your PC for apps from Windows Store. It ideally uses a few megabytes of memory, but in some cases, a faulty app might cause Runtime Broker to use up more.

 

Stop runtime broker from Task manager, and try to run App troubleshooter and check:

 

Try the followings steps:

 

  • Click "Search" and type "Troubleshooting" without quotes and hit enter.

  • Click  “Hardware and Sound”

  • Select Windows store apps

  • Click next to run the troubleshooter.

 

 

Hope this helps.

Regards,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Welcome to Microsoft Community.

Runtime Broker is a Windows process in Task Manager that helps manage permissions on your PC for apps from Windows Store. It ideally uses a few megabytes of memory, but in some cases, a faulty app might cause Runtime Broker to use up more.

Stop runtime broker from Task manager, and try to run App troubleshooter and check:

Try the followings steps:

  • Click "Search" and type "Troubleshooting" without quotes and hit enter.

  • Click  “Hardware and Sound”

  • Select Windows store apps

  • Click next to run the troubleshooter.

Hope this helps.

Regards,

I've done as you directed. I hit end task on Runtime Broker. I took me a while to find the troubleshooter that was located in the control panel section. I ran the troubleshooter and it says it could not find any problems. After a while the runtime broker program started back up after ending task. 

Previously known as Win7Xbox 360

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

 I found a fix for your problem: go to Settings >> System >> Notifications >> Turn off Show me tips about Windows.

 Here is the source: Runtime Broker CPU Usage Fix

Knowledge should be shared!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I shut everything off and am still getting high cpu usage. I contacted technical support and they ran some troubleshooters and messed with a few settings and I still have the problem after the tech support agent said it was fixed it popped up again when I closed out the chat. I'm not sure what I should do at this point other than to reinstall Windows 7. 
Previously known as Win7Xbox 360

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Update: I did some searching around the internet and stumbled across this post:

Runtime Broker is a service called Time Broker, which can be disabled through editing the registry.
Right-click on the Start Menu Icon. Go to RUN and type regedit.exe and select OK.

Find the following entry:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003 

Change the 3 to a 4.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

4 is Disabled, 3 is Manual and 2 is Automatic startup. 

Before editing, the original value was 3. Set to 4 to disable. Just change the 3 to a 4 through the MODIFY menu selection, exit regedit and reboot your system.

After this edit, Runtime Broker no longer runs and the CPU at idle is now only 0 to 1 or 2 percent.

No adverse affects after disabling Runtime Broker on my system.

link: http://www.tenforums.com/general-discussion/7907-runtime-broker-process.html

After trying this here is the result:

Runtime Broker has been tamed for now until there is some sort of patch that can fix this process. 

Not sure what the adverse effects of disabling it will be but as long as my machine runs normally again I am happy. 

Previously known as Win7Xbox 360

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

 I found a fix for your problem: go to Settings >> System >> Notifications >> Turn off Show me tips about Windows.

 Here is the source: Runtime Broker CPU Usage Fix

This fixed my issue with Runtime Broker.  I don't need tips, as I am a Windows 8.x/10 Power User.

Surface Pro 3, Windows Insider Fast Ring
Lumia 640, AT&T US; Windows Insider 10 build 14295

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

HI,

Be sure to check for malware if the below does not work.

First -> Start  Settings- System - Notifications & actions - Turn off -> "Show
me tips about Windows".

Then Reboot the computer.

That will work for many.

Hope this helps.
--------------------------------------------------------------------------------------------
Rob Brown - Microsoft MVP <- profile - Windows Experience : Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows and Devices for IT 2010 - current
Windows Insider MVP 2016 - current

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This nor anything else I have tried has stopped it. App History tab in task manager lists CPU time for EDGE at 8.55, Cortana from yesterday to today went from 5+ to 8.24, Store was third ranking at 7.09. Next highest under 1.0 by far. I have cleared edge data, cleared and reestablished Cortana, done all updates, Tried the end task runtime and restart, with no change. None of the three above are listed in startup tab, Under user tab, ending Cortana, ending Store, ending Search and Cortana application, Edge is not listed anywhere In task manager ( identifiably). Ended tasks restart and runtime restarts and builds up to cpu total of 92% particularly if not using PC, while in use, runtime is less impactful till wait states happen. I have set RuntimeBroker to below normal priority so I could get back control to progress. 

THIS IS WINDOWS ISSUE AND NEEDS A FIX, CRIPPLING MY BUSINESS. 

1) Runtime and OS are to protect OS from App issues

2) Apps are reported as vetted by MS

3) I suspect that APPS are being accused of the cause when edge/Cortana/Store/Indexing/Getting to know you are at fault.

4) I guess since Edge and Other MS Apps are Apps, it may still be MS (APPS)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.