Runtime Broker constantly eating up resources and thus resulting overheating and increased fan speed

After installing the upgrade of Windows 10  i noticed that the process named "Runtime Broker" is constantly running and  constantly eating up my CPU Cycles and other resources.

This  process is eating nearly 30 % of my CPU Cycles thus  resulting in overheating and increased fan speed.

Kindly provide me with the solution to this issue.

Thanks

 

Question Info


Last updated September 24, 2018 Views 9,041 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi TanmayGupta,

Thank you for posting your question in the Microsoft Community.

Sorry to know that you are facing this issue.

Runtimebroker.exe is basically in charge of metro permissions.  If you have a bunch of metro apps running it will get larger.  You can’t kill the process because that would kill the metro apps.

Runtime Broker is a Windows process in Task Manager that helps manage permissions on your PC for apps from Windows Store. It should only use a few megabytes of memory, but in some cases, a faulty app might cause Runtime Broker to use up to a gigabyte of RAM or more.

If your RAM use is high and your PC is running slowly, an app may be the cause of the problem. Press “Ctrl+Shift+Esc” to open Task Manager and then, on the Processes tab, check to see how much memory Runtime Broker is using. If it’s using more than 15% of your memory, you probably have an issue with an app on your PC. To stop Runtime Broker from using so much memory, select Runtime Broker in the list, select End task to close Runtime Broker, and then restart your computer.

Ensure to install any pending updates and also update all device drivers from Device Manager. Once this is done restart the computer to check if this helps.

Keep us informed to help you further.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The same is happening to me, I had never before that problem, specially because I have a PC for gamers which I just use it for Word, the computer is extremely hot and this Runtime Broker is running all the time consuming a big amount of the CPU.

Please I need a solution.

Thank you,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

HI,

Be sure to check for malware if the below does not work.

First -> Start  Settings- System - Notifications & actions - Turn off -> "Show
me tips about Windows".

Then Reboot the computer.

That will work for many.

Hope this helps.
--------------------------------------------------------------------------------------------
Rob Brown - Microsoft MVP <- profile - Windows Experience : Bicycle - Mark Twain said it right.
Rob Brown - Microsoft MVP - Windows and Devices for IT 2010 - current
Windows Insider MVP 2016 - current

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

The solution worked... but just for half a day, and now I have the problem again. What can I do then?

Thanks,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

While you are troubleshooting leave that setting off - there can be more than
one reason the Runtime Broker is using so many resources.

Be sure to check the startup programs - try a clean boot.

Check with Malwarebytes, Kapersky's TDSSKiller.exe, and Hitman Pro (trial)
as no one program detects all malware.

Some have uninstalled the security updates around 12 - 13 August.

Rob - SpiritX
Rob Brown - Microsoft MVP - Windows and Devices for IT 2010 - current
Windows Insider MVP 2016 - current

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Runtime Broker (RB) is triggered by a Metro App.  I experienced overclocking of my laptop, overheating, very high memory utilization and constant running of RB in the background.  My NAS drive has thousands of photos and videos stored on it.  The NAS drive was being hit with a lot of activity.  If I unplugged my NAS drive, RB would stop.  My feeling was Photos was the Metro App causing my problem, but there was no solution to stop it (other than registry changes?).  Again, I suspected the problem was caused by an app running in the background ligitimately triggering a buggy Runtime Broker to run - causing it to do whatever it does with all the photos on my NAS drive.


Ater 2 weeks of this and trying every "solution" I could find on the internet, I discovered Privacy settings.  Go to Settings/Privacy/Background Apps and turn off all the apps.  Runtime Broker will stop immediately (you may have to reboot your computer, but I didn't have to).  I use Live Mail instead of Mail, Photo Gallery instead of Photos, IE 11 instead of Edge, so I've left all of the Metro Apps off.  I found that if you turn the Photos app off and see Runtime Broker stop and then turn Photos back on again, it might take up to a day before Photos causes Runtime Broker to start running again and the problem will resurface.  So, the safest thing is to turn off Photos and leave it offf until Microsoft fixes the problem.  In the mean-time, use something like Photo Gallery or Picasa.  Just make sure that the apps Background Apps are turned off and Runtime Broker will stop.  It worked for me and nothing else did.  Good luck

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there.

I really can't stand this issue anymore... 16GB RAM and for the 1st time in history (all the Windows & Linux), I have to see Windows 10 killing the app "he" thinks occupy all the memory. And this is the lucky case. If I play games, I risk the screen will go black and the computer will freeze, forcing me to reboot.

I don't understand how this issue is still there after so much feedback received by users during the development of the OS. What for to have an OS in beta, a public beta, and a so annoying and clear as the sun issue still there??!!

It ruins my experience with Windows 10.

I use Photoshop and I have to fear Win 10 will close the application...

It already did it....damn!

I wonder if Microsoft devs are planning to work thoroughly into this bug or not with the upcoming update.

Windows 8.1 was PERFECT for me.

Imagine.. even the research of the programs installed was perfect!

Now if I search a program that in Windows 8 I could find easily by typing the letters, on Windows 10 research box the research doesn't find anything and piont me to online search. It's ridiculous. How could Microsoft screw up something that was working greatly??!!

I don't need  Metro apps and stuff but many people need them and they should kill those notifications just to make Windows 10 works normally without draining all the RAM available?

Microsoft devs, please tell us something concrete about this issue.

Tell us you are working on it and soon we're going to receive the definitive fix to whatever causes this bug on the Runtime Broker process.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try this if you're using Windows 10, make sure you have the November update for it first.:

Runtime Broker kept thrashing my system, usually using 40% of my CPU although memory use wasn't much, according to the Task Manager. I'm currently using Windows 10 Pro x64 version 10240.

Runtime Broker is a service called Time Broker, which can be disabled through editing the registry.
Right-click on the Start Menu Icon. Go to RUN and type regedit.exe and select OK.

Find the following entry:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003

Change the 3 to a 4.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

4 is Disabled, 3 is Manual and 2 is Automatic startup.

Before editing, the original value was 3. Set to 4 to disable. Just change the 3 to a 4 through the MODIFY menu selection, exit regedit and reboot your system.

After this edit, Runtime Broker no longer runs and the CPU at idle is now only 0 to 1 or 2 percent.

No adverse affects after disabling Runtime Broker on my system. (ADDITIONAL NOTE: Disabling Runtime Broker will prevent apps from the Microsoft Store from running.)

Jon A Martinez MCSE

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The issue's disappeared since that update, luckily!

Now Windows 10 works flawless.

Cheers!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

after having roamed various forums found the one solution that did the trick for me: in Metro Apps (foto, music, video,..) remove all references to network -folders (on different PC, NAS)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.