Windows HDR option within Windows 10 settings. Poor display quality when enabled.

Hi. :)

My TV is 100% HDR compatible. I have a Nvidia GeForce GTX1080 and can run games with HDR perfectly.

Normally when I output my display to my 4K HDR TV (single display 3840x2160p 60Hz) it's a perfect picture. Nice and sharp with vivid colour. However today when I changed the output to my TV the picture quality was very poor. It was nowhere near as sharp and the colours were very weak.

I went into the Windows 10 display options and noticed that there is option for 'HDR and Advanced Colour' which was set to 'On'. I don't remember having seen this option before. Is this a new option which has been included in the new Creators update?  

It appears as though this HDR option does not work as it should. When set to 'on' the TV automatically changes the picture mode to HDR as it should be but as I said, the picture quality goes bad. When I turn this option off the perfect picturequality comes back to what it should be.

Games still run in HDR when this option is turned off so I don't really know whats going on.

And is this option really needed when HDR compatible GPU's will automatically display HDR if required? 

If anyone can shed some light on this I'd be very grateful.

Many thanks in advance. :)

***Post moved by the moderator to the appropriate forum category.***

[Moved From: Windows / Windows 10 / Performance & system failures / PC]

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Thanks. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello there, is just to say, that for AMD side, the Windows 10 HDR is finally fixed in version 17.7.2 :)

Best regards for Nvidia ppl :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can confirm that the 17.7.2 AMD driver has patched the issue for me. There's still a problem with Microsoft's implementation of HDR, so I have it turned off. However, it appears AMD's driver can now override the Windows 10 settings once again and play games in HDR, despite the OS settings. Also, had to set my color space to YCbCr 4:2:2 with a 10-bit color depth in the Radeon settings manager. Glad AMD was able to step up and address this issue from their end. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

yeah, it was about time to fix it... i´m using 4:4:4 8bpc, the image is far better, its alot pixelated, but 4:2:2 10bpc or 12bpc is good too for the colors, but i prefer pixels.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just updating that it seems like the HDR issue is on MEA only. The new driver seems to allow Nvidia to override OS level settings. Tried it with Hitman, by disabling HDR on windows, and the game launches HDR perfectly.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

ME:A HDR works properly now with AMD's latest driver. Sorry Nvidia folks! :) 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

ah well, just gotta hope someone fixes it.. until then, will focus on attacking the backlogs :)

just one thing.. with AMD, do you find HDR movies getting picked up correctly, with Windows setting off? I tried on my system, and the HDR bubble never came up.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I haven't tested with HDR movies on my AMD build, but I doubt it will work as I have to turn HDR off in Windows due to my colors being greyed out and wrong when it's turned on. However, the new AMD driver does definitely work when playing HDR games even if HDR is turned off within Windows itself. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks mate :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well... I finally managed to get the latest Nvidia driver downloaded and installed.

The only difference for me is that HDR will work in games. But the colour and brightness is still messed up!

HDR is also working in games when Windows HDR is turned off. It was not working with older drivers. For me anyway. So I can now leave 384.94 installed and am able to play games in HDR without having Windows HDR on..

 

Good try Nvidia but Microsoft still needs to do their part too!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 29, 2020 Views 108,478 Applies to: