Windows HDR option within Windows 10 settings. Poor display quality when enabled.

Hi. :)

My TV is 100% HDR compatible. I have a Nvidia GeForce GTX1080 and can run games with HDR perfectly.

Normally when I output my display to my 4K HDR TV (single display 3840x2160p 60Hz) it's a perfect picture. Nice and sharp with vivid colour. However today when I changed the output to my TV the picture quality was very poor. It was nowhere near as sharp and the colours were very weak.

I went into the Windows 10 display options and noticed that there is option for 'HDR and Advanced Colour' which was set to 'On'. I don't remember having seen this option before. Is this a new option which has been included in the new Creators update?  

It appears as though this HDR option does not work as it should. When set to 'on' the TV automatically changes the picture mode to HDR as it should be but as I said, the picture quality goes bad. When I turn this option off the perfect picturequality comes back to what it should be.

Games still run in HDR when this option is turned off so I don't really know whats going on.

And is this option really needed when HDR compatible GPU's will automatically display HDR if required? 

If anyone can shed some light on this I'd be very grateful.

Many thanks in advance. :)

***Post moved by the moderator to the appropriate forum category.***

[Moved From: Windows / Windows 10 / Performance & system failures / PC]

 

Question Info


Last updated August 19, 2019 Views 98,385 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

We want to know more about the issue that you're experiencing. Please provide us the following information:

  • How do you connect your Windows 10 device to your 4K display monitor?
  • Have you tried troubleshooting this issue using Windows Update Troubleshooter? If not, please click this link.

We will wait for your quick response.

Regards.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Jennifer Cha. :)

Thank you for your reply.

I use a HDMI 2.0 Certified 18mbps cable to connect to my display.

I don't understand what troubleshooting Windows update would have to do with my issue. Windows update is working properly and all updates are installed.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The HDR options is included in the Windows Creators Update. Since you have been experiencing this issue after the update, it is possible that the update has not been installed properly or this is a potential bug that will be addressed in the next update.

For the meantime, we suggest that you try the following troubleshooting steps:

Method 1: Try to use a different HDMI cable to check if same issue will occur.

Method 2: Update the graphics card driver. You can uninstall the driver and restart your PC to reinstall it back, or you may also visit the manufacturer's website to install it manually. To learn more, click this link.

Method 3: Run the System File Checker or DISM to fix corrupted system files that may be causing the issue. To get started click this link.

We also recommend that you provide a feedback using the built-in Feedback Hub on your PC to let our developers know in case the issue still persist after troubleshooting attempts.

Feel free to post back for the result.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The HDR options is included in the Windows Creators Update. Since you have been experiencing this issue after the update, it is possible that the update has not been installed properly or this is a potential bug that will be addressed in the next update.

For the meantime, we suggest that you try the following troubleshooting steps:

Method 1: Try to use a different HDMI cable to check if same issue will occur.

Method 2: Update the graphics card driver. You can uninstall the driver and restart your PC to reinstall it back, or you may also visit the manufacturer's website to install it manually. To learn more, click this link.

Method 3: Run the System File Checker or DISM to fix corrupted system files that may be causing the issue. To get started click this link.

We also recommend that you provide a feedback using the built-in Feedback Hub on your PC to let our developers know in case the issue still persist after troubleshooting attempts.

Feel free to post back for the result.

Hi.

The creators update has been installed correctly. I also installed it on my other PC and it has the same problem with the HDR setting in the 'Windows'display options.

The fault is not with the HDMI cable. The cable works perfectly and so does HDR on games. However as you asked I did use a different cable and I get the same problem.

It's not a driver issue. My drivers are all up to date too.

SFC returns no errors nor does DISM.

Maybe the HDR option in the windows settings it just buggy at this time. It wouldn't surprise me. Windows 10 has a lot of annoying little bugs. Even more so after the Creators update. 

Thank you for your assistance so far.

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We appreciate your response. For us to get a proper report about the HDR issue and for additional troubleshooting assistance, you may also get in-touch with our Answer Desk associates using this link.

Feel free to post for other inquiries.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi. :)

My TV is 100% HDR compatible. I have a Nvidia GeForce GTX1080 and can run games with HDR perfectly.

Normally when I output my display to my 4K HDR TV (single display 3840x2160p 60Hz) it's a perfect picture. Nice and sharp with vivid colour. However today when I changed the output to my TV the picture quality was very poor. It was nowhere near as sharp and the colours were very weak.

I went into the Windows 10 display options and noticed that there is option for 'HDR and Advanced Colour' which was set to 'On'. I don't remember having seen this option before. Is this a new option which has been included in the new Creators update?  

It appears as though this HDR option does not work as it should. When set to 'on' the TV automatically changes the picture mode to HDR as it should be but as I said, the picture quality goes bad. When I turn this option off the perfect picturequality comes back to what it should be.

Games still run in HDR when this option is turned off so I don't really know whats going on.

And is this option really needed when HDR compatible GPU's will automatically display HDR if required? 

If anyone can shed some light on this I'd be very grateful.

Many thanks in advance. :)

I'm having this issue too. This is happening on 4K displays connected via HDMI. The Windows 10 HDR feature does not work properly when pixel format is set to output at YCbCr 4:2:2 with a color depth of 10 bpc or 12 bpc. New video drivers were released by both Nvidia and AMD to use the Windows HDR feature instead of their own. If you roll back to an older video card driver, HDR should work properly again in games. That's what worked for me. I had zero problems with HDR content prior to the creators update. Microsoft needs to test this some more. 

35 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Wufei1981 :)

I'm sorry that you have the same problem as I but I'm happy that it's not only me who is experiencing this issue.

As HDR in games automatically switches my TV's mode to HDR when I play them I Initially didn't see what the point was in having a HDR setting in the Windows display settings. But then I thought about 4K HDR movies. When I play movies on my PC the HDR picture mode on my TV never worked. Maybe it was the media player I was using that didn't work with HDR. Maybe it was just because Windows didn't have a HDR option. If it is the latter of the two then it would be very good if Microsoft can fix this issue and allow us to watch HDR 4K movies in true HDR.

Does anyone know if Windows !0's built in media player supports HDR? If not then I think MS should make it so. 

If anyone knows of a media player for Windows 10 which supports HDR please let me know. Thanks. :)

 

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Jennifer :)

I used the link you provided for the Answer Desk support. This did not provide any answers. I then clicked on the 'Call me back' option but I could only choose US or Canada. I live in the UK.

Please advise.

Thanks.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here's the additional information that you requested so you can contact our level 2 support. To get help from our Answer Desk global support, click this link. We also suggest that you start a chat conversation with them so they can guide you while working on your PC or have them set a callback if in case the issue is still not resolved.

Best regards.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Jennifer :)

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.