Windows 10 Taskbar Won't Auto-hide

For some weird reason, my taskbark just doesn't seem to want to auto-hide. I've checked the box that says to auto-hide it, but it just stays locked. It works for a few minutes when I restart my computer, but seems to just go back to staying locked. Anyone find a fix for this? 
 

Question Info


Last updated April 21, 2019 Views 42,503 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Spazzin,

Thank you for posting your query in Microsoft Community.

I understand the inconvenience caused to you. I will be glad to assist you with the Issue.

I would suggest you to try the below step and check if it helps.

Try this:

  1. Press Windows Key + R on your keyboard.
  2. Key in PowerShell and hit Enter.
  3. Right click on the PowerShell icon on the taskbar and select Run as Administrator.
  4. Now paste the following command in the Administrator: Windows PowerShell window and press Enter key:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

  1. Wait for PowerShell to execute and complete the command. Ignore the few errors (in red color) that may pop up.
  2. When it finishes, try hitting Start and hopefully it’ll start working. If not, this solution won’t apply to you, unfortunately.

Also install all the Windows update.

Try the above step and let us know if it helps. For further assistance feel free to post your queries in Microsoft forums. We will be glad to assist you.

Thanks

272 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Sangeeta!

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It actually worked. Thank you. 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Didn't work for me.

I still can't auto-hide the taskbar even though auto-hide is checked.

Also, please help me with another taskbar issue.  I only see the search icon and when I right click on the taskbar and choose search, I don't have the option of enabling the search BOX instead of the search ICON.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you check for updates/restart your computer after? It worked after I installed an update and restarted my computer. 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Auto-hide works now.  I just had to restart.

But I'm still facing the issue about not being able to use the search box on the taskbar.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you right-click the taskbar, go to search, and click show search box? 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Of course I tried that because it works on my laptop but not on my desktop pc.

I called Microsoft about this issue of not seeing an option to enable search box but they said they don't know what is causing the bug.  Last time I had to downgrade to windows 8.1 and the upgrade back to windows 10 just to get the search box back.  

Guess that is what I'm going to do again.  It sucks.  Microsoft needs to fix this bs.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, I just found out that if you right click taskbar and click properties you will see the option to "use small taskbar buttons."  Now, if this box is CHECKED then you will NOT have access to enable the search box function whatsoever.

Thanks for nothing Microsoft.  I can't believe I spent so many hours on hold trying to find out a solution to this problem only to be told that Microsoft doesn't know why I couldn't enable the search box.

I downgraded to Windows 8.1 and upgraded to Windows 10 about 3 times before I figured this out.

[Removed by MSMODs]

At least I can auto-hide the taskbar now.  lol

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Has made no difference. Not exactly a major thing, but considering I had to wait for the upgrade, you'd think you'd have sorted minor issues like this.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.