re-arrangement of keys in keyboard

The following keys in my desktop keyboard have rearranged themselves without my doing anything.

Keys @ and " have changed place each other.

So if I want to use @ key, I have to press " key and vice versa.

Please let me know how to fix this issue so that these keys are in their correct places in the keyboard.

Thanks,

Balakrishnan.

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated August 20, 2019 Views 940 Applies to:
Answer
Answer

Balakrishnan,

Change keyboard region back to the intended one, prevent accidental keyboard changes

Your keyboard layout has been changed from your normal one to another [e.g. from UK to US or from US to UK].  Switch your keyboard region back to the one for which your keyboard was designed.

1  You can change this through Control panel -

  • Start button,
  • Scroll down to Windows system & click on it to expand it,
  • Control panel,

  • [View by - Small icons, just so you can see everything],
  • Language,

  • [next to the existing keyboard entry] Options,

  • Add an input method,

  • scroll in the list of keyboard layouts 
  • use Preview to find out which layout matches that of your actual keyboard,

  • Add,
  • In Input methods you'll now see the new one added so click on Remove next to the wrong one i.e. the original one that was giving you the wrong keyboard characters.
  • Your keyboard should now behave as you intended.

- - - - - - - - - - - - - - - - - - - -

2  I always then take a further precaution to avoid any accidental switching between input methods [to remove the hotkeys that switch language input methods and cause this type of problem].  You will not want to use these steps if you do really use multiple languages and you want to be able to switch between them easily using hotkeys.

  • Back in Control panel, Language,
  • Advanced settings,

  • Clear the Use the desktop language bar when it's available [unless you have some particular need for it]
  • Then Change language bar hot keys & select the Advanced key settings tab,

  • select the Between input languages entry in the list and click on Change key sequence,

  • Change both entries to Not assigned then OK,
  • Back in the list, select your normal language entry [To English ..., in my case] & click on Change key sequence,

  • Make sure that the Enable key sequence checkbox is clear,
  • OK, OK.

Denis

Try*3 - a user
Dell Inspirons 7779, 1545, 9300; Windows 10 Home x64 & Pro x86; Office Pro 2007; HP DJ2540; HTC UPlay [Android 6.0], MyPhoneExplorer

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.