Prevent Auto Monitor Detection

First off:

STOP THINKING FOR THE USER!!!!!!!!!!

I go to post, I type in a title and then click on the body to type, and suddenly your system pops up some infernal message blocking my typing, which upon space bar sends me to that first link and I'm no longer on the page to post for the forum.  Requiring two steps at this juncture is NOT efficient customer service.  That **** me off more than then problem that brought me here, so now i'm doubly pissed.  I am smarter than any computer and the continual insult that I am not gets on my nerves.  I clicked "Ask the Community" for a reason.  If you have suggestions for my title, GREAT. But don't interfere with my typing.  I am not some idiotic mouse-clicking-image-based mac user.  I'm a typist and a developer, and I know what I want to ask, and how I want to ask it, and don't need your development staff thinking they know better.

That being said:

Also in the realm of "Thinking for the user".

I have tried, Win+P, I have tried the NVidia control panel, and I've tried the Control Panel | Display window.  (So don't suggest them).

Every time i try to disable the 'second monitor' (A Panasonic TV by way of a Yamaha Amplifier) within moments Window 10 annoyingly re-enables it.

I get just plugging a monitor is all well and good for plug and play, but when the user SPECIFICALLY SAYS TURN OFF, it should stay off.  I don't care if i unplug and plug it back in again, or if the Yamaha amplifier flickers its voltage making the computer think a secondary monitor was unplugged and plugged back in.  The User Command is GOD.   User specifically turns off the monitor, it should not reactivate until the user specifically turns it back on.

The reason is, that when I switch the Yamaha input from HDMI 3 (my computer) to AV1 (the TV) i get flickers on my lap top monitor.  It constantly hiccups and refreshes as if it is added and removing the monitor ever other minute.  THis is annoying.  Since I am watching TV I don't need the second monitor, but I shouldn't be required to unplug my TV connection EVERY TIME I want to watch something other than my computer screen.  I want it to simply be a key command, which the concept of Win+P suggests it could be. 

However, when I hit Win+P and Select "PC Screen Only", 3 minutes later, it auto-resets back to "Extend Display".

Ideas on how to resolve this?

Thanks

Jaeden "Sifo Dyas" al'Raec Ruiner

 

Question Info


Last updated November 10, 2018 Views 4,704 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Thank you for posting the query on Microsoft Community. I am glad to assist you on this.

I would suggest you to disable Transient Multimon Manager (TMM)  in the Registry of Windows 10 and check if it helps. To locate this you can follow the below path.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TMM

Follow the below steps and check if you can disable Automatic Monitor Detection.

1) Press the Windows + R button to get the Command prompt.

2) Type regedit then press Enter

3) Navigate to the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TMM

4) Look for the value "UseIViewHelper" and change it to 0 or if you don't have that key then simply right click in the TMM sub key and create a new DWORD giving it the name UseIViewHelper then set its value to 0

Note: To re-enable Automatic Monitor Detection, simply go back to the same reg key and change the value of "UseIViewHelper" to 1

Registry disclaimer

To do so: Important this section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

http://support.microsoft.com/kb/322756/en-us

How to back up and restore the registry in Windows

I hope this information helps. Please do let us know if you need any further assistance.

Thank You.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sadly this doesn't work for me.

I changed the value of "UselViewHelper" to 0 and rebooted, but Windows 10 still auto-detected the monitors.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Bump!

Any look with this? 

This is driving me insane and NOTHING seems to work!

Thanks in advance.

Harry

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Harry,

I would suggest you to perform clean boot and check the issue.

Refer:
How to perform a clean boot in Windows
https://support.microsoft.com/en-us/kb/929135
(Also holds good for Windows 10)

Clean boot is performed to start Windows by using a minimal set of drivers and startup programs. This helps eliminate software conflicts that occur when you install a program or an update or when you run a program.

Note: After you have finished troubleshooting, follow these steps from section “How to reset the computer to start as usual after clean boot troubleshooting” to reset the computer to start as usual.

Please keep us posted.

Thank you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Please Microsoft stop filling your own forums with millions of replies like "perform a clean boot, or reinstall the system". There are a lot of users who are facing this issue, and even if a clean boot might fix the issue (not in this case, the issue even persists after a *clean install*), the underlying problem is not solved, and it might re-appear when the same conditions are met again.

It's ridiculous to suggest a clean boot for every problem. If one of your "Support Engineers" doesn't have a clue about a specific issue, it's much better if they don't post at all, than to spam the forum with banal advice.

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Arul, 

Unfortunately the above has still not worked, upon "Clean Booting", Windows 10 is still thinking that I'm unplugging my monitors when I'm simply turning them off. 


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Agreed!

This is obviously an issue with Windows OS itself and the way it handles these connections. (Display-port and HDMI)  

This needs to be solved as It's just unacceptable to deal with! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Arul,

Do you have any further updates or fixes for this issue as it still very much an active issue. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Arul,

Do you have any further updates or fixes for this issue as it still very much an active issue. 

It's been a problem since Windows Vista. It's a problem that's 10 years old and they just ignore it and fill forums with the same useless solutions. They will not fix this. 

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Good news!

I have managed to resolve this issue myself with both of the following fixes/work around's;

1. Use my Macbook plugged into multiple monitors and run a Windows VM... (Yes this is actually more useful than MS' response) 

2. Buy an Nvidia graphics card and make some slight adjustments, which is turn disables the auto detect feature on the card. 

Unfortunately, still no look with finding a fix for AMD cards.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.