Fuzzy fonts and large icons on external monitor - Is scaling the issue?

I have a Windows 10 laptop with 1440p screen and at 150% scaling, everything looks great and sharp.

The laptop is also connected to an external monitor (Dell U2415H 1920X1200) set at 100% scaling. But only on the external monitor, apps like Chrome, Adobe Reader, Office 365 look blurry, and icons appear disproportionately huge.

But system apps like File Explorer would look fine on the external monitor.

Since Windows 10 allows separate scaling for different displays, why is this still happening, and how can it be resolved?

 

Question Info


Last updated August 23, 2019 Views 13,064 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for posting your query in Microsoft Community.

I do understand your concern, you can go ahead and change the icon size manually by right clicking on the desktop screen> View by> Small Icons.

 

Make sure you install all the pending Windows update and install the latest graphics drivers from the manufacturer’s website and check if it helps.

 

Thank you.

Thank & Regards,

SuJata Moktan.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm sorry that doesn't address the issue at all.

The issue is not about the size of desktop icons which your solution addresses.

Let me reiterate. It is the fonts and buttons of apps that look fuzzy and disproportionately large on the external monitor only. These apps are: Office 365, Adobe Reader, Google Chrome.

Is this about scaling, and is there a fix?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,
Please follow the steps and check if it helps:

How to use display scaling in Windows 10

You can find the scaling options by hitting the Windows key (or clicking on the Start button) and typing “scaling” into the search field. The setting you want is called “Change the size of the Apps on the screen”.

Windows 10 will open the display settings as below. If you haven't already connected your second monitor, you'll need to do that now before continuing.

Select “Extend these displays” from the dropdown menu, and tick the box to indicate which of the two is your main screen. Windows 10 also lets you virtually rearrange your desktops, so you can specify which monitor is on which side, and optionally adjust the relative heights of your displays by dragging the screen images up and down. Once you've told Windows how your screens are set up, click Apply to save changes.

By default, Windows will use the same scaling for both of your screens. If you want to increase the size of windows on your second monitor, simply return to the Display settings. Click on the screen whose scale you want to adjust, then drag the slider marked “Change the size of text, apps and other items” to the right to increase the size of windows. To save changes, just click Apply.

Display Scaling in Windows 10

Hope this helps and do let us know if you need further assistance. We will be glad to help.

Rohit Chettri
Forum Moderator

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Could you act like a professional and stop giving us childish solutions. We are not kids and we ask MS, only when all the methods do not work. So, if you do not know the answer, you better ask someone senior or just ask the developers to rectify the issue. Because we have already paid hundreds of pounds for Windows OS. We are not here to listen to your silly childish answers...

28 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The real issue is that there is no separate scaling available if using a second monitor as an extended desktop.  The referenced slider to change the size of apps/text, etc. is only available for the main screen.  For my laptop, I need to set the slider at 225% to be able to see the icons and be able to read the text in a reasonable size.  This same 225% setting is then applied to the second monitor where the toolbars end up taking up 1/3 of the screen (only for certain apps).  Is there a way to have separate scaling for each monitor when using as an extended desktop? Thanks.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Exactly!  If you are going to try to answer a question, read the question carefully and make sure you are actually answering it.  Don't give obvious solutions when the user has stated quite clearly that the problem is different.  Did you read:

"only on the external monitor, apps like Chrome, Adobe Reader, Office 365 look blurry, and icons appear disproportionately huge.   But system apps like File Explorer would look fine on the external monitor."

So clearly your answer is not going to address that problem.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Rohit,

I'm having the same issue.

So, is there a solution to this problem?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

AMEN!  I get so tired of all these support people providing pat responses that do nothing to help most of us.  Thanks for calling that out.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I believe I've figured this out!

I was having the same issue. Whenever I had extended displays a lot of things on the external monitor show up with huge fonts (example: "save image as" and the dialog box shows up in huge boxes and fonts)

All I did was change the scaling to 100% on "display settings", but (very important) right after you do that, you need to "sign out" and sign back in. 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks very much.. But we knew this for a very long time although you found this today. Go to older posts and see how many times the work-around you suggested has been mentioned.. But our problem is that, even though we set it to 100%, it does not solve our problem. That is our issue... and we knew that we have to logout and login back. Thanks for the post. But its useless...

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.