FIX - Windows 10 Taskbar Not Functioning (Start/Search/Settings/etc.)


1. Find C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe

2. Right-click and Run as Administrator

3. Copy this line:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

4. Right-click in the Powershell window to Paste and then press Enter.

5. There is no need to restart. The fix should implement right away.

If you have previously disabled Windows Firewall or do not have it running, the above steps will result in errors. Use the steps below to enable Windows Firewall and the reverse if you wish to turn it off again afterwards.

1. Right-click the Start button -> Click Run

2. Type Services.msc and press Enter

3. Scroll down to find Windows Firewall

4. Right-click then click Properties

5. Under Startup Type dropdown -> Select Manual. Click Apply

6. In the top left portion of the Services Window, Click Start this service.

7. Now follow the steps in the first section, and it should work.

These steps worked for me. They have no guarantee to work for you. Just trying to spread some help/love. Best of luck to all in your troubleshooting. 

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

That works for me...

  • Press [Ctrl]+[Shift]+[Escape] to start Task Manager.
  • Click File -> Run new task.
  • Type "cmd" into the Run dialog, tick Create this task with administrative privileges and click [OK].
  • A command prompt window should open.
  • Type/copy the following text and press [Enter]: net user Admin123 MyPassword /add
  • Type/copy the following text and press [Enter]: net localgroup Administrators Admin123 /add
  • Log off and login to the new Admin123 account.  If it works correctly, you can migrate your data to the new user account.  You are welcome to replace "Admin123" with your username of choice (just enclose it in quotes if it has a space, and be sure to use the same name in both commands).  The login password will be "MyPassword".  You can easily change it later.
  • Log off
  • Log on on new account 
  • done *

Just do that steps, will work....

Microsoft has worsened over the years....

Had 3 bugs and microsoft solved nothing, only the desperate users can do.

For me, everything was a firewall issue (ESET, an external firewall that didn't start up visibly).

I just signed into a different account, where the firewall didn't block the initial setup. After that, my usual account worked without creating a new one.

BTW: I also made the steps mentioned initially but nothing changed.

Windows firewall must be enabled to run the powershell script. If not, it won't allow the files to be installed. After I did the steps with WF on, I just clicked the start button 3-4 times and it worked as normal.
Thank You Very Much saved the day...for me anyway.  Your suggestion worked like a champ and now I have everything working again.
...not only is my Start Menu and Taskbar working, but Microsoft Edge is working as well.  Until now, Microsoft Edge would give me an error message that said "...trial has expired...go to Windows Store to purchase app..."  Didn't make sense...but no matter now...if is FIXED!

This doesn't work for me. I followed all steps as instructed. 

This is what I get:

You can try running a system scan and it will repair files if they need to be.

Right-click Start and open a command prompt as administrator

type sfc /scannow 

Let it finish and see repairs anything. If so, try the steps above again.

Didn't work for me....

I was just starting the above described Powershell thing but was struggling with rightclick that did not work so I could not run it as an administrator. So I did a computer reboot and in the reboot process it installed an update from Microsoft. Immediatelly after the reboot I found that all my taksbar and righclick problems disappeared. So apparently Microsoft found a fix for the problem and is pushing it out. Saves me a lot of hassle !

any ideas what KB for this fix?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.


Discussion Info

Last updated July 16, 2020 Views 333,345 Applies to: