desktop icons keep moving in windows 10

desktop icons keep moving in windows 10

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Unchecking the 'Allow Themes to  change icon' option does NOT stop the problem for me - nor does unchecking 'Auto-Arrange' option (found via Right click on DT > 'View' )

26 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Where do I find the last sub-key which in this case is InProcServer32?

Thank you

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have been having this problem since about a week ago.  I just checked "Auto-arrange icons" under the desktop right-click-->view menu, then refreshed, then unchecked the "Auto-arrange", replaced my icons where I wanted them, and refreshed again.  It looks like the problem is solved after putting the machine to sleep and waking it back up.  Fingers crossed it holds up.

Hope this can help someone else.

19 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same issue. Brand new HP spectre 360 and I can not get the desktop icons to stay where I put them. I have unchecked and checked auto arrange several times. Also checked and unchecked the grind in combination with the auto arrange but every time I turn my laptop on and off they are always rearranged. Is there any answer to this yet?

8 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I also had auto arrange unchecked, had upgraded drivers and all the bit and it still occurred.  I wanted to share this information that I found yesterday.  It has worked so far in keeping my icons in place (fingers crossed that it continues):

  1. Right click on the desktop

  2. Select View

    1. Uncheck ‘Auto Arrange Icons’

    2. Check ‘Align Icons to Grid’

  3. Arrange your icons in the way you want them

  4. Right click on the desktop

  5. Left click Refresh (this is the key for Windows remembering your icon location.  There is something that makes Windows forget – sometimes and only sometimes.  I’d suggest clicking refresh several times.   I also restarted after and hit refresh again just for good measure– like an elevator button for an elevator not arriving fast enough, useless likely but you feel better). 

52 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

tried this but didnt stick, does anybody have a solution or will microsoft even bother to fix this problem....**** me off when ever the computer resets, sleeps, or i switch or mirror to the tv that this sh** keeps happening

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

tried this but didnt stick, does anybody have a solution or will microsoft even bother to fix this problem....**** me off when ever the computer resets, sleeps, or i switch or mirror to the tv that this sh** keeps happening

Sorry, these steps finally worked for me. I hit refresh several times and restarted. It has been several months and they have not moved again.  

I read another location to be sure your drivers are up to date. May be worth a shot. Good luck

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi MS fellow,

this answer is not helpful but trivial. In another thread several hundreds have posted their frustration with this topic. One of them has even twittered Gabe Aul, a hot shot manager at MS without any reaction.

Best regards
Jörg

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Its a problem well known in the community. Another tread has hundreds of post. But even Tweets to Gabe Aul did not change a thing.

Here my opinion to the facts:

The reason for all this is the new booting process started with Windows 10 where MS has changed to an "always on" philosophy. This has produced some severe incompatibilities in functions that depend on solid hardware-information like the screens attached. On the other side, many larger screens no longer support DVI as their host-protocol but need DisplayPort or HDMI.  Many of them don't deliver configuration data to the drivers. This altogether leads to calls of graphic drivers to the Shell with default a screen resolution of 1024 x 768. The Shell Shell simply tries to map icons and windows into this "new" screen size. This works as designed. You can check that yourself by trying to drop any icon onto an existing non-folder icon and you will see how icons are moved. After any changes, the icon positions are stored in a "bag" which is index by screen resolution.

And here a typical MS bug rises its head: Instead of saving the rearranged icon positions in their proper bag, they are saved in the "actual" bag which has been remembered from the last boot. Et voilà, they are scrambled on the screen. And there seems to be no way to convince MS to put this on the bug-list.

Here are some possible workarounds (Ordered with increasing complexity to handle):

  1. Use a display driver that is designed to support Windows 10.
  2. Disable the "Generic PnP Monitor" driver using Device Manager if you don't have a native DVI attachment to your monitor. This is hard to check on laptops!.
  3. Use the standard display drivers from Microsoft. It should be always offered, when you want to "Update" the display driver from sources on your PC.
  4. Use a screen and a graphics card with native DVI adapters. Be aware of restricted refresh rates in this case.
  5. Use a save/restore software available from the internet. Be aware of virus threat!

I'm using an EIZO 27" 2560 x 1440 monitor and an Intel 4600 integrated graphics engine on an ASUS board with display port cabling. My icons were misplaced after each boot or wake up.

To fix this, I changed to MS standard driver first. Sleep mode was gone with it! Then I had some postings with the Intel support. Since the last update from Intel to driver version 20.19.15.4331 all my 60 icons rest in peace at the locations I put them.

Best regards
Jörg

12 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

thanks, will try some of those

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated March 3, 2021 Views 89,273 Applies to: