Screen Auto-Rotate Not Working with Windows 10 on Tablets.

Hi, I recently downloaded Windows 10 for my Nextbook 10.1" tablet. My screen doesn't automatically rotate when I turn it from Portrait to Landscape and use the keyboard. It stays in portrait mode and the screen is sideways. I was wondering if there is any way I can fix this. Thanks
 

Question Info


Last updated February 13, 2020 Views 96,100 Applies to:
Answer
Answer

Hi Guys

I had the same problem with my 2 nextbook tablets. It turns out to be a problem with the Kionix KXCJ9 Accelerometer SPB drivers and the Kionix Sensor Fusion Device in the device manager.

Below is how I resolved the issue. 

1. go to device manager and ensure you update the drivers for the following 3 devices. you will need to be connected to the internet to do this. Double click the device and go the "device" tab. click on the "update driver" button and choose to "search automatically for updated driver software" let it pull the 2015 drivers off the internet. do this for the below 3 devices

  a. "sensor I/O devices --- Kionix KXCJ9 Accelerometer SPB"

  b. "Sensor --- Kionix Sensor Fusion device"

  c. "Sensor --- Sdo Sensor V2"

2. Now you are going to have to play in the registry a bit.  tap and hold the "windows start icon" for a bit longer (right click) then tap on "run" and type "  regedit  " (no ") . a user account control window pop up comes up click "yes"

3. Now expand "HKEY_LOCAL_MACHINE" then expand "system", then expand "CurrentControlSet", then expand "Enum", then expand "root", then expand "SENSOR", then expand "0000", then expand "Device Parameters", then click on "kxfusion"

4. On the right hand window double click on "ACPI\SMO8500\1-0" make sure the value data is the following

     {CDA4B5F8-53B4-4E7C-8A73-0D69852FBEBA}

5. Now in the same window double click on the "Orientation" and make sure the Value Data is the following

     0000   01 00 00 01 01 00 02

   Now the above value may vary by manufacturer so if you have a problem and notice that your rotation is 90degrees off you may have to try a couple of different values ie   0000  01 01 00 00 01 01 02

These are from what I can see the settings for the x-y axis of the device accelerometer

6. close regedit and reboot the device everytime you try a different value in point 5.

I hope this helps everyone and you get to enjoy Windows 10.

94 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi, I recently downloaded Windows 10 for my Nextbook 10.1" tablet. My screen doesn't automatically rotate when I turn it from Portrait to Landscape and use the keyboard. It stays in portrait mode and the screen is sideways. I was wondering if there is any way I can fix this. Thanks

Hi Tommyboy82,

I've searched far and wide for a solution. For now, it looks like there are only simple workarounds and no true solution for regaining the auto-rotate feature. You have to manually rotate the screen:

First Method: 

With the keyboard connected, press Ctrl + Alt + [directional key]

The directional key could be the up arrow, down arrow, left arrow, or right arrow depending on your preference.

(This keyboard shortcut/command should work in most versions of Windows on all PCs.)

Second Method:

Find an empty space on the desktop.

Either tap and hold with your finger, or right-click blank space on desktop. Go to Graphics Options > Rotation > select desired rotation angle.

Third Method:

Start Menu > Settings > System > Display. Click the box under Orientation > make a selection.

This third method may prove most useful without a keyboard while multi-tasking. The window with the display settings can be kept open or minimized, and you can always bring it back up to quickly change the orientation at will.

Note:  This applies to the screen rotation issue for the Nextbook 10.1 as well as the Nextbook 11.6 after updating to Windows 10.

I found this was the issue on both systems, and it obviously didn't matter whether it had been an "in place upgrade" or a "clean install"; either way the issue persists after installing W10.

Also, I noticed that an internet search for "auto rotation windows 10" reveals that Nextbooks are not the only tablets affected. Microsoft might consider this "expected product behavior" for its latest operating system.

While I know that this is not the solution any of us hoped for, I do hope it was helpful to see these methods for manually rotating your tablet's screen. If anyone else has more information, please do share. Cheers :)

124 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.