How to enable NumLock key in Windows 10

How do I enable the NumLock key in Windows 10 before logging into an account without pressing the key?  Does one have to edit the registry or is there a setting for the key?
 

Question Info


Last updated May 30, 2020 Views 22,536 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I found the answer by checking the forum for the same issue in Windows 8.1.  The following is what I found by users posted on the forum and appears to work with Windows 10 Pro: 

Open the registry and go to HKEY_USERS\DEFAULT\Control Panel\Keyboard

Look for Initialkeyboardindicators in the right panel

The value I observed was 2147483648

Change the last two digits from 48 to 50 as underlined above

Thanks to everyone that posted an answer for the same issue in the previous editions of Windows.

35 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sadly none of the suggested registry edits work in this case. Microsoft are still working on this problem and have acknowledged its an unresolved Win 10 issue.

When you consider that they are also actively promoting PIN entry at Login, it us an issue that is/will affect more and more Win 10 users in the coming weeks.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately this doesn't work for me and a hard reset (i.e. power down)

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This suggested edit of the registry worked for me.  Part of my initial log in password includes numbers so it was annoying to have to input my password, realize the NumLock key was not activated and have to press the NumLock key and input my password again. I was apparently slow to realize that this was something Windows 10 was doing - upgraded from Windows 7 so didn't know this had been a known problem with the last versions of Windows.  A simple search for "Windows 10 and NumLock key" showed me that many of us are/were having the same problem and it was being caused by the OS.

This "fix" must be a bit of a pain for those who aren't comfortable working with the Registry and it seems hard to believe that Microsoft has been dealing with users complaining about this annoyance since Windows 8 but still didn't bother to change the behavior in Windows 10 when they had plenty of time to do so before rolling out their "brand new....but still based on DOS, lol..." operating system.

(Slightly off topic:  Guess I shouldn't be surprised by Microsoft and their habit of introducing new products that really aren't quite ready for prime time.  Their own gaming site, the MSN Game zone, lets you know that you should be using Internet Explorer instead of their new browser, Edge; apparently they haven't bothered to optimize their own site to make it compatible with Edge!  The site doesn't recognize that Flash is integrated in Edge, either, says you need to download the latest version of Flash....  Silliness!)

8/14/2015 update - well, I thought the registry edit worked.  I had restarted my system after doing the edit yesterday and the numlock key remained activated, but when I booted up my system this morning, same old problem, the NumLock key was not activated.  I did some more research, found the below "fix:"

1. Go to your lock screen - restart your system or click on the Windows key + "L" key to get to the lock screen.

2.While on the lock screen, press and hold the NumLock key.

3. Go to the power options icon on the bottom right side of the screen and  click the "restart" option while still holding down the NumLock key.

4.Theoretically, the NumLock key will remain activated for ever and ever now.

I am not sure why this would work, and it didn't work for me, but apparently some people have had luck with it so it might be worth a try.

Microsoft's arbitrary decision to override our personal preference to have the NumLock key always activated is beginning to **** me off!  There is a reason why we have it set to "always on" in the BIOS.  Sure, it is easy enough - once you get into the habit of doing so - to activate the number key after your system has booted into Windows so that you can put in your correct password - with numbers -  but why should we have to?  Setting this in the BIOS has been all we have needed for YEARS, until Windows 8.  You would think they had received enough complaints about that, and yet they programmed in this same behavior in Windows 10 AND somehow have disabled the end users' ability to apply any of the fixes found  previously.  WHY????!!!!?????   (I know shouting doesn't help, but it made me feel better!)

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes. I'm fully at ease editing the Registry. But the suggested fix did not work for me. Win 10 sets a lot of defaults in their revised Login screen with the new Pin Code option. The majority of the laptops and desktops we've "upgraded" to Win 10 suffer the NumLck bug.

You are the lucky exception that proves the rule.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Robert - I had to edit my previous reply.  The registry edit didn't work for me, either, as I discovered today when I started up my system. 

There doesn't seem to be any sort of way to fix this problem; Microsoft apparently did something sneaky to take away the end users ability to customize their own computers - must be that old "Microsoft knows best" attitude.  I have no idea why they think having the numlock key inactive at boot up is a good thing and necessary, or why, on the other hand, they think having it always activated is a bad thing. 

Does anyone know why they made this decision in Windows 8 and insisted on keeping to it in Windows 10, despite the numerous "give us a NumLock fix" threads and posts by unhappy users?  Perhaps we would all feel better about it if we knew there was some sort of logical reason for the programmers and developers to have done this.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Finally found a solution that DOES work to keep the NumLock key activated under Windows 10 - disabling the "Fast start up" option.  I had seen this posted before but for some reason never tried to implement it until today.

Here is what worked for me:

1.  Go to the Control Panel (right click on Start button and choose "Control Panel" or press the "Win-x" keys to get to the same menu and choose Control Panel.)

2.  Click on the "System and Security" setting and then click on the "Change what the power buttons do" option under the Power Options heading.

3.  Click on the "Change settings that are currently unavailable" link near the top of this window.

4.  Under "Shutdown settings" uncheck the box in front of "Turn on fast startup (recommended)"  (logical to have a start up option listed under shut down options, right?!?) 

I shut down my system and rebooted it to make sure this worked; it did.  I am hoping that it continues to work - never know when a new update may disable this again, since for some reason MS doesn't want us to have the key activated at Windows start up.

At some point, or so I have read, Microsoft plans to phase out the Control Panel in favor of their new "Settings" application, but I would say the Control Panel seems to have more functionality than Settings, at least, this couldn't have been done with the current reiteration of Settings.  Makes me wonder what other personal preference options for our systems we might lose when MS gets rid of the Control Panel.  :-(

Holly

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sadly, Holly, didn't work for me.

Have had Fast Startup unchecked for weeks, and tried all combinations of Registry Edit as well.  No lasting success.

But maybe it might work for others (it's certainly been mentioned in many web pages). But you're right, WHY do Microsoft want the NumLk disabled at start up?

Illogical.  I mean WHO ever uses the keypad for anything other than numeric anyway!

Robert

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

:-(  So sorry this trick didn't work for you either, Robert. 

Even though this NumLock key activation problem seems to be intrinsic to the OS itself, the fix - and whether or not it works - must somehow have to do with our different system configurations and the way the OS interacts with the BIOS.  I can't think of any other reason these suggested fixes don't work universally.  If it was just a question of something in OS itself causing the problem, theoretically, the same fix should fit all!

Well, it wouldn't be Windows if there weren't annoyances that the end user has to deal with; thus far someone has been able to find a work around for many of the problems found with various operating systems, so hopefully someone will come up with something that works for Robert and the others who have no luck with the fixes currently 'discovered.' 

We may need to accept the fact that the "next best OS" will always come with its own built-in frustrations; no matter how "improved" the OS may be, some things get skipped/missed/screwed up or changed in ways that long time users don't like.  (What ever happened to the philosophy "if it ain't broke, don't fix it?"  They didn't need to mess with the NumLock key behavior, Windows users had been happy with the way it worked for years, and then Windows 8 came along...)

Holly

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Works for me. Thanks.
Don't back down when you are right!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.