Can't remove a Keyboard layout in Windows 10

I changed my computer region to USA for a reason and returned it back to Egypt.

But, There I keyboard layout was added which is English (United Kingdom) and rewritten in its description (United States - International Keyboard). How can I remove this? It doesn't in the settings.

 

Question Info


Last updated October 17, 2019 Views 80,209 Applies to:
Answer
Answer

Hi,

 

Welcome and thank you for posting your query in Microsoft Community.

 

Let us try the following steps, and check if it helps.

  1. Press the Windows key on the keyboard.

  2. Click on Settings, then click on Time & language option.

  3. Click Region & language on the top left of the screen.

  4. Click on Windows Display language to expand, and click on Options.

  5. Select the Keyboard layout, and click on Remove.

 

Hope it helps.

 

Let us know if you have any further query on Windows, we are glad to assist you further.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Finally found out what causes this problem and a solution for it!

Why this stuff happens: for some reason Win 10 adds "parasitic" registry key for default keyboard layout after some major updates. For my version it is US English layout. But I use only Russian and British (UK) layouts.

How to fix: simply delete key for that "parasitic" layout.

Step-By-Step:

1) Open registry Editor (Win+R -> regedit) as Administrator.

2) Navigate to Computer\HKEY_USERS\.DEFAULT\Keyboard Layout\Preload

3) Here you can see some files like this:

 

That is your layouts. Then, find keyboard codes using search engine you want.

In my case I have three layouts: 809 is for UK, 409 is for US, 419 is for Russian.

4) You know what to do. Simply delete unneeded key. 

5) Reboot you device. Voila!

!!!UPDATE PLS READ!!!

If you want this fix to be permanent:

1) Right-click on "Preload" branch and choose "Permissions".

2) Click on "Advanced".

3) Click on "Disable Inheritance" and confirm disabling. Then click "Apply" button.

4) Head back to "Permissions for Preload" and left-click on System.

5) In "Permissions for System" part of the window UNCHECK "Full Control" box and hit "Apply".

WARNING! DO NOT ACCIDENTALLY UNCHECK THIS BOX ON YOUR ADMINISTER USER

6) Reboot again. 

Be advised: after doing this stuff you WILL NOT be able to add/delete layouts. If you for some reason want to change your layout setting allow Full Control again, make your changes and then uncheck this box again.

!!!ONE MORE UPDATE PLS READ!!!

Seems like disabling Full Control for Preload folder doesn't work anymore.

Now you have to disable it for the whole Keyboard Layout branch. System looks stable for 2 days. No parasitic layouts spotted.

169 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.