Windows 10 Firewall will not open port

Hi,

I am trying to open up a port on Windows 10, but doing a port scan test shows that it Timed Out, but when disabling Windows Firewall the port test shows that its Closed instead of Time Out.

I have enabled the application in Windows Firewall as well as went into advanced security and specified a port for UDP and TCP to that application.

I have also opened up the port in my router and pointed it to the IP address of the workstation that needs the port opened.

I have successfully opened ports for other non-Windows applications in the past, I am not sure what I am missing or doing wrong.  If anyone can help I'd really appreciate it.

Thank you in advance.

 

Question Info


Last updated June 17, 2019 Views 7,371 Applies to:

Hi Mike,

Thank you for posting in Microsoft Community. I understand your concern and I am glad to assist you.

If Windows Firewall is blocking an application and you want to allow that application to receive info through the firewall, you can usually do that by selecting the application in the list of allowed applications, as described in the previous section.

However, if the application isn't listed, you might need to open a port (a way for applications to receive info through the firewall).

For example, to play a multiplayer game with friends online, you might need to open a port for the game so that the firewall allows the game info to reach your PC. A port stays open all the time, so be sure to close ports that you don't need open any more.

  1. Open Windows Firewall by swiping in from the right edge of the screen, tapping Search (or if you're using a mouse, pointing to the upper-right corner of the screen, moving the mouse pointer down, and then clicking Search), entering firewall in the search box, and then tapping or clicking Windows Firewall.

  2. Tap or click Advanced settings.  You might be asked for an admin password or to confirm your choice.

  3. In the Windows Firewall with Advanced Security dialogue box, in the left pane, tap or click Inbound Rules, then, in the right pane, tap or click New Rule.

  4. Follow the instructions on your screen.

Hope this post helps. Get back to us for further queries. We are happy to help!

Thanks & Regards
Joy

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Joy,

I have already done all those and still when doing a port test it shows Timed Out, but if I turn off firewall it shows the port is Closed.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

still it doesn't work

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I would suggest you to post this query on TechNet Forums as we have a dedicated team to further help with these type of issues.

Here is the link: https://social.technet.microsoft.com/Forums/en-US/home?category=Windows10ITPro

Hope this helps.

Thanks & Regards
Joy

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.