How to Switch user at Locked Screen in Windows 10

SOS, any ideas?

Running Windows 10 Pro on multiple PCs.  All PCs have multiple user accounts defined. Only one PC allows users to logon by picking their name from the list of users.  If a users is already logged on, and the desktop is locked, that user must log off entirely before the user list shows.

This is not the case on one of PCs.  On the one PC, if a user left the PC with a locked Desktop, any configured user can simply select their name and switch user without the need to log off the previous user.  All processes and apps are left intact as well for the previous user. 


I did notice that after pressing CTRL+ALT+DEL the PC that is working as needed offers the option to "Switch User" whereas the other PCs do not offer that option. 

I did read suggestions HERE to no avail.  Does anyone have any ideas?  We are not using picture security on any pf the PCs.  Any tips or help will be greatly appreciated.  

 
Question Info

Last updated August 14, 2018 Views 8,108 Applies to:
Found the answer to my problem, please see below:

Windows 10: Enable or Disable Fast User Switching
http://www.technipages.com/windows-10-enable-or-disable-fast-user-switching

Option 1 – Group Policy [This worked for me]

Hold the Windows Key and press “R” to bring up the Run dialog box.
Type “gpedit.msc” then press “Enter“.
The Local Group Policy Editor appears. Expand the following:
Local Computer Policy
Computer Configuration
Administrative Templates
System
Logon

Open “Hide Entry Points for Fast User Switching“.
Select “Enabled” to turn Fast User Switching off. Set it to “Disable” to turn it on.

Option 2 – Registry

Hold the Windows Key and press “R” to bring up the Run dialog box.
Type “regedit” then press “Enter“.
Expand the following:
HKEY_LOCAL_MACHINE
SOFTWARE
Microsoft
Windows
CurrentVersion
Policies
System
Look for a value called “HideFastUserSwitching“. If it does not exist, right-click the “System” folder, select “New DWORD 32-bit value“, then type a name of “HideFastUserSwitching“. Press “Enter” to create the value.
Double-click “HideFastUserSwitching“. Change the “Value data” to “1” to disable Fast User Switching, set it to “0” to enable it.

15 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.