how to change folder and file permissions in windows 10

how to change folder and file permissions in windows 10
 

Question Info


Last updated October 22, 2019 Views 35,343 Applies to:

Hi David,

 

Thank you for contacting Microsoft Community.

  • Are you trying to give permission to particular files and folders?

I suggest you to follow the below step and check if it helps.

  1. Once you choose the file that you want to give permission, right click on it.
  2. Click on properties and go to security tab, check whether any permission have been set.
  3. After you have viewed the permissions that are already set, you can now click on the Advanced Button that is right below the "Permissions for Authenticated Users"
  4. Once you have clicked Advanced, a box like this should appear, the "Permission Entries" box, which shows all the permissions that are set for the users. Now, after you have spotted the user whose permissions you wish to change, click "Change Permissions.
  5. Click on the user you would like to edit, and then click the option that says "Change Permissions" which is right below the box.
  6. Once that is clicked, you are going to get the same box pop up, but this time, you can actually edit the options. You do that by clicking the "Administrators" user again, and this time, you are going to click the "Edit" option.

Hope this information was helpful and do let us know if you need further assistance. We will be glad to assist.

32 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

All boxes are grey . How should I continue ?

64 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi David,

Thank you for contacting Microsoft Community.

  • Are you trying to give permission to particular files and folders?

I suggest you to follow the below step and check if it helps.

  1. Once you choose the file that you want to give permission, right click on it.
  2. Click on properties and go to security tab, check whether any permission have been set.
  3. After you have viewed the permissions that are already set, you can now click on the Advanced Button that is right below the "Permissions for Authenticated Users"
  4. Once you have clicked Advanced, a box like this should appear, the "Permission Entries" box, which shows all the permissions that are set for the users. Now, after you have spotted the user whose permissions you wish to change, click "Change Permissions.
  5. Click on the user you would like to edit, and then click the option that says "Change Permissions" which is right below the box.
  6. Once that is clicked, you are going to get the same box pop up, but this time, you can actually edit the options. You do that by clicking the "Administrators" user again, and this time, you are going to click the "Edit" option.

Hope this information was helpful and do let us know if you need further assistance. We will be glad to assist.

this is for a file... how for a folder and ALL subfolders and files

thanks.

thomas acito

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I do not see a security tab under properties

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The options are greyed out, even though I am an administrator and this folder belongs to me. Why?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found out what was wrong. Microsoft encourages login with a microsoft account, but even though it says it is part of the administrator group, you don't have those priviledges. You need to create and login using a local account (that is also an administrator).

Windows 10 is not making good first impressions.

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.