Folder and file permissions changed in Windows 10

Got the upgrade to Windows 10 done successfully, but now when I use it, I have all sorts of messages from my applications that I don't have the right permission to access a data file, or I have to be an administrator (which I was in 8.1).  I can't even write to drive C.  Is there some major change from 8.1 to Windows 10 that is preventing me from accessing my own files, from opening data files or writing files? 

Example - trying to open Outlook, I was told I didn't have the right permission to open the *.pst file.  Then in Quicken, I was told I didn't have the right permission to open my data file, did I want to make a copy and open it from a different place (?).  Just a couple examples of where the applications are hitting roadblocks based on my permissions - never had that in Windows 8.1, I had access to everything.

I have tried changing permissions on a folder basis, a file basis and also changing permissions in groups.  It looks like this version is trying to force you to have a separate administrator account and a separate user account, but since I am the only one using the files and apps, I have been "both" as administrator. I can foresee hours and hours of fixing files, there was no warning on this. 

Is there a simple top level fix?

Thank you,

JC

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have the same permission issues. I am an admin. In addition I added a family member as an admin and now it is really screwed up. Can not access one drive docs , my email .pst is locked out, my doc folder refuses to talk to me. Tried resetting the security settings and permissions. It works until the other user logs in and then she has the problems. She resets everything and then the problem comes back to me.

Also using IE as the default browser does not work right. Every webpage you open will ask you what browser to use. This is a pain.

Any help will be appreciated. Played with this for 2 days now

2052 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Had the same problem. I went to the highest level folder, accessed Properties and then the security tab and changed the permissions on the "home user" to allow full control. This seems to have solved the problem for me.

88 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also changed the security as suggested by Seneschal3601. It only works for the session you are in. If you shut down the machine, securities reset to not allowing you to create files or folders. 

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just went through support.microsoft.com after rolling back to Win 8.1 and discovered I still could not access or change my files without permission (from whom I not sure). We discovered 2 malicious files which were removed (used HitmanPro 3.7.9). the only thing I'd done prior to upgrading to Windows 10 was install SparkTrust PC cleaner - which said they were a Windows Partner. they are not. Scanned my computer and it said it removed all manner of files from registry etc., possibly my admin priv as well. Don't know for sure. Removed the program. Anyway, have reinstalled Win 10 on my desktop and now it works. Hope someone finds this useful.

Unfortunately when I signed into OneDrive (Win 10) on my desktop all the permission problems are back. Still looking for a solution, haven't resigned to bailing to Apple. (Meant this in jest).

 

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having this problem too (though it seems to only impact my library linked folders and any folders who are inheriting permissions from them). I'm using Windows 10, OneDrive 17.3.5907.0716.

There are a lot of threads about this problem around the net right now. Here are a couple of others on this site:

http://answers.microsoft.com/en-us/windows/forum/windows_10-security/how-do-i-change-folder-and-file-permissions/ba9ce914-5138-4155-a5a9-269c8cc1ccfc

http://answers.microsoft.com/en-us/onedrive/forum/odwork-odfiles/onedrive-resets-the-file-permissions-on-single/fe9025e1-af1a-4b4f-91a7-23560f3b1d3b

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Any reset/restart or a change in user will mangle the permissions again. This is frustrating.

Anybody have a problem using IE11 as the default browser? If I click on a link, it comes up with the dialog to select the browser. Checking always use this does not seem to work. E#very website not seen before asks the same question. My wife is ready to kill me for upgrading!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

System Builder, Power User, Gamer, Computer Geek
Windows 10 Pro 64-bit

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

http://answers.microsoft.com/en-us/windows/forum/windows_10-security/permissions-on-user-folders-after-win-10-upgrade/8b4c1806-061f-4a6f-950d-9d638f6a4695

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried that as well, but all of the security permissions kept resetting for me after each log on...nothing would "stick".
System Builder, Power User, Gamer, Computer Geek
Windows 10 Pro 64-bit

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have this issue on at least three machines I upgraded to Windows 10, two Windows 8.1 Pro and one Windows 7 Ultimate.

Looking at the particular error folder for my latest problem I see these permissions:

Administrators: Full control
SYSTEM: Full control
HomeUsers: Read & Execute

The owner of the folder is my current Microsoft account signon.

What's got me puzzled is that the current signon on the machine is an administrator, so it would seem to me that the user should have full control of the folder, but that's not the case.

Use the following procedure to fix this as long as you don't reboot your machine:

  1. Signon as an administrator on your machine.
  2. Navigate to the folder where you're having the problem, in my case D:\users\myname\Documents. Right-click and select Properties from the pop-up menu.
  3. Under Properties | Security tab, click the Advanced button, then click "Change" owner on the Advanced Security Settings dialog (if you are already the owner, do this step anyway!), and in the resulting dialog enter whatever you want the owner to be, in my case it's my Microsoft account).
  4. Now a new check-box appears labeled "Replace owner on subcontainers and objects"; check it.
  5. Also check the box at the bottom "Replace all child object permission entries with inheritable permission entries from this object."
  6. Make sure under the Permission entries grid that your current account has Full control (if not Edit or Add your account to be listed with foll control). Finally hit Apply. This may take a while.

If you don't follow the above Advanced procedure and just try to add permissions on the Security tab, you may get errors.

Kevin

89 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 4, 2020 Views 196,394 Applies to: