Windows 10 keeps changing the power saving settings behind my back

Hi

Every time the battery is getting low and I've manually switched off the screen on my laptop, Windows 10 will change the power settings behind my back.  I don't know why it does this.  All the drivers and software are up-to-date and everything else works fine.

This is how I've set the power settings, which I don't want changed:

___________________________________________________________________

This is what Windows 10 changes it to, behind my back:

Obviously a bug in Windows 10?  I don't want my screen powering off automatically or the laptop going to sleep too soon because I use this laptop on my TV, with the HDMI cable, for long periods of time.  If the battery gets too low, Windows is supposed to just hibernate the computer; earlier versions of Windows did just that.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

"Intel ready mode" has a quiet hours setting, and on my computer, it was set from 10 PM to 6 AM.  Once I disabled this setting, my computer is no longer going to sleep.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I that solved it. it has not repeated at least for now. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

"Intel ready mode" has a quiet hours setting, and on my computer, it was set from 10 PM to 6 AM.  Once I disabled this setting, my computer is no longer going to sleep.
my computer doesn't have Intel Ready Mode Technology.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've purchased a few new Dell computers since December 2017, all running Windows 10, all with slightly different processors/memory/drive configurations and one with 10 Home the others with 10 Pro, and EVERY UNIT had a similar problem. They, at various times, have the Power Options Power Plan changed without any user intervention to "Power Saver" where it puts the computer to sleep in very short order. This has been extremely frustrating, but I've found the problem and it is NOT a Microsoft issue... It's all related to INTEL READY MODE TECHNOLOGY

To solve the problem, I modified the Service "IRMTService" (Intel Ready Mode Technology) first by stopping the service and then setting it to "Startup type: Manual" so that the service is never started on bootup. On these newer Dell's BIOS, you can also go into the settings and disable Intel Ready Mode Technology at the BIOS level. 

This whole RMT is designed to allow your computer to share files while asleep... something I definitely do NOT need or want.

So, while many are blaming Microsoft for this problem... it is something out of their control, but they should definitely be aware of the culprit, as many newer computers have this so called "feature!"

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My computer does not seem to have that IRMTService but I definitely did have this problem. Oddly enough though the issue has just seemed to resolve itself on it's own. My computer has not reset the power settings once in the last 2 weeks.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It is not Win 10 on Dell XPS8930, it is Dell update. Noted a patttern in the replies. Dell was mentioned a lot.

Look at system log: Dell update performs power event and puts machine in sleep.

Mine did this local time 22:00.

Deinstall of Dell update should help. There are no relevant updates from Dell anyhow.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Even though IRMT was disabled, the service was still running.  I disabled it and this has been fixed ever since.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My computer does not have this IRMTService either, but it has this problem - with a twist. Not only does it automatically change the power settings, but upon sleep, it refuses to wake up again! This necessitates a hard reboot.

Needless to say, this is driving me nuts.

Dell Latitude

Windows 10 Enterprise 2016 LTSB

i5-7300U CPU @ 2.60 GHz

16 GB RAM

64 bit

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Check for IRMT at the following levels:

1) bios: boot the computer and enter the bios before windows boots. Go to the "Advanced" screen. There should be several "Intel" features depending upon your hardware configuration. On newer computers you'll find "Intel(R) Ready Mode Technology": Enable/Disable. I've disabled it on all of our new computers at the bios level.

2) Next, check to see if the software is installed. Normally it would be located here:

"C:\Program Files\Intel\Intel(R) Ready Mode Technology\IRMTModernUI.exe"

You can uninstall it from Settings, Apps & Features.

3) Launch the Task Manager, go to "Startup" tab and check for items published by Intel, look under (click the arrow next to) Delayed launcher and see if the program is being launched at startup. If so, delete that entry in Startup, 
then go to the "Services" tab, sort by name and look for (Name) "IRMTService", (Description) "Intel(R) Ready Mode Technology". This service should be stopped. To stop it and permanently disable it from launching, click the gear at the bottom of the Services tab "Open Services". Once all Services are opened, scroll down to "Intel(R) Ready Mode Technology", double click on it. In the General tab, next to "Startup type:" click and select: "Manual" and if it's running, press the Stop button. Click OK to save changes.
If you leave the software on your machine just make sure to a) stop it from starting every time the computer boots in the Task Manager "Startup" tab in Delayed launcher & 2) permanently force the service to "Startup type: Manual". That way you don't have to remove the software, but you stop it from launching on boot and force the service to manual. 

Also, BrianMcCarthy3, I've had a machine or two do the same as you have experienced... wouldn't wake up and had to do a hard reset.


Since disabling this service at the Bios and Windows Service level, although the software is still installed, I've never had a problem on these newer machines. I never let my computers sleep, as sometimes I've experienced problems with some software when the computer wakes up. This IRMT has been a real thorn in my side, but no longer!


8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for the help! I was able to disable something that looked like IRMT within the BIOS, but did not find the application or service within Windows 10. Fingers crossed!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated August 7, 2020 Views 36,505 Applies to: