"monitor off" detection moving windows to turned off monitors

I thought this "feature" was going to be fixed in Windows 10 but to my surprise not only is not fixed now is moving some of the windows to any turned off monitor. If I turn on the monitor where it was moved and turn it off it moves the window to the other turned off monitor... and never to the main monitor... It's REALLY frustrating and annoying.

I have 3 monitors, but I'm not using all of them so I have to turn some of them off. And no, I'm not going to turn them all on before I turn on the computer as I read somewhere (viva la tecnologia!!)... ¬¬

In Windows 8.1 I noticed that this "feature" was only happening when I installed the amd driver from the amd website. But now it seems Windows 10 uses a new version that have it always activated by default plus it's **** up... (the driver... or the "super real useful indesactivable feature").

In Windows 10 is working really weird, sometimes keeps the window in the turned off monitor but sometimes moves the window to the main monitor and sometimes moves the window to a turned off monitor.

So +1 to this incredible feature that have more than 5 years? and it's working great!

 

Question Info


Last updated October 25, 2019 Views 28,529 Applies to:

Hi Chazy,

Thank you for posting your query in Microsoft Community.

I understand the inconvenience you're going through and I regret the same.

You can fix the issue by disabling the "Auto-Detection" feature of your graphics card through the 'Advanced display properties' or from the 'Driver Management utility'. Since it is always on.

If you are unable to disable it, you can try installing the driver in compatibility mode and check if that helps.

Follow these steps to install the drivers in compatibility mode and check if that helps.

a. Download the driver from the manufacturer’s website.

b. Right-click on the driver setup file and click on ‘properties’.

c. Click on the ‘compatibility’ tab and check the box ‘Run this program in compatibility mode for’ and select Windows 8/8.1 operating system from the drop down menu and proceed with the installation. Once this is done, restart the computer and check if the issue persists.

For further assistance in this regard, please get in touch with AMD support team to fix the issue.

http://support.amd.com/en-us

Hope this will address your query.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry for the delay, I didn't get the notification since you edited instead of creating a new reply.

In the AMD Catalyst Control Center I find two options in Desktop Management -> Advanced Display Settings:

  • Detect whenever AMD Catalyst Control Center is opened
  • Use manual detection only (I must click the Detect Displays button)

The second one was the enabled... I tried changing but nothing.

And how can I start the Driver Management utility? I prefer the command name to open it.

Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Yashwanth, what are the steps to disable the Auto-Detection of my graphics card in Windows 10? I understand how to get to Advanced display properties and the Driver Management utility but don't have the steps beyond this.

Thanks, ryan

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Ryan,

Thank you for the update on the issue.

If you need to disable auto detection of the drivers then you may try the steps provided below and see if it helps.

  • Press Windows key+ X.
  • Click on System.
  • Click on Advanced System settings.
  • Select Hardware from the top navigation menu.
  • Click on Device Installation Settings.
  • Select No let me choose what to do.
  • Uncheck the box stating Automatically get the device app and info provided by your device manufacture

Do keep us updated about the status of your issue.

Regards,

Ramesh Kumar.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi I had similar issues, unfortunately nothing helped at the end with my AMD card.

You can use a hardware adapter called "MonitorDetectKiller" as a last resort which was inexpensive..

https://community.amd.com/thread/191221

It worked for me.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

 

Thank you for sharing your experience and resolution on Microsoft Community. We really appreciate your efforts and time which you spent on resolving the issue. This information shared by you will benefit other community members to solve their similar issues.

 

In addition to that, you are always welcome to post your queries on Microsoft Community forum. We'll be glad to assist you again.

Regards,

Ramesh Kumar.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have been pulling my hair out for months with my Triple 4K setup because every time the computer goes to sleep, the monitors get screwed up.  I finally found a program that allows you to manually override EDID info for your displays and force your desired resolution so the screens will always be setup correctly when you turn on the computer.  The program is also free.  

Check out Custom Resolution Utility

https://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU

Once you run it:

  1.  Disable all of the default "Established Resolutions"
  2.  Delete all of the default "Detailed Resolutions"
  3.  Delete all of the default "Standard Resolutions"
  4.  Add a new "Detailed Resolution"
  5.  Under new "Detailed Resolution" I left all of the settings the same except for the active horizontal and vertical pixel dimensions, which is obviously where you set your desired screen resolution.
  6.  Then repeat steps 1-5 for each monitor.
  7.  Once all monitors are configured properly, close CRU and run the restart.exe or restart64.exe included with CRU and you should be good to go!

I hope this helps other folks who are having similar issues to me with Windows 10 monitor auto detection and displayport connections.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Amazing, how many years later and even after the problematic Fall update that breaks anything within a country mile, this display issue persists? I mean how DUMB can Windows be to insist on displaying windows on a monitor that is POWERED OFF? I shouldn't have to change a darn thing to fix it (note that changing auto detect did nothing) - humans cannot see things on a monitor that is turned off. If you can, you're not human. Is Windows not for humans? Nevermind.

Worse yet, after I "lose" a bunch windows and turn on the 3rd monitor to find them, Windows does it's cutesy little chime and the missing windows pop back to the right monitor! Now where's the logic in that behavior?

Sheez

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I gave up with Windows 10 (back after I created this question) and went back to Linux full time. I'm currently running Manjaro Gnome (based on Arch Linux) and everything works great:

- No more monitor detection f4ck ups.
- No more hidden nasty stuff running on background 24/7 (well that may be an exaggeration but they deserve it).
- No more forced updates and restarts (linux takes just a minute to do a full update, max speed download, fast package updates, no more no less).
- No more telemetry, hidden telemetry, keyloggers, stealing of personal data (lots of encrypted packets going out when i have no programs running, wtf is windows sending outside!?).
- No more bullsh1t from Microsoft.

- These last years, Linux gained support from many triple A game engines so it's just a matter of time more devs start supporting it. When that happens, I see Windows loosing a great deal of market share.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The flip side of it is that it automatically moving them off a missing monitor trashes my desktop every morning.  When I wake my laptop up from standby it takes an extra second for my USB dock to wake up and turn the monitors on.  Despite my computer coming up at the lock screen that interval of 1 monitor attached is long enough to move all my apps to my laptop screen.  Once the dock is showing the monitors one of my external displays becomes primary and all the windows get moved to it.

They're clearly not getting everything right doing it automatically, but forcing it to either option won't always be right either.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.