Windows 10: prevent sleep mode from disconnecting wifi when copying files?

I have the latest Dell XPS 13 laptop with Windows 10 home.

I was copying some files from my desktop to my laptop via wifi (they're both connected to the same router) but noticed that, after about 5 minutes, the laptop would switch off the display and disconnect from wifi. I had to move the mouse every 4 minutes or so to prevent the laptop from going to sleep and losing wifi. I tried copying with both windoes explorer and teracopy, and the result is the same.

Is there a way to make sure the laptop doesn't disconnect from wifi if it is busy doing something over wifi, like copying files?

The network adapter is the Killer wireless 1535. In device manager, it has no option to prevent the PC from turning it off; not sure if this is to do with Windows 10 or with the driver, because I had always seen this option in Windows 7.

Moved from: Windows / Windows 10 / Network & internet / PC

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

We suggest that you change the power options of your laptop. Kindly follow these steps:

  1. Press Windows logo key on the keyboard, type Power Options and select the top most search result.
  2. Click on Change when the computer sleeps option from the left side panel of the window and click on Change advanced power settings.
  3. Expand Sleep>Sleep after and choose Never from the drop down bar.
  4. Click on Apply and OK after setting the time.
  5. Close the window and check if the changes are effective.

Keep us posted.

37 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, thank you, but it's not really an answer!

You are suggesting I don't let the laptop sleep, ever. Is the PC not smart enough to understand that it should not go to sleep when it is busy copying some files? Is that too much to ask?

Windows 7 had an option to set whether, in the power save settings, the PC could switch certain devices, like a wifi adapter, off or not. Is that option gone in Windows 10? Does it depend on Windows 10 or on the specific wifi adapter?

48 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To isolate the cause of this issue, we recommend running the Power Troubleshooter for Windows 10. Kindly follow these steps:

  1. Press Windows Key + X and click on Control Panel.
  2. Click on Troubleshooting.
  3. Click on View all.
  4. Click on Power and hit next to run the Power Troubleshooter.
  5. Follow the directions to complete the process.

Kindly restart the computer once it's done and check if the issue persists.

Let us know how it goes.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The troubleshooter didn't find any issues

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We recommend that you try the steps below to avoid disconnecting Wi-Fi when copying files.

  1. Press Windows Key + S, and type Network and Sharing Center.
  2. Click on the top result to open Network and Sharing Center.
  3. Click on Change adapter settings.
  4. Right click on Wireless Network Connection and select Properties.
  5. Click on the Configure button.
  6. Choose the Power Management tab.
  7. Uncheck the Allow the computer to turn off this device to save power.
  8. Restart your device and check if the issue persists.

We look forward to your response.

104 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Like I said in my post, there is no option to "Allow the computer to turn off this device to save power." That's the first thing I looked for. I accessed the setting from device manager rather than from the network and sharing centre, but it's the same setting window, and it does NOT have a power management tab. Not sure if this is something that was removed from Windows 10 9I am new to Windows 10, always used Win 7 until now) or if it's to do with the Killer wireless adapter in my Dell XPS laptop. By the way, the drivers are up to date.

If I click on the battery icon in the system tray, I notice there's a setting:

Network connection --> on battery power, stay connected to network while asleep.

It is enabled, but it does NOT work. I have verified that, after 4 minutes (the time it takes to go to sleep), the laptop disconnects from the wifi network, even if it was busy copying or downloading files. I have verified it accessing my router configuration page and double checking that the laptop was no longer connected, plus of course I verified the laptop stopped copying or downloading.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there,


Since the steps provided did not resolve the issue, let's run System File Checker and check if the issue persists.


Let us know how it goes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

One answer- Windows 10 did NOT drop the Power Management tab for devices.  It is still there. 

Have you tried going into your network adapter Properties in Device Manager, and selecting the Advanced tab, and find the Selective Suspend property and set it's Value to Disabled?

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi All,

I'm actually having exactly same issue. I'm doing alot of work using VPN-connections and it is really annoying that every time my laptop sleeps, Wifi connection disconnects causing VPN to drop and forcing me to reconnect VPN (and wait to required VPNs SMS-autentication).

So, let me re-frame the question as simply as i can; is there anyway to prevent WiFi-connection to drop when my laptop sleeps (WiFi adapter is Intel Dual Band Wireless-AC 7265).

In my opinion, there is no way to prevent this at WiFi adapter preperties.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm thinking a new generation of programmers is forgetting about basics in computing. How on earth is it possible that a pc cannot copy files when the screen is of (it doesn't even go into sleep!)?

Just look at this menu: A slider for Save me power (Turn of my network card )A Check box for Network connection but only on battery.

Exactly what is the idea behind this?

No use complaining, next "update" and you start the search again. This is the solution, the save power slider

34 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 27, 2020 Views 116,147 Applies to: