How do I stop Windows 10 from waking itself up from Sleep Mode?

I've had this problem back with Windows 8.1 but was able to fix it using the Device Manager. But I have tried just about everything in the Device Manager and unchecking the "Allow this device to wake my computer" but it still keeps waking up. In Windows 8.1, I could go to Command Prompt and use "powercgf -devicequery wake_armed" and it would tell me what woke it. But they removed that feature from Windows 10 because CMD Prompt says "powercfg is not recognized". This was a useful feature to have and now my computer keeps waking up for no reason and I can't figure out why. The keyboard and Mouse is disabled from waking up the computer.

Does anybody know how to find out what's waking it up and how to stop it in Windows 10?

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

ICC

1 person found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

this helped when I tried it for the first time last night..

I often would find my pc whirring away when I got up in the night or got up in the morning only to find it wasting electricity.

The waking pc made any savings from putting any tv, recorder etc to off instead of standy, pale into insignificance with this single multiple wattage waste of power!!!!!

We'll see how it goes to find out if it really has fixed the problem :)

Thanks for the tip anyway :)

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Mine was a media center update scheduled for 6:22 Am, why media center updates in Windows 10? Anyway hope that works

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

   powercfg -devicequery wake_armed

didn't work for me, but

   powercfg /DEVICEQUERY wake_armed

did.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

For anyone else having trouble with auto-wake in Windows 10, here's a big list of things to try. Some are reiterated from previous answers, but I thought it might be helpful to have some various info collected in one place.

See What's Allowed to Wake Your Computer
You can get a better idea of what's going on from a command prompt.

  • Open a command prompt with elevated privileges by right-clicking the Start menu button and selecting "Command Prompt (Admin)". Click "Yes" to confirm the action
  • From the prompt, type "powercfg /DEVICEQUERY wake_armed" for a list of devices that are allowed to wake your computer
  • Type "powercfg /LASTWAKE" to see what last woke your computer
  • Type "powercfg /WAKETIMERS" for a list of scheduled system services that may wake your computer. More about wake timers below

Turn Off Auto-Update, Auto-Restart, and LAN Broadcast
By default, Windows 10 is allowed to automatically check for updates, install them, and wake and restart your computer to do so.

  • Go to Settings > Network & Internet > Wi-Fi > Advanced Options and turn on "Set as metered connection". This prevents automatic updates since it tells Windows you're on a connection where there are extra fees for using too much bandwidth
  • In the same window, turn off "Find devices and content". This prevents other devices on your LAN from probing your computer and waking it for access
  • Go to Settings > Update and Security > Advanced Options and select "Notify to schedule restart" under "Choose how updates are installed". This prevents Windows from auto-restarting your computer to install any downloaded updates

Turn Off Device Wake
Wireless keyboards, mice, and network adapters can wake the computer up.


  • Open Device Manager, expand the Keyboards section, and double-click your keyboard's icon. Under Power Management, uncheck "Allow this device to wake the computer" (don't do this for wired keyboards)
  • Do the same for your mouse (only if wireless)
  • Do the same for any wired (Ethernet) and wireless adapters, especially any Realtek PCIe controller, unless you absolutely need Wake-On-LAN. Leave any other Bluetooth devices/controllers alone. Some have said that network adapters shouldn't wake the computer as long as "Wake Only for Magic Packets" is selected
  • While you're at it, update the drivers for your devices from this window

Note that this may or may not disable manual wake via wireless keyboards and mice, which is actually desirable in most cases (since otherwise you'd need to hit your computer's power button to wake it). Test things out by sleeping your computer and trying to wake it with a key press, mouse click, and mouse move. If you don't want manual activity to wake the computer, power off the keyboard and mouse with their power buttons.

Turn Off Wake Timers
Wake timers are scheduled system tasks that are allowed to wake your computer from sleep.

  • Open Settings > System > Power & Sleep > Additional Power Settings > Change Plan Settings > Change Advanced Power Settings
  • Under "Allow Wake Timers", select "Important Wake Timers Only" (or "Disable", but this may have unwanted effects like disabling user-scheduled wakes or alarms)
  • If you want more granular control over individual timers, open Task Scheduler and edit the appropriate items, de-selecting "Wake the computer to run this task". A common culprit is Microsoft\Windows\UpdateOrchestrator\Reboot

Uninstall TeamViewer
Some versions of TeamViewer ignore the system wake timer settings. Removing it or updating to the latest version may help disable auto-wake. If you've recently installed similar third-party software that makes use of a network connection in the background, you can try temporarily disabling or uninstalling it.

48 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated August 12, 2021 Views 36,993 Applies to: