windows task wakes up computer

Hello,

windows task wakes up my computer.

I delete it and it comes back every week.

Even if I modify the task, it reverts to normal after approx 1 week

1) how to remove it?

2) what is it for?

Name: shell
Location: \Microsoft\Windows\rempl
Trigger: daily -> at 10:00 every day
Action: start a program -> %ProgramFiles%\rempl\remsh.exe
Wake up the computer to run this task

---

***Post moved by the moderator to the appropriate forum category.***

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

A third-party program conflict can be the reason for this error. For us to identify the next step to take, we would like to ask the following questions:

  • Can you provide a screenshot of the application that you’re using to delete the task?
  • What is the build and version of Windows that you’re using? To check, type winver in the Search box and send us a screenshot of the information window.
  • If any, what error message did you receive?
  • Have you made any recent changes before you encountered this issue?
  • What troubleshooting steps have you done so far to resolve your concern?

We look forward to your response.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Remsh.exe is connected with this update:

https://support.microsoft.com/en-hk/help/4023057/update-to-windows-10-versions-1507-1511-and-1607-for-update-reliabilit

Expand x86 or x64 according to what your system is.

After remsh.exe installed I had update service enabled again and received the new update (November Update for my build 1511). Imho remsh.exe and the recent 3 updates for the mentioned builds are connected.

Remsh.exe works from hours eating usage of my PC. I wanna know how to disable it too.

PS. I have KB4023057 installed in my Programs and Features alongside with Windows 10 Update and privacy settings. Does it mean remsh can be uninstalled from here and Privacy Settings too?

Reason over delusions

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I disabled it and it's triggers from Task Scheduler. Also checked the option to start only on idle PC (mine is rarely idle ;)).
Reason over delusions

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

windows 10
1511 (10586.1106)

This is the task:

This is the task code, exported in xml:

<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.4" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <URI>\Microsoft\Windows\rempl\shell</URI>
    <SecurityDescriptor>D:(A;;GA;;;SY)(A;;FRFX;;;LS)(A;;FRFX;;;BA)</SecurityDescriptor>
  </RegistrationInfo>
  <Triggers>
    <CalendarTrigger>
      <StartBoundary>2017-04-24T10:00:00</StartBoundary>
      <Enabled>true</Enabled>
      <RandomDelay>PT1H</RandomDelay>
      <ScheduleByDay>
        <DaysInterval>1</DaysInterval>
      </ScheduleByDay>
    </CalendarTrigger>
    <RegistrationTrigger>
      <Enabled>true</Enabled>
      <Delay>PT10M</Delay>
    </RegistrationTrigger>
  </Triggers>
  <Principals>
    <Principal id="LocalSystem">
      <UserId>S-1-5-18</UserId>
      <RunLevel>HighestAvailable</RunLevel>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>true</AllowHardTerminate>
    <StartWhenAvailable>true</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>true</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <DisallowStartOnRemoteAppSession>false</DisallowStartOnRemoteAppSession>
    <UseUnifiedSchedulingEngine>true</UseUnifiedSchedulingEngine>
    <WakeToRun>true</WakeToRun>
    <ExecutionTimeLimit>PT72H</ExecutionTimeLimit>
    <Priority>7</Priority>
  </Settings>
  <Actions Context="LocalSystem">
    <Exec>
      <Command>%ProgramFiles%\rempl\remsh.exe</Command>
    </Exec>
  </Actions>
</Task>

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

We appreciate the information you provided. It's possible that you're unable to delete this task permanently due to an outdated operating system. We suggest installing the latest updates for Windows 10 by following these steps:

  1. Click Start.
  2. Go to Settings.
  3. Click Update & Security.
  4. Click Check for Updates.

If your computer supports it, you may be able to update to the latest build, which is Version 1703 Build 15063.632. If your computer doesn't support the Creators Update, then the latest version you could get would be Version 1607 Build 14393.1737.

Let us know if you're able to permanently delete this task after installing the latest Windows 10 updates.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My build is the same and I disabled both tasks in rempl. Now my CPU is at 1-2% as it was before rempl install lasr month and before the November Update (for our 1511 build). I disabled all tasks related to Custom Experience too.
Reason over delusions

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there, I have the same issue as the op. My Windows 10 install shows version

Version 1607 Build 14393.1770

My screenshot looks same as OP - every day at 10am, my computer suddenly awakes from Hibernate state and when I look at active tasks, the only one I see scheduled for 10am is rempl one.

Under Conditions tab, it shows "Wake the computer to run this task" as CHECKED in gray (so I cannot seem to uncheck it?). It's in gray even if I run Task Scheduler as Administrator.

What's the reason for this task? Why does it have to wake my PC? How do I unckeck waking up PC?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry, to answer part of my own question, while the option is grayed out in the bottom pane, I found I can edit it but right clicking on the item in the top pane and clicking on Properties. So, I am able to uncheck "Wake the computer to run this task", but I still have remaining questions:

- what does this do?

- why does it (apparently by default) want to wake up my PC automatically?

- Should I disable ALL (even so called "important") auto-wake up timers? What's a potential downside?

Apparently this can be done via:  Control Panel -> Power Options -> Edit Plan Settings -> Change advanced power settings -> Sleep -> Allow wake timers -> Disable

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Justin,

Some services and software have maintenance or update tasks that need to perform regularly. To do this, users can set a specific time frame for these processes to activate. This can range from a monthly task to something done every day at a specific time. By using the scheduling features Windows has, developers can ensure that their apps keep themselves maintained.

While this functionality may be useful for some users, there’s an option within Windows to shut off all wake timer functionality altogether. This will stop any current and future wake timers from booting up your PC without your permission.

If you have further questions, feel free to get back to us.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Aileen, thank you for your response. I am still unclear on following 4 questions though:

- what does rempl/shell.exe task specifically do? What does this specific task maintain?

- Does it want to wake up and do something only on my environment or ALL Windows users will have this task waking up their PC daily at 10am?

- Hibernate mode does not seem very useful if we know the PC will be awake within a day. It does not shut down or go back to hibernate afterwards from my experience. Is this right?

- More generally, if I disable timers, would the rempl/shell.exe maintenance still be automatically performed? Just later when I am actually logged in? If I want my PC mostly be in hibernate mode and use it rarely, is there any downsides from disabling all timers (even "Important Wake Timers")?

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 7, 2019 Views 16,653 Applies to: