Windows Mail client either spits out error "0x800706be" or loads forever when trying to add a new account.

Forgive me if I've put this in the wrong topic, I couldn't find one more fitting. 

To start off, thanks for reading this and helping if you do. 

I have a gmail account that I have had on my windows 10 mail app for a long time and it works perfectly. However, I tried to add my old (but still very much needed) iCloud email account to the app many times with no success. I've tried using the default "iCloud" preset and also customizing the servers and ports myself to what I've found online. I've used my regular password and the app-specific password apple provides for accounts with two factor auth enabled. I've tried reinstalling with powershell. I've tried rebooting. I've tried running a core file check with SFC and it comes out clean. However, I don't think any of these things are close to solving the real problem. When I look up this error code I find some forum posts (I've tried everything) but mostly ads for sketchy "registry cleaners," which is quite frustrating. If the registry is even the problem, I've found no instructions on what I could do manually with regedit (I'm not downloading and running some weird exe that is supposed to "fix all error messages").

Thanks so much for all your help and time reading this post. Hopefully this gets solved and can help anyone out there in the same predicament. Cheers.

 

Question Info


Last updated January 30, 2018 Views 929 Applies to:
Answer
Answer
I found a solution : open the CONTACT app, and add your icloud account .

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.