Windows 10 high cpu usage by "Music Application"

I noticed the last few days that my computer was slowing way down at times. I looked under Task Manager > Processes > and it's always "Music Application" using 40-70% of the CPU. I follow this to Details and it is "Music.UI.exe" I never play music on my pc but I do have music on it to access from the home theater. This just started about 5 days or so ago. I switched my default music app to Windows Media Player but that does not help. I can "end task" and it stops for a few minutes to a few hrs but always comes back on. The only updates I can find have nothing to do with the music player and were simply cumulative, malicious software removal and Adobe Flash updates but I don't know enough to say if it could or could not be one of them. It has gone as far as to lock the system up requiring a wait of 3-5 minutes before ctrl+alt+del brings up the troubleshooter screen to use task manager. I thought about uninstalling Groove Music but do not think it would help and couldn't anyway without using cmd prompt or PowerShell. I couldn't find any other threads about this but if someone knows of one please point me in the right direction. Thank you in advance
 

Question Info


Last updated December 5, 2018 Views 9,494 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

Are you referring to Groove App in Windows 10?

 

If you’re referring to Groove app then you may face this kind of issue due to Software conflict or app corruption.

I suggest you to place you system in clean boot state and check if the issue persist.

A clean boot is performed to start Windows by using a minimal set of drivers and startup programs. This helps eliminate software conflicts that occur when you install a program or an update or when you run a program. Follow the below mentioned steps to perform Clean Boot:

 

a. Press Windows Key, type msconfig in the search box, and hit Enter.

b. On the Services tab of the System Configuration dialog box, tap or click to select the Hide all Microsoft services check box, and then tap or click Disable all.

c. On the Startup tab of the System Configuration dialog box, tap or click Open Task Manager.

d. On the Startup tab in Task Manager, for each startup item, select the item and then click Disable.

e. Close Task Manager.

f. On the Startup tab of the System Configuration dialog box, tap or click OK, and then restart the computer. Once you reboot your PC experience if any difference in performance.

 

Now it indicates that some other services are causing the issues. I suggest you turn on 5 services at a time which are disabled before, reboot and then see if the problem reappears, keep repeating this until you find a group of 5 services, which are causing this issue, then check the one by one, till you find the one which is causing your issue. Perform the same divide and apply for Startup's too.

 

Refer the below article on "How to Perform Clean Boot". As the article is designed for Windows 8.1, Windows 8 and Windows 7. Unlike launching step for 'System Configuration', options and steps to Clean Boot are same for Windows 10.

 

Note: After you finish troubleshooting, refer "How to reset the computer to start normally after clean boot troubleshooting" from the same article.

 

Do ensure that your PC is up to date with Windows Update. Go to Start Button/>Settings/>Update & Security/> Windows Update and click Check Updates.

 

Keep us posted if you require further assistance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

WT...?... my computer is going nuts and all I'm doing is writing this note. really is this what Microsoft is up to these days using my computer and a **** load of my bandwidth for your own agenda, how is anyone in the world supposed to make use of their computers if your **** with it so much.. and That politely said. if I were to get mad I'd send a witch with all it's hexes and that would not be polite at all..!! look at this machine bandwidth running a muck will you ... you know who I am I've been her fr 30 plus year, I haven't got time for the rubbish I too busy designing and global transport system to be inaugurated 2050 KLEIJbykleij .......................

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

A pitiful response from a pitiful, broken corporate organisation.

Every aspect of your platform from Phones to PC Op/Sys to the Surface are now broken in one way or another. God knows I have tried...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is an awful choice of resolution. As long as Microsoft wishes to keep Windows proprietary, take responsibility for creating useful fixes that automate a process like this, which I know can be accomplished. How about you do your job and actually engineer a solution to this problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Settings ->    Privacy ->    Background Aps:

Turn OFF Groove Music and any other little used applications

85 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don tmind testing windows 10 for Microsoft its fun and I learn thingd,but there getting too much into my personal life and it bugs me to no end I don't need a machine to ask me anything or do what it thinks is best. I just want a reliable system I can access the web from any of my machine without homegroups or such and I defiantly want a button to turn off all the services when I'm playing a game online.

100%  use on one core???? music.ui.exe as well as other services is costing me games and money,and that should not be what this company becomes know for.
brian goguen

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

JoeMaine great tip to turn off Groove Music in Background Apps and i have done this.

I have another suggestion for those that don't want to do this. I got the problem of Music.UI.exe continuous cpu usage after the very 1st time i started Groove Music (accidently clicked on an mp3 and default music app started) but i closed the program after only about a minute cos i decided i didnt want to use it as i prefer another music player. In Taskmanager I noticed that Music.UI.exe kept running even though i had closed Groove Music so i terminated the process manually and rebooted my pc.
After reboot i saw Music.UI.exe process usineg cpu even though i hadn't even started Groove Music so again i terminated the process manually in Taskmanager.
I had a thought that because i originally closed Groove Music down after only about minute the 1st time i used it that it might have been trying to do some initial setup and it may not have completed. I decided to start Groove Music and of course Music.UI.exe was loaded and using 10-20% cpu so i just left running for a few minutes and after a while it remained loaded but not using any cpu and as soon as i closed Groove Music the process was also terminated. So Groove Music and process Music.UI.exe are now running ok.
My OS is latest (Oct2016 updates) Win10 Home 1607 64bit on Dell Inspiron 15R laptop, intel i7, 8GB Ram.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What I want and what i get is getting farther and farther apart.If I play a game online I dont need a machine asking me or tying up my cpu til the very reason i'm on it  wont work.Sure for many they like the helpful hints ands all but i'm old school you want something you assk you dont assume anything and that what windows is becoming,services after services,its to the point that i just turn them off completely, and I would have revo ininstaller do its thing if i could find it,i am that upset right nows there is know way the avg user can be sure if the file or service it critical to the system till you delete it or turn it off and thats just plain wrong. its bad enough the gov want to play "Big Brother" I really dont need a company trying to do the same. **** I cant even keep the damn sysnic form putting both desktops on my machines the same. I put them on there for a reason its getting to the point the system software is more harmful to my physical and mental well being than any of the viruses on the net

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I got rid of this annoyance by Uninstalling the Zune software.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So did I.... really annoying !!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.