Windows 10 Creators Update - can no longer Run as Administrator

Hi,

I recently updated my main Windows 10 PC to Creators Update. Since then, "Run as Administrator" no longer works for most programs. It always worked previously in the Anniversary Update.

Details:

I am the sole user of this PC, and my account has Administrator privileges.

If I press the Windows key and start typing the name of a program, e.g. "Command" or "cmd" (for Command Prompt), and right-click on it in the search results, "Run as Administrator" appears as one of the options. But choosing "Run as Administrator" does absolutely nothing. There is no UAC prompt, and the program does not launch at all. I've also tried using Shift-Ctrl-Enter on the search result, which should do the same thing as "Run as Administrator", but get the same result, e.g. nothing.

Same thing goes for Windows Powershell, and ANY other programs for which "Run as Administrator" is an option. These programs DO run if I attempt to launch them normally (without "Run as Administrator"), just not with elevated rights.

The problem also happens when I browse through the Start Menu, right-click a program, and choose "More > Run as Administrator" from the context menu. And, it happens right-clicking ANY program shortcut, on the Desktop or anywhere on the system.

Now, I CAN get a program to run as Administrator IF I right-click a shortcut to it, select Properties, Shortcut tab, Advanced, and check "Run as Administrator" (and click on all the "Okay" buttons to save the change). THEN, double-clicking the shortcut will give me a UAC prompt, and if I click yes, launches the program with elevated rights.  I can also locate the actual .exe file on disk, right-click and choose "Run as Administrator", and it will work as expected. But the first workaround would require me to create additional shortcuts for every program which I might want to run elevated, and the second is too cumbersome to do on a regular basis.

A possibly-related problem is that on the Quick Access menu (right-click on the Start button), most of the tools will not launch. This includes Event Viewer, Device Manager, Disk Management, Computer Management, Command Prompt, Command Prompt (Admin), Task Manager, and File Explorer. (all the ones which ultimately open Settings pages, on the other hand, DO work.)

In order to try fixing this, I've tried "sfc /scannow" (which finds no integrity violations), "DISM /Online /Cleanup-Image /RestoreHealth" (which also finds nothing wrong), disabling UAC (no effect). I've also tried making a new user account with admin rights, but it had the same problem. I've even gone so far as to do a "repair install" of Windows 10 from a Creators Update ISO image, following this tutorial (https://www.tenforums.com/tutorials/16397-repair-install-windows-10-place-upgrade.html). Again, no dice.

I've seen posts from other users who have the same or similar problems with Creators Update. In particular, this post is nearly identical to the problem I'm having.

Creators Update has otherwise been working well, but this one issue is really annoying to a power user like me. Please help.

 

Question Info


Last updated September 24, 2019 Views 2,543 Applies to:
Answer
Answer

Actually, I discovered that the problem was caused by a shell extension installed along with one of my major application programs. Disabling this extension cleared up the "Run as Administrator" issue AND the non-functional Quick Access menu. Apparently, the upgrade to Creators Update munged up this extension, and it was interfering with the normal shell functions. (I was able to re-enable the extension afterwards, which must have properly re-registered it, as everything still worked afterwards.)

If anyone else has this problem, I recommend getting the tool ShellExView and use it to find the troublesome shell extension. Basically, you check the "Options/Hide all Microsoft extensions" setting, then sort by the Type column so all Context Menu items are grouped together. Then, it's a matter of disabling them in small groups, then restarting the PC and testing, until you find the extension causing the problem.

Shell extensions can do so many useful things, but sometimes they break. *shrug*

Aimhere

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.