System time always drops back 2 hours

I have seen several users have time changing or corruption issues but my problem adds another 'weird' happening to them.

My wife uses Windows 10 on a ThinkPad T420. Even after repeatedly setting the correct time (date, time-zone and time-server settings remain unchanged and set correctly) a few days later the displayed time always drops back  'exactly' two hours.

Here is some more appropriate information: My wife uses German Windows 10 (she is German and we live in Germany) and she has always had this time problem even some years ago when she was using German Windows XP Home Edition running in a dual-core desktop PC. I upgraded her machine to a Dell Inspiron laptop freshly installing her XP Home OS and moving all her data across to it. Exactly the same time problem appeared. The ThinkPad T420 is her latest hardware which came with Windows 7 and was upgraded to Windows 10. The same time problem remains.

Here is the next strange behaviour: I still have my old Windows XP Professional (English) on a four-core desktop PC. I also have Windows XP Professional (English) on an old Lenovo N3000 laptop. Neither have ever had any time changing problems. However, impressed with the wife's T420, I also bought one and it came with German Windows 7 which was also upgraded to Windows 10. This too has the same time changing problem.

I am a Linux user and on all of my hardware (therefore multi-OS) under Linux or Windows I have never had any time changing problems. It seems that if the Windows is a German problem then the time is puched back two hours.

I have checked all timer and time-server settings being the same used on my English Windows XP systems. I have followed an article regarding recommended Min-/Max- Pos-/Neg- offset settings in the registry for WTime32 config values. I discovered an article suggesting a BIOS update had repaired someone's dissimilar time problem. I have just applied an update for our T420s BIOS (ver. 1.46 raised to 1.48). Bear in mind the older XP hardware would have been completely different.

Has anyone any ideas as this is driving me nuts!

 

Question Info


Last updated November 9, 2018 Views 1,403 Applies to:

Hi Peter,

I will certainly help with the issue you are facing with time settings.

I appreciate your efforts in resolving the issue.

I would like to have more understanding with the issue and would appreciate if you could provide the following details so that we can assist you better:

  1. Are you logging in with a Microsoft account or a local account?

  2. Is the time and time-zone set automatic or manual? If automatic, then I suggest to change it to manual and observe the behavior.

Please get back to us with the report to assist further.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Meghana,

Many thanks for your quick response.

I am logging in via my Microsoft [live] account. It is my first time using a Microsoft account and using this forum.

I will try switching to manual but I would like to wait a couple of days before checking Windows time as I have only just updated the BIOS as a possible remedy.

One thing I have not yet determined is if the BIOS time is changed too. I will note BIOS time first before booting into Windows.

When I do correct the Windows time I do this in my administrator account and then via the time-date settings available under the control panel.

I am not expecting any change to the problem from the BIOS update and a pattern appears to be that the Windows left totally shut down for a few days. This seems to be the case for both my wife's and my hardware.

I largely use Linux (Ubuntu) in between the rare occasions when I would need Windows. Whether I use Linux or not in the meantime appears to have no effect on the Windows time problem.

Get back to you again soon.

Peter

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Peter,

 

Contact the BIOS manufacturer to guide you appropriately in updating, modifying or making any changes in BIOS to prevent any incorrect settings which might result in an unresponsive computer.

 

Disclaimer: Modifying BIOS/complementary metal oxide semiconductor (CMOS) settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of BIOS/CMOS settings can be solved. Modifications of the settings are at your own risk. 

 

Write to us with the status of the issue experienced on the computer for further assistance. Your reply is most important for us to ensure we assist you accordingly.

 

Thank you.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Today (15th Aug), I booted my T420 into Windows 10 but before doing so I checked the BIOS time. The BIOS time had again fallen back exactly 2 hours. Without making any change to the BIOS I re-booted to bring up Windows 10. Its system time was 2 hours behind.

My laptop is multi-OS (Linux/Windows) using Grub2 as the boot manager. Grub2 had shown the correct local time.

I selected new start under Windows 10 without making time changes and re-booted. The BIOS time still showed 2 hours behind.

I restarted again from within the BIOS by selecting 'discard changes' (therefore not by powering of then on) and booted into Linux (default under Grub2 for my machine). Linux showed the correct local time.

I chose re-start under Linux and checked BIOS time and it was still left at 2 hours behind. I presume Linux therefore does not alter the BIOS time.

If I may answer here to Lihitha's reply about BIOS settings:

My ThinkPad T420 BIOS is UEFI BIOS 83ET78WW (1.48) of date 2016-01-21 and which I had updated just 5 days ago. This update has no effect on the time changing problem.

The BIOS Date-Time settings has its 'own tab' in the BIOS settings and offers adjustment to time and date only. No other options or features appear available with anything to do with time settings.

From my experience with Windows and Linux, the former also sets the BIOS time and date when timer settings under Windows are made and under Linux perhaps no changes to the BIOS time and date settings are made.

Please consider that this strange time-change behaviour has occurred with three entirely different hardware platforms: a 'hybrid' (self-built desktop running Windows Home XP; a Dell Inspiron laptop running German Windows XP and an IBM ThinkPad T420 laptop running German Windows 10 (upgraded from Windows 7). All had an entirely different BIOS.

In further reply to Meghana's suggestion:

Now that it is established that the BIOS update has made no effect I can now set the Windows time-setting to 'manual' as requested. Tie will then be checked again but in some days time.

(PS. I am assuming 'manual' means disable (uncheck) the 'sync with time-server' box?)

I will report on the 'manual test' in a few days time!

I am astonished that having had the machine of for a few days and before booting the OS the BIOS time when checked shows 2 hours back - how??? Have all three entirely different platforms had the 'same' fault across the three different BIOSs??? Crazy!!

Thanks for everyone's patience.

Peter

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Meghana,

In reply to point 2 your post August 11, 2016: All our devices using Windows were enabled to automatically synchronise.

As per your suggestion I disabled the auto-sync setting of time on my ThinkPad T420 but after forcing a synchronisation to ensure the correct time (local for me is time-zone Berlin, GMT+1) After a few days I checked the time. On checking BIOS time first (before booting any OS) it had again become exactly 2 hours behind. On re-booting into German Windows 10 the time was the same as per the BIOS time. The 'manual' (non-sync) time setting remained in force.

I cannot explain why the BIOS time should change (without booting into Windows??) but up until now I had believed this time-change behaviour was not appearing on my old English Windows XP desktop system. However, the other day when booting up the Windows XP system and automatically logging into my own admin' account I just managed to see the time leap up by 2 hours I guess due to the time auto-sync. Given previous experience on my wife's previous German Windows XP Home systems and her current Windows 10 laptop my immediate thought is the German Windows is not actually performing time auto-sync when set to do so(?)

The fact that I might now have had three entirely different hardware platforms running mixed language and versions of Windows that seem to have their BIOS times turned back 2 hours apparently even when they are turned off (powered down) is utterly puzzling!!

All these system connect via LAN cable either directly to the router-modem or via a switcher. I will disconnect the LAN cable to my T420 and see what happens to the BIOS time.

Peter

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry for my delayed update - it's summer time and that means holidays, travel, visiting families etc.

Okay, after searching around the web on similar problems I have reached the conclusion that by having a dual-boot (Linux and Windows) system then one meets the different ways in how BIOS time is managed. Windows uses BIOS time to hold 'local' time (UTC+offset+daylight savings according to the time zone used) and Linux uses BIOS time to hold Universal Time (UTC).This for me explains why I get this exact 2-hour difference which will no doubt become 1-hour when clocks move back again in October.

My wife's PC is purely a Windows 10 machine but I do sometimes use to boot up from a Linux external drive. This must be the explanation of 'why' she suffers from time to time with this '2-hour' shift!

Following various arguments and suggestions elsewhere on the internet I modified Windows 10 Registry to tell Windows to use BIOS time for Universal Time. (Danger: an installed Windows OS can be catastrophically made inoperable if specific content in its registry is wrongly modified in any way).

I can now run one OS then re-boot into the other and irrespective of the boot-up order both OSs now show the same 'local time' (both being set of course to the same time zone/location/daylight savings info etc.)

I believe that both our both German Windows 10 for some reason were not and possibly never were (even before the above said registry mod) auto synchronising! Yet my two English XP systems do?? This, I guess, was why I momentarily observed my desktop XP quickly changing from 2-hours behind to correct local time because autsync had correct it.

Some people elsewhere have also had problems with time-synchronising not running so I followed a suggestion to add a scheduled task (only applied to our German Windows 10 systems) that calls an time-autosync at start-up. These machines now behave like my English XP boxes.

As my time difference problem is resolved I would like to consider this thread as solved but remain open to receiving any further posts for a short term.

Peter

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.