Missing VCOMP140.DLL

My computer has a Windows 10 64-bit operating system. When I went to use Media Go to change some music files on my model NWZE385 Walkman, it initially let me delete some albums from the Walkman but suddenly notified me of an upgrade to Media Go 3.1 which I downloaded. As soon as Media Go tried to reopen, an error message saying "The program can't start because VCOMP140.DLL is missing from your computer. Try reinstalling the program to fix the problem". I spent about 1 1/2 hours on the Sony online chat support with no solution offered other than reinstall, which I have tried almost a dozen times to no avail. I also tried e-mailing Sony support only to have get a recommendation from Sony eSupport to try using the Microsoft Windows Media Player, which it turns out is not compatible with Windows 10.

I have no idea why the VCOMP140.DLL file would be missing from my operating system, and I have no idea how to recover the file since I do not want to utilize one of those third-party file recovery services since I can probably buy a new Walkman for what those services cost.

Does anyone out there know how I can recover the missing VCOMP140.DLL file and reinstall it on my computer?

Thanks in advance!

 

Question Info


Last updated October 20, 2019 Views 90,474 Applies to:
Answer
Answer

My thanks to everyone who offered possible solutions to the problem of using Media Go with Windows 10, but I was able to find a fairly simple solution to the problem. I guess perseverance pays off. Here is what I did.

Before doing anything, make sure to uninstall Media Go from the Programs and Features in the Control Panel. Go to Microsoft website and download the Visual C++ Redistributable for Visual Studio 2015 from https://www.microsoft.com/en-ca/download/details.aspx?id=48145. You are going to want to select both ‘vc_redist.x64.exe’ and ‘vc_redist.x86.exe’ files to download. Once the files are downloaded, restart the computer as prompted. After restarting the computer, go to the Media Go website http://mediago.sony.com/enu/download and download Media Go. I selected the “Save and Run” option and downloaded Media Go normally. If you should get a warning saying something about “the certificate is invalid or corrupt”, right click and select “run anyway”. Media Go should now load up and function as intended.

I hope this helps anyone who has the same problem I had.

249 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.