(SOLVED) Memory Management/Page fault in nonpaged area BSOD on Startup

I got PAGE_FAULT_IN_NONPAGED_AREA blue screen error today after I updated my BIOS to Version 01.05.00, A04, Release date 18.1.2016 (Link to details page of the driver).And my laptop is Dell Inspiron 7359 2-in-1. 

And then I booted from a USB with windows(setup) I got blue screen with error MEMORY_MANAGEMENT

After few restarts I got to Windows Recovery screen, I had no restore points so I picked Startup repair, it ran for like 30 mins and said 

it failed. When I restarted again after windows loading screen there was a blue flash and system restarted and it started worked fine.

Just out of curiosity I booted back into USB, it still shows the Blue Screen with MEMORY_MANAGEMENT.

and then when I booted back to my working system it showed PAGE_FAULT_IN_NONPAGED_AREA blue screen again!

after a restart it's started working fine. Now I'm afraid to boot to USB again

here is my system info created by msinfo32.exe : Link to Google Drive file(Google think its and audio file)

Only Memory dump file I have :  Being uploaded 86.7 MB after compressing

HISTORY :

Reason for me to update BIOS was that I can't boot to any (USB)Linux distributions I have  (ubuntu-12.04.2-desktop-i386 & KNOPPIX_V7.2.0CD-2013-06-16-EN ). (can boot to Ubuntu using Oracle VM VirtualBox but it's really slow. KNOPPIX run faster but I can't share files with it)

When I boot from Ubuntu I get  "piix4_smbus  SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr" on VirtualBox and form USB(not exactly sure cant remember)

 video with exact error with kind of no solution



When I boot from KNOPPIX I get "Failed to execute /init
                                                             Kernel panic - not syncing: no working init found.

                                                                     See linux documentation/init.txt for guidance."

After updating BIOS I booted to KNOPPIX(USB)(before booting to windows). And it went further than before into booting but 

gave a black screen last, so I rebooted to KNOPPIX and same old Kernal Panic comes.

So I gave up and booted to Windows which gave me a PAGE_FAULT_IN_NONPAGED_AREA blue screen. 

THANK YOU

Answer
Answer
Thanks for the help I just had to reinstall my windows  UEFI method. It seems my firmware have buggy legacy support(BIOS), I think.  When I'm using UEFI method to boot Ubuntu new version there are no kernal panics. Everything runs smoothly. 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 4, 2020 Views 3,770 Applies to: